summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-04 17:58:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-01-04 17:58:28 +0000
commit27b3d69c09e08e24caf8e9e2f1ecb15660a679af (patch)
treee6a3efbbfc05c958f5cf9451f5c48a710440f39d /media-libs/libdts
parentmark ~ppc (bug #112207) (diff)
downloadgentoo-2-27b3d69c09e08e24caf8e9e2f1ecb15660a679af.tar.gz
gentoo-2-27b3d69c09e08e24caf8e9e2f1ecb15660a679af.tar.bz2
gentoo-2-27b3d69c09e08e24caf8e9e2f1ecb15660a679af.zip
Improve patch to make sure it always builds with PIC version also on x86.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-libs/libdts')
-rw-r--r--media-libs/libdts/ChangeLog8
-rw-r--r--media-libs/libdts/files/libdts-0.0.2-libtool.patch54
2 files changed, 29 insertions, 33 deletions
diff --git a/media-libs/libdts/ChangeLog b/media-libs/libdts/ChangeLog
index 76073e71a464..d8315df0e94e 100644
--- a/media-libs/libdts/ChangeLog
+++ b/media-libs/libdts/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libdts
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdts/ChangeLog,v 1.24 2005/11/25 00:59:37 flameeyes Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdts/ChangeLog,v 1.25 2006/01/04 17:58:28 flameeyes Exp $
+
+ 04 Jan 2006; Diego Pettenò <flameeyes@gentoo.org>
+ files/libdts-0.0.2-libtool.patch:
+ Improve patch to make sure it always builds with PIC version also on x86.
25 Nov 2005; Diego Pettenò <flameeyes@gentoo.org>
files/libdts-0.0.2-libtool.patch, -files/libdts-0.0.2-libtool2.patch,
diff --git a/media-libs/libdts/files/libdts-0.0.2-libtool.patch b/media-libs/libdts/files/libdts-0.0.2-libtool.patch
index ed784b4556b3..c6e26c5ea7e1 100644
--- a/media-libs/libdts/files/libdts-0.0.2-libtool.patch
+++ b/media-libs/libdts/files/libdts-0.0.2-libtool.patch
@@ -2,7 +2,7 @@ Index: libdts-0.0.2/configure.ac
===================================================================
--- libdts-0.0.2.orig/configure.ac
+++ libdts-0.0.2/configure.ac
-@@ -77,22 +77,22 @@ else
+@@ -77,22 +77,8 @@ else
esac
fi
@@ -10,12 +10,8 @@ Index: libdts-0.0.2/configure.ac
-#libtool# AC_DISABLE_SHARED
-#libtool# AC_LIBTOOL_WIN32_DLL
-#libtool# AC_PROG_LIBTOOL
-+dnl Checks for libtool - this must be done after we set cflags
-+#AC_DISABLE_SHARED
-+AC_LIBTOOL_WIN32_DLL
-+AC_PROG_LIBTOOL
-
- dnl Build the PIC library? - to be removed once libtool is re-enabled
+-
+-dnl Build the PIC library? - to be removed once libtool is re-enabled
-AC_PROG_RANLIB
-case "${target_os}" in
- *mingw32* | *cygwin* | *djgpp*)
@@ -26,16 +22,8 @@ Index: libdts-0.0.2/configure.ac
- ;;
-esac
-AM_CONDITIONAL(NEED_PIC, ${NEED_PIC})
-+#AC_PROG_RANLIB
-+#case "${target_os}" in
-+# *mingw32* | *cygwin* | *djgpp*)
-+# NEED_PIC=false
-+# ;;
-+# *)
-+# NEED_PIC=:
-+# ;;
-+#esac
-+#AM_CONDITIONAL(NEED_PIC, ${NEED_PIC})
++AC_LIBTOOL_WIN32_DLL
++AC_PROG_LIBTOOL
dnl Checks for libraries.
LIBAO_LIBS="-lm"
@@ -43,7 +31,7 @@ Index: libdts-0.0.2/libdts/Makefile.am
===================================================================
--- libdts-0.0.2.orig/libdts/Makefile.am
+++ libdts-0.0.2/libdts/Makefile.am
-@@ -1,22 +1,22 @@
+@@ -1,22 +1,13 @@
AM_CFLAGS = $(OPT_CFLAGS) $(LIBDTS_CFLAGS)
-#libtool# lib_LTLIBRARIES = libdts.la
@@ -58,9 +46,6 @@ Index: libdts-0.0.2/libdts/Makefile.am
+libdts_la_SOURCES = bitstream.c parse.c downmix.c
+libdts_la_LIBADD = $(LIBDTS_LIBS)
+libdts_la_LDFLAGS = -no-undefined
-+
-+#lib_LIBRARIES = libdts.a $(libdts_pic_a)
-+#libdts_a_SOURCES = bitstream.c parse.c downmix.c
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libdts.pc
@@ -72,17 +57,12 @@ Index: libdts-0.0.2/libdts/Makefile.am
-endif
-libdts_pic_a_SOURCES = $(libdts_a_SOURCES)
-libdts_pic_a_CPPFLAGS = -fPIC -DPIC
-+#if NEED_PIC
-+#libdts_pic_a = libdts_pic.a
-+#endif
-+#libdts_pic_a_SOURCES = $(libdts_a_SOURCES)
-+#libdts_pic_a_CPPFLAGS = -fPIC -DPIC
-
+-
Index: libdts-0.0.2/src/Makefile.am
===================================================================
--- libdts-0.0.2.orig/src/Makefile.am
+++ libdts-0.0.2/src/Makefile.am
-@@ -2,10 +2,10 @@ AM_CFLAGS = $(DTSDEC_CFLAGS)
+@@ -2,10 +2,8 @@ AM_CFLAGS = $(DTSDEC_CFLAGS)
bin_PROGRAMS = dtsdec extract_dts
dtsdec_SOURCES = dtsdec.c getopt.c gettimeofday.c
@@ -91,9 +71,7 @@ Index: libdts-0.0.2/src/Makefile.am
-dtsdec_LDADD = $(top_builddir)/libdts/libdts.a \
- $(top_builddir)/libao/libao.a $(LIBAO_LIBS)
+dtsdec_LDADD = $(top_builddir)/libdts/libdts.la \
-+ $(top_builddir)/libao/libao.a $(LIBAO_LIBS)
-+#dtsdec_LDADD = $(top_builddir)/libdts/libdts.a \
-+# $(top_builddir)/libao/libao.a $(LIBAO_LIBS)
++ $(top_builddir)/libao/libao.la $(LIBAO_LIBS)
extract_dts_SOURCES = extract_dts.c getopt.c
man_MANS = dtsdec.1 extract_dts.1
@@ -111,3 +89,17 @@ Index: libdts-0.0.2/libdts/configure.incl
AC_ARG_ENABLE([fixed],
[ --enable-fixed use fixed-point (integer-based) arithmetic])
AC_ARG_ENABLE([double],
+Index: libdts-0.0.2/libao/Makefile.am
+===================================================================
+--- libdts-0.0.2.orig/libao/Makefile.am
++++ libdts-0.0.2/libao/Makefile.am
+@@ -1,7 +1,7 @@
+ AM_CFLAGS = $(OPT_CFLAGS)
+
+-noinst_LIBRARIES = libao.a
+-libao_a_SOURCES = audio_out.c audio_out_null.c audio_out_float.c \
++noinst_LTLIBRARIES = libao.la
++libao_la_SOURCES = audio_out.c audio_out_null.c audio_out_float.c \
+ audio_out_oss.c audio_out_solaris.c audio_out_al.c \
+ audio_out_win.c audio_out_wav.c audio_out_aif.c \
+ audio_out_peak.c convert2s16.c