summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-09-29 18:25:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-09-29 18:25:21 +0000
commita31d4d613a8f576117d1dbf20239be5f38a7823d (patch)
treebad3c5bfe8ba2e89875fb5ebd8fe68814a376ba8 /media-libs/libkate
parentStable on sparc, bug #238863 (diff)
downloadgentoo-2-a31d4d613a8f576117d1dbf20239be5f38a7823d.tar.gz
gentoo-2-a31d4d613a8f576117d1dbf20239be5f38a7823d.tar.bz2
gentoo-2-a31d4d613a8f576117d1dbf20239be5f38a7823d.zip
version bump and fix build without doxygen, bug #238858
(Portage version: 2.2_rc11/cvs/Linux 2.6.26.5 x86_64)
Diffstat (limited to 'media-libs/libkate')
-rw-r--r--media-libs/libkate/ChangeLog9
-rw-r--r--media-libs/libkate/files/libkate-0.2.1-doc.patch32
-rw-r--r--media-libs/libkate/libkate-0.2.1.ebuild (renamed from media-libs/libkate/libkate-0.2.0.ebuild)19
3 files changed, 57 insertions, 3 deletions
diff --git a/media-libs/libkate/ChangeLog b/media-libs/libkate/ChangeLog
index 8ae6fe7c2cd7..c9c5937dbccf 100644
--- a/media-libs/libkate/ChangeLog
+++ b/media-libs/libkate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/libkate
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libkate/ChangeLog,v 1.8 2008/09/27 12:49:32 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libkate/ChangeLog,v 1.9 2008/09/29 18:25:20 aballier Exp $
+
+*libkate-0.2.1 (29 Sep 2008)
+
+ 29 Sep 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/libkate-0.2.1-doc.patch, -libkate-0.2.0.ebuild,
+ +libkate-0.2.1.ebuild:
+ version bump and fix build without doxygen, bug #238858
27 Sep 2008; Ferris McCormick <fmccor@gentoo.org> libkate-0.2.0.ebuild:
Add ~sparc for testing. Part of Bug #237813 and now needed for vlc.
diff --git a/media-libs/libkate/files/libkate-0.2.1-doc.patch b/media-libs/libkate/files/libkate-0.2.1-doc.patch
new file mode 100644
index 000000000000..07868fc91da2
--- /dev/null
+++ b/media-libs/libkate/files/libkate-0.2.1-doc.patch
@@ -0,0 +1,32 @@
+Index: libkate-0.2.0/Makefile.am
+===================================================================
+--- libkate-0.2.0.orig/Makefile.am
++++ libkate-0.2.0/Makefile.am
+@@ -1,4 +1,7 @@
+-SUBDIRS=. tools doc
++SUBDIRS=. tools
++if HAVE_DOXYGEN
++SUBDIRS+=doc
++endif
+
+ OGGDIR=built-streams
+ kateincdir=$(includedir)/kate
+Index: libkate-0.2.0/configure.ac
+===================================================================
+--- libkate-0.2.0.orig/configure.ac
++++ libkate-0.2.0/configure.ac
+@@ -68,7 +68,13 @@ AC_CHECK_HEADERS(
+ AC_TYPE_SIZE_T
+
+ AC_CHECK_PROG(HAVE_PKG_CONFIG,pkg-config,yes)
+-AC_CHECK_PROG(HAVE_DOXYGEN,doxygen,yes)
++AC_ARG_ENABLE(doc, [ --disable-doc Disable building documentation (default enabled)])
++if test "x$enable_doc" != "xno"
++then
++ AC_CHECK_PROG(HAVE_DOXYGEN,doxygen,yes)
++else
++ HAVE_DOXYGEN="no"
++fi
+ AM_CONDITIONAL(HAVE_DOXYGEN,test "${HAVE_DOXYGEN}" = "yes")
+
+ AC_ARG_ENABLE(valgrind, [ --enable-valgrind Run the tests with Valgrind (default disabled)])
diff --git a/media-libs/libkate/libkate-0.2.0.ebuild b/media-libs/libkate/libkate-0.2.1.ebuild
index 4c018f950f3a..ada491a2c232 100644
--- a/media-libs/libkate/libkate-0.2.0.ebuild
+++ b/media-libs/libkate/libkate-0.2.1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libkate/libkate-0.2.0.ebuild,v 1.3 2008/09/27 12:49:32 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libkate/libkate-0.2.1.ebuild,v 1.1 2008/09/29 18:25:20 aballier Exp $
+
+inherit eutils autotools
DESCRIPTION="Codec for karaoke and text encapsulation for Ogg"
HOMEPAGE="http://code.google.com/p/libkate/"
@@ -16,7 +18,20 @@ RDEPEND="media-libs/libogg
DEPEND="${RDEPEND}
dev-util/pkgconfig
sys-devel/flex
- sys-devel/bison"
+ sys-devel/bison
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-doc.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable doc)
+ emake || die "emake failed"
+}
src_install() {
emake DESTDIR="${D}" install || die "make install failed"