summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-05-22 09:11:43 +0000
committerTim Harder <radhermit@gentoo.org>2013-05-22 09:11:43 +0000
commit7076aa6a399de39520c7bb8173108fd9168c6df7 (patch)
tree9f8592c47e72b5a719e4e637e30a14ce2b8fa22d /media-libs/libquvi
parentFixed path to sources (${S}) (diff)
downloadgentoo-2-7076aa6a399de39520c7bb8173108fd9168c6df7.tar.gz
gentoo-2-7076aa6a399de39520c7bb8173108fd9168c6df7.tar.bz2
gentoo-2-7076aa6a399de39520c7bb8173108fd9168c6df7.zip
Version bump, update to EAPI 5, and add subslot.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'media-libs/libquvi')
-rw-r--r--media-libs/libquvi/ChangeLog8
-rw-r--r--media-libs/libquvi/files/libquvi-0.9.1-headers-reinstall.patch15
-rw-r--r--media-libs/libquvi/libquvi-0.9.1.ebuild49
3 files changed, 71 insertions, 1 deletions
diff --git a/media-libs/libquvi/ChangeLog b/media-libs/libquvi/ChangeLog
index 4603842f7038..b1a528d634c9 100644
--- a/media-libs/libquvi/ChangeLog
+++ b/media-libs/libquvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libquvi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libquvi/ChangeLog,v 1.22 2013/02/24 18:49:05 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libquvi/ChangeLog,v 1.23 2013/05/22 09:11:43 radhermit Exp $
+
+*libquvi-0.9.1 (22 May 2013)
+
+ 22 May 2013; Tim Harder <radhermit@gentoo.org> +libquvi-0.9.1.ebuild,
+ +files/libquvi-0.9.1-headers-reinstall.patch:
+ Version bump, update to EAPI 5, and add subslot.
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> libquvi-0.4.1.ebuild:
Stable for sparc, wrt bug #458986
diff --git a/media-libs/libquvi/files/libquvi-0.9.1-headers-reinstall.patch b/media-libs/libquvi/files/libquvi-0.9.1-headers-reinstall.patch
new file mode 100644
index 000000000000..d8412875819c
--- /dev/null
+++ b/media-libs/libquvi/files/libquvi-0.9.1-headers-reinstall.patch
@@ -0,0 +1,15 @@
+--- libquvi-0.9.1/src/quvi-0.9/quvi/Makefile.am
++++ libquvi-0.9.1/src/quvi-0.9/quvi/Makefile.am
+@@ -16,12 +16,4 @@
+ qsupp.h\
+ qversion.h
+
+-install-data-local:
+- @if test -f $(libquvisubincludedir)/qfunc.h ; then \
+- echo "** Old headers found in $(libquvisubincludedir). You should" ; \
+- echo "** remove the contents of this directory and type 'make " ; \
+- echo "** install' again." ; \
+- false ; \
+- fi
+-
+ # vim: set ts=2 sw=2 tw=72 expandtab:
diff --git a/media-libs/libquvi/libquvi-0.9.1.ebuild b/media-libs/libquvi/libquvi-0.9.1.ebuild
new file mode 100644
index 000000000000..a288bc2ba09d
--- /dev/null
+++ b/media-libs/libquvi/libquvi-0.9.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libquvi/libquvi-0.9.1.ebuild,v 1.1 2013/05/22 09:11:43 radhermit Exp $
+
+EAPI=5
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="Library for parsing video download links"
+HOMEPAGE="http://quvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/quvi/${PV:0:3}/${P}.tar.xz"
+
+LICENSE="AGPL-3"
+SLOT="0/8" # subslot = libquvi soname version
+KEYWORDS="~amd64 ~x86"
+IUSE="examples nls static-libs"
+
+RDEPEND="!<media-libs/quvi-0.4.0
+ >=dev-libs/glib-2.24.2:2
+ >=dev-libs/libgcrypt-1.4.5:=
+ >=media-libs/libquvi-scripts-0.9
+ >=net-libs/libproxy-0.3.1
+ >=net-misc/curl-7.21.0
+ >=dev-lang/lua-5.1[deprecated]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+PATCHES=( "${FILESDIR}"/${P}-headers-reinstall.patch )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable nls)
+ --with-manual
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.{c,h}
+ fi
+}