summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-19 09:22:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-19 09:22:51 +0000
commit3c940ff34a1cd3d5b28b6016712c004ea0408409 (patch)
tree95bb1c76bef2747e97c2b48d02558b1804d5b657 /media-libs/libv4l
parentbump to 1.1.0 final (diff)
downloadgentoo-2-3c940ff34a1cd3d5b28b6016712c004ea0408409.tar.gz
gentoo-2-3c940ff34a1cd3d5b28b6016712c004ea0408409.tar.bz2
gentoo-2-3c940ff34a1cd3d5b28b6016712c004ea0408409.zip
verion bump, bug #254598
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/libv4l')
-rw-r--r--media-libs/libv4l/ChangeLog9
-rw-r--r--media-libs/libv4l/libv4l-0.5.8.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/media-libs/libv4l/ChangeLog b/media-libs/libv4l/ChangeLog
index b9884a73179d..a9f82372d45a 100644
--- a/media-libs/libv4l/ChangeLog
+++ b/media-libs/libv4l/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libv4l
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.13 2008/12/13 13:45:20 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/ChangeLog,v 1.14 2009/01/19 09:22:51 aballier Exp $
+
+*libv4l-0.5.8 (19 Jan 2009)
+
+ 19 Jan 2009; Alexis Ballier <aballier@gentoo.org> +libv4l-0.5.8.ebuild:
+ verion bump, bug #254598
13 Dec 2008; Tobias Scherbaum <dertobi123@gentoo.org> libv4l-0.5.3.ebuild:
ppc stable, bug #249391
diff --git a/media-libs/libv4l/libv4l-0.5.8.ebuild b/media-libs/libv4l/libv4l-0.5.8.ebuild
new file mode 100644
index 000000000000..03363c65ce3d
--- /dev/null
+++ b/media-libs/libv4l/libv4l-0.5.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libv4l/libv4l-0.5.8.ebuild,v 1.1 2009/01/19 09:22:51 aballier Exp $
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="V4L userspace libraries"
+HOMEPAGE="http://people.atrpms.net/~hdegoede/
+ http://hansdegoede.livejournal.com/3636.html"
+SRC_URI="http://people.atrpms.net/~hdegoede/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_compile() {
+ tc-export CC
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="/usr" LIBDIR="/usr/$(get_libdir)" \
+ DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README* TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "libv4l includes wrapper libraries for compatibility and pixel format"
+ elog "conversion, which are especially useful for users of the gspca usb"
+ elog "webcam driver in kernel 2.6.27 and higher."
+ elog
+ elog "To add v4l2 compatibility to a v4l application 'myapp', launch it via"
+ elog "LD_PRELOAD=/usr/$(get_libdir)/libv4l/v4l1compat.so myapp"
+ elog "To add automatic pixel format conversion to a v4l2 application, use"
+ elog "LD_PRELOAD=/usr/$(get_libdir)/libv4l/v4l2convert.so myapp"
+ elog
+}