summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Medinas <metalgod@gentoo.org>2006-01-10 01:21:07 +0000
committerLuis Medinas <metalgod@gentoo.org>2006-01-10 01:21:07 +0000
commit58e00cc1301dd92786dc95a1538c26478cd74bd2 (patch)
treeaa102583d7564f7406fd4b1765d665af40038302 /media-libs/libvorbis/libvorbis-1.1.2.ebuild
parentVersion Bump. Update Homepage thanks to Thomas Cort <tcort@cs.ubishops.ca>. C... (diff)
downloadgentoo-2-58e00cc1301dd92786dc95a1538c26478cd74bd2.tar.gz
gentoo-2-58e00cc1301dd92786dc95a1538c26478cd74bd2.tar.bz2
gentoo-2-58e00cc1301dd92786dc95a1538c26478cd74bd2.zip
Version Bump. Update Homepage thanks to Thomas Cort <tcort@cs.ubishops.ca>. Closes bug #117980.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-libs/libvorbis/libvorbis-1.1.2.ebuild')
-rw-r--r--media-libs/libvorbis/libvorbis-1.1.2.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/media-libs/libvorbis/libvorbis-1.1.2.ebuild b/media-libs/libvorbis/libvorbis-1.1.2.ebuild
new file mode 100644
index 000000000000..dbf3189219cf
--- /dev/null
+++ b/media-libs/libvorbis/libvorbis-1.1.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvorbis/libvorbis-1.1.2.ebuild,v 1.1 2006/01/10 01:21:07 metalgod Exp $
+
+inherit libtool flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="the Ogg Vorbis sound file format library"
+HOMEPAGE="http://xiph.org/vorbis/"
+SRC_URI="http://downloads.xiph.org/releases/vorbis/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libogg-1.0"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+S=${WORKDIR}/${P/_*/}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # Fix a gcc crash. With the new atexit patch to gcc, it
+ # seems it does not handle -mno-ieee-fp very well.
+ sed -i -e "s:-mno-ieee-fp::g" configure
+
+ # Fixes some strange sed-, libtool- and ranlib-errors on
+ # Mac OS X
+ if use ppc-macos; then
+ glibtoolize
+ else
+ elibtoolize
+ fi
+
+ epunt_cxx #74493
+}
+
+src_compile() {
+ # Cannot compile with sse2 support it would seem #36104
+ use x86 && [ $(gcc-major-version) -eq 3 ] && append-flags -mno-sse2
+ [ "`gcc-version`" == "3.4" ] && replace-flags -Os -O2
+
+ # take out -fomit-frame-pointer from CFLAGS if k6-2
+ is-flag -march=k6-3 && filter-flags -fomit-frame-pointer
+ is-flag -march=k6-2 && filter-flags -fomit-frame-pointer
+ is-flag -march=k6 && filter-flags -fomit-frame-pointer
+
+ # over optimization causes horrible audio artifacts #26463
+ filter-flags -march=pentium?
+
+ # gcc-3.4 and k6 with -ftracer causes code generation problems #49472
+ if [ $(gcc-major-version) -eq 3 -a $(gcc-minor-version) -eq 4 ];
+ then
+ is-flag -march=k6* && filter-flags -ftracer
+ is-flag -mtune=k6* && filter-flags -ftracer
+ fi
+
+ # gcc on hppa causes issues when assembling
+ use hppa && replace-flags -march=2.0 -march=1.0
+
+ # Make prelink work properly
+ append-flags -fPIC
+ append-ldflags -fPIC
+
+ econf || die
+ use ppc-macos && cd ${S} && sed -i -e 's/examples//' Makefile
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ if use ppc-macos; then
+ dosym libvorbisfile.3.1.0.dylib /usr/$(get_libdir)/libvorbisfile.3.dylib
+ dosym libvorbisenc.2.0.1.dylib /usr/$(get_libdir)/libvorbisenc.2.dylib
+ else
+ dosym libvorbisfile.so.3.1.0 /usr/$(get_libdir)/libvorbisfile.so.3
+ dosym libvorbisenc.so.2.0.1 /usr/$(get_libdir)/libvorbisenc.so.2
+ fi
+
+ rm -rf ${D}/usr/share/doc
+ dodoc AUTHORS README todo.txt
+ docinto txt
+ dodoc doc/*.txt
+ dohtml -r doc
+}