summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-12-11 18:05:42 +0000
committerAchim Gottinger <achim@gentoo.org>2000-12-11 18:05:42 +0000
commitcc34e10aad6ac7542d1c8bb7ab9506f2639d89f9 (patch)
treea6ed831386d2385c8dacff518df1b6663b2715a0 /media-libs/mesa/mesa-3.4.ebuild
parent*** empty log message *** (diff)
downloadgentoo-2-cc34e10aad6ac7542d1c8bb7ab9506f2639d89f9.tar.gz
gentoo-2-cc34e10aad6ac7542d1c8bb7ab9506f2639d89f9.tar.bz2
gentoo-2-cc34e10aad6ac7542d1c8bb7ab9506f2639d89f9.zip
*** empty log message ***
Diffstat (limited to 'media-libs/mesa/mesa-3.4.ebuild')
-rw-r--r--media-libs/mesa/mesa-3.4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/mesa/mesa-3.4.ebuild b/media-libs/mesa/mesa-3.4.ebuild
new file mode 100644
index 000000000000..8d33e2c571d5
--- /dev/null
+++ b/media-libs/mesa/mesa-3.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-3.4.ebuild,v 1.1 2000/12/11 18:05:42 achim Exp $
+
+P=MesaLib-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/Mesa-${PV}
+DESCRIPTION="OpenGL like graphic library for Linux"
+SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+DEPEND=">=sys-libs/glibc-2.1.3
+ >=x11-base/xfree-4.0.1"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/mesa --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+# rm -f ${D}/usr/X11R6/lib/libGL.*
+
+# rm -f ${D}/usr/X11R6/include/GL/gl.h
+# rm -f ${D}/usr/X11R6/include/GL/glx.h
+# rm -f ${D}/usr/X11R6/include/GL/osmesa.h
+ cd ${D}/usr/X11R6/lib
+ ln -s libGLU.so.1.1.030400 libMesaGLU.so.3
+ ln -s libGL.so.2.1.030400 libMesaGL.so.3
+
+ cd ${S}
+ dodoc docs/*
+}
+