summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-16 00:56:48 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-16 00:56:48 +0000
commitd8a4a98ae2628b377943d8ac4d6cd0dd902dff26 (patch)
treed55a715086733e43a8b909d588abc86ccb2e3523 /media-libs/ming
parentBump, drop old. Notable changes: fixes buffer underflow in PriorityQueue. (diff)
downloadgentoo-2-d8a4a98ae2628b377943d8ac4d6cd0dd902dff26.tar.gz
gentoo-2-d8a4a98ae2628b377943d8ac4d6cd0dd902dff26.tar.bz2
gentoo-2-d8a4a98ae2628b377943d8ac4d6cd0dd902dff26.zip
Revbump to add perl-5.14 support w/ Debian patch (thanks to turtle, bug 380153)
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/ming')
-rw-r--r--media-libs/ming/ChangeLog9
-rw-r--r--media-libs/ming/files/ming-0.4.3-perl-5.14.patch43
-rw-r--r--media-libs/ming/ming-0.4.3-r2.ebuild119
3 files changed, 170 insertions, 1 deletions
diff --git a/media-libs/ming/ChangeLog b/media-libs/ming/ChangeLog
index 5afd254b43b7..e70427eb273b 100644
--- a/media-libs/ming/ChangeLog
+++ b/media-libs/ming/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/ming
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.81 2011/11/15 22:27:59 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ChangeLog,v 1.82 2011/11/16 00:56:48 xmw Exp $
+
+*ming-0.4.3-r2 (16 Nov 2011)
+
+ 16 Nov 2011; Michael Weber <xmw@gentoo.org> +ming-0.4.3-r2.ebuild,
+ +files/ming-0.4.3-perl-5.14.patch:
+ Revbump to add perl-5.14 support w/ Debian patch (thanks to turtle, bug
+ 380153)
15 Nov 2011; Michael Weber <xmw@gentoo.org> ming-0.4.3-r1.ebuild:
Adding virtual/yacc as DEPEND on stable ebuild (reported by David Owen, bug
diff --git a/media-libs/ming/files/ming-0.4.3-perl-5.14.patch b/media-libs/ming/files/ming-0.4.3-perl-5.14.patch
new file mode 100644
index 000000000000..e34eb0f6f5e5
--- /dev/null
+++ b/media-libs/ming/files/ming-0.4.3-perl-5.14.patch
@@ -0,0 +1,43 @@
+From a0ea1cc47330a3ab316713d720892b6272401890 Mon Sep 17 00:00:00 2001
+From: Niko Tyni <ntyni@debian.org>
+Date: Sun, 10 Jul 2011 21:46:09 +0300
+Subject: [PATCH] GvCV() isn't an lvalue since Perl 5.13.10
+
+GvCV() can't be assigned to anymore with recent perls, so use the new
+GvCV_set() macro when available or implement it the old way if it isn't.
+---
+ perl_ext/Exports.c | 2 +-
+ perl_ext/perl_swf.h | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletions(-)
+
+diff --git a/perl_ext/Exports.c b/perl_ext/Exports.c
+index 65f8912..5529728 100644
+--- a/perl_ext/Exports.c
++++ b/perl_ext/Exports.c
+@@ -190,7 +190,7 @@ void export_cv(SV *class, SV *caller, char *sub)
+ SvPVX(caller), sub, SvPVX(class), sub);
+ #endif
+ gv = gv_fetchpv(form("%s::%s",SvPVX( caller), sub), TRUE, SVt_PVCV);
+- GvCV(gv) = perl_get_cv(form("%s::%s", SvPVX(class), sub), TRUE);
++ GvCV_set(gv, perl_get_cv(form("%s::%s", SvPVX(class), sub), TRUE));
+ GvIMPORTED_CV_on(gv);
+ GvMULTI_on(gv);
+ }
+diff --git a/perl_ext/perl_swf.h b/perl_ext/perl_swf.h
+index b960229..1a3656e 100644
+--- a/perl_ext/perl_swf.h
++++ b/perl_ext/perl_swf.h
+@@ -58,6 +58,10 @@ typedef SWFFontCollection SWF__FontCollection;
+ #define aTHXo_
+ #endif
+
++#ifndef GvCV_set
++# define GvCV_set(G, C) (GvCV(G) = (C))
++#endif
++
+ #ifndef S_DEBUG
+ #define swf_debug 0 /* Should we get this from, say, $SWF::debug? */
+ #define S_DEBUG(level,code) if (swf_debug >= level) { code; }
+--
+1.7.5.4
+
diff --git a/media-libs/ming/ming-0.4.3-r2.ebuild b/media-libs/ming/ming-0.4.3-r2.ebuild
new file mode 100644
index 000000000000..19d721b55eec
--- /dev/null
+++ b/media-libs/ming/ming-0.4.3-r2.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/ming/ming-0.4.3-r2.ebuild,v 1.1 2011/11/16 00:56:48 xmw Exp $
+
+EAPI="3"
+
+PHP_EXT_NAME=ming
+PHP_EXT_OPTIONAL_USE=php
+PYTHON_DEPEND="python? 2"
+
+inherit eutils autotools flag-o-matic multilib php-ext-source-r2 perl-module python
+
+DESCRIPTION="An Open Source library for Flash movie generation."
+HOMEPAGE="http://ming.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ming/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+perl +python php static-libs"
+
+RDEPEND="perl? ( dev-lang/perl )
+ python? ( dev-lang/python )
+ media-libs/freetype
+ media-libs/libpng
+ media-libs/giflib
+ sys-libs/zlib
+ !media-libs/libswf"
+DEPEND="${DEPEND}
+ sys-devel/flex
+ virtual/yacc"
+
+S=${WORKDIR}/${P/_/.}
+
+# Tests only work when the package is tested on a system
+# which does not presently have any version of ming installed.
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng-1.5.patch
+ epatch "${FILESDIR}"/${P}-perl-5.14.patch
+
+ # Let's get rid of the TEXTRELS, link dynamic. Use gif.
+ sed -i \
+ -e 's/libming.a/libming.so/' \
+ -e 's/lungif/lgif/' \
+ perl_ext/Makefile.PL
+ sed -i \
+ -e 's/ungif/gif/' \
+ py_ext/setup.py.in
+
+ if use php; then
+ cd "${S}/php_ext"
+ php-ext-source-r2_phpize
+ cd "${S}"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # build is sensitive to -O3 (bug #297437)
+ replace-flags -O3 -O2
+
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable perl) \
+ $(use_enable python)
+}
+
+src_compile() {
+ emake || die
+
+ if use php; then
+ cd "${S}"/php_ext
+ myconf="--disable-rpath
+ --disable-static
+ --with-ming"
+ php-ext-source-r2_src_compile
+ fi
+}
+
+src_test() {
+ emake check || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" INSTALLDIRS="vendor" install || die
+
+ rm -f "${ED}"usr/lib*/lib${PN}.la
+
+ fixlocalpod
+
+ # Get rid of the precompiled stuff, we generate it later.
+ find "${ED}" -name "*.pyc" -print0 | xargs -0 rm -f
+
+ if use php; then
+ cd "${S}"/php_ext
+ php-ext-source-r2_src_install
+ fi
+}
+
+pkg_postinst() {
+ use perl && perl-module_pkg_postinst
+ use python && python_mod_optimize ming.py mingc.py
+}
+
+pkg_prerm() {
+ use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+ use perl && perl-module_pkg_postrm
+ use python && python_mod_cleanup ming.py mingc.py
+}