summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-23 00:12:55 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-23 00:12:55 +0000
commit5453f94e0082bcd63960433c25b1d1f05ee278d1 (patch)
tree5c6c6b935531727f351904c073c3ba4473d1d94e /media-libs/nurbs++
parentremoved older versions of mplayer and avifile (diff)
downloadgentoo-2-5453f94e0082bcd63960433c25b1d1f05ee278d1.tar.gz
gentoo-2-5453f94e0082bcd63960433c25b1d1f05ee278d1.tar.bz2
gentoo-2-5453f94e0082bcd63960433c25b1d1f05ee278d1.zip
repoman'd
Diffstat (limited to 'media-libs/nurbs++')
-rw-r--r--media-libs/nurbs++/nurbs++-3.0.10.ebuild28
1 files changed, 21 insertions, 7 deletions
diff --git a/media-libs/nurbs++/nurbs++-3.0.10.ebuild b/media-libs/nurbs++/nurbs++-3.0.10.ebuild
index 271cfec9850f..f463481aeb38 100644
--- a/media-libs/nurbs++/nurbs++-3.0.10.ebuild
+++ b/media-libs/nurbs++/nurbs++-3.0.10.ebuild
@@ -1,24 +1,38 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/media-libs/nurbs++/nurbs++-3.0.10.ebuild,v 1.3 2002/07/11 06:30:39 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/nurbs++/nurbs++-3.0.10.ebuild,v 1.4 2002/07/23 00:12:55 seemant Exp $
S=${WORKDIR}/${P}
DESCRIPTION="NURBS surfaces manipulation library"
SRC_URI="http://yukon.genie.uottawa.ca/~lavoie/software/nurbs/${P}.tar.bz2"
HOMEPAGE="http://yukon.genie.uottawa.ca/~lavoie/software/nurbs/"
-DEPEND="virtual/glibc
- virtual/x11
+
+SLOT="3"
+LICENSE="LGPL-2"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
sys-devel/perl"
#media-gfx/imagemagick # doesn't work yet either
# opengl? ( virtual/opengl ) # doesn't work yet
src_compile() {
- #use opengl && myconf="$myconf --with-opengl=/usr" || myconf="$myconf --without-opengl"
- [ -n "$DEBUG" ] && myconf="$myconf --enable-debug --enable-exception --enable-verbose-exception" || myconf="$myconf --disable-debug --disable-exception --disable-verbose-exception"
-
- ./configure --with-x --prefix=/usr $myconf || die # --with-magick
+ #use opengl \
+ # && myconf="$myconf --with-opengl=/usr" \
+ # || myconf="$myconf --without-opengl"
+ [ -n "$DEBUG" ] \
+ && myconf="${myconf} \
+ --enable-debug \
+ --enable-exception \
+ --enable-verbose-exception" \
+ || myconf="${myconf} \
+ --disable-debug \
+ --disable-exception \
+ --disable-verbose-exception"
+
+ ./configure --with-x --prefix=/usr ${myconf} || die # --with-magick
make || die