summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-27 17:03:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-27 17:03:52 +0000
commit5fbe7488a2b7a0215de43990e1345707e4110f66 (patch)
tree61b8bb06b3e0761b5c048277b8c920c2ddb3215d /media-libs/openal
parentppc stable #284306 (diff)
downloadgentoo-2-5fbe7488a2b7a0215de43990e1345707e4110f66.tar.gz
gentoo-2-5fbe7488a2b7a0215de43990e1345707e4110f66.tar.bz2
gentoo-2-5fbe7488a2b7a0215de43990e1345707e4110f66.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/openal')
-rw-r--r--media-libs/openal/ChangeLog8
-rw-r--r--media-libs/openal/openal-1.9.563.ebuild43
2 files changed, 50 insertions, 1 deletions
diff --git a/media-libs/openal/ChangeLog b/media-libs/openal/ChangeLog
index d9f03fb946f4..b6dcab622d1a 100644
--- a/media-libs/openal/ChangeLog
+++ b/media-libs/openal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/openal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.122 2009/09/27 15:36:49 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/ChangeLog,v 1.123 2009/09/27 17:03:52 ssuominen Exp $
+
+*openal-1.9.563 (27 Sep 2009)
+
+ 27 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +openal-1.9.563.ebuild:
+ Version bump.
27 Sep 2009; nixnut <nixnut@gentoo.org> openal-1.8.466.ebuild:
ppc stable #282238
diff --git a/media-libs/openal/openal-1.9.563.ebuild b/media-libs/openal/openal-1.9.563.ebuild
new file mode 100644
index 000000000000..c12675eaf831
--- /dev/null
+++ b/media-libs/openal/openal-1.9.563.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openal/openal-1.9.563.ebuild,v 1.1 2009/09/27 17:03:52 ssuominen Exp $
+
+EAPI=2
+inherit cmake-utils
+
+MY_P=${PN}-soft-${PV}
+
+DESCRIPTION="A software implementation of the OpenAL 3D audio API"
+HOMEPAGE="http://kcat.strangesoft.net/openal.html"
+SRC_URI="http://kcat.strangesoft.net/openal-releases/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa debug oss portaudio pulseaudio"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ portaudio? ( >=media-libs/portaudio-19_pre )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS="alsoftrc.sample"
+
+src_configure() {
+ local mycmakeargs="$(cmake-utils_use alsa ALSA)
+ $(cmake-utils_use oss OSS)
+ $(cmake-utils_use portaudio PORTAUDIO)
+ $(cmake-utils_use pulseaudio PULSEAUDIO)"
+
+ use debug && mycmakeargs+=" -DCMAKE_BUILD_TYPE=Debug"
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "If you have performance problems using this library, then"
+ elog "try add these lines to your ~/.alsoftrc config file:"
+ elog "[alsa]"
+ elog "mmap = off"
+}