summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-28 18:04:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-28 18:04:54 +0000
commitba058f97f3623aa60f00884e0850495f3995a459 (patch)
treefe8365ccb6b8fe3473a794a439d6dd57effbea3b /media-libs/raptor
parentKeyworded ~sparc (diff)
downloadgentoo-2-ba058f97f3623aa60f00884e0850495f3995a459.tar.gz
gentoo-2-ba058f97f3623aa60f00884e0850495f3995a459.tar.bz2
gentoo-2-ba058f97f3623aa60f00884e0850495f3995a459.zip
version bump, bug #171269
(Portage version: 2.1.2.2)
Diffstat (limited to 'media-libs/raptor')
-rw-r--r--media-libs/raptor/ChangeLog9
-rw-r--r--media-libs/raptor/files/digest-raptor-1.4.153
-rw-r--r--media-libs/raptor/raptor-1.4.15.ebuild75
3 files changed, 85 insertions, 2 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index 9f6969d0790a..2973dbeeae50 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/raptor
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.42 2006/10/15 02:26:16 agriffis Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.43 2007/03/28 18:04:54 aballier Exp $
+
+*raptor-1.4.15 (28 Mar 2007)
+
+ 28 Mar 2007; Alexis Ballier <aballier@gentoo.org> +raptor-1.4.15.ebuild:
+ version bump, bug #171269
15 Oct 2006; Aron Griffis <agriffis@gentoo.org> raptor-1.4.9.ebuild,
raptor-1.4.12.ebuild:
diff --git a/media-libs/raptor/files/digest-raptor-1.4.15 b/media-libs/raptor/files/digest-raptor-1.4.15
new file mode 100644
index 000000000000..5de36f8d0f4f
--- /dev/null
+++ b/media-libs/raptor/files/digest-raptor-1.4.15
@@ -0,0 +1,3 @@
+MD5 658fac0c25d50274c879f6cc49c3364b raptor-1.4.15.tar.gz 1445553
+RMD160 b9b25d15a35eee2a0d75eb6b4ba0a70b42a72eeb raptor-1.4.15.tar.gz 1445553
+SHA256 df391e58c8ee3cd1efd8f1bef7ae6dc103c1479ec9e54511e5a933d057983efc raptor-1.4.15.tar.gz 1445553
diff --git a/media-libs/raptor/raptor-1.4.15.ebuild b/media-libs/raptor/raptor-1.4.15.ebuild
new file mode 100644
index 000000000000..e2b921a65a5d
--- /dev/null
+++ b/media-libs/raptor/raptor-1.4.15.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.15.ebuild,v 1.1 2007/03/28 18:04:54 aballier Exp $
+
+inherit eutils
+
+DESCRIPTION="The RDF Parser Toolkit"
+HOMEPAGE="http://librdf.org/raptor/"
+SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
+
+LICENSE="LGPL-2 Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="curl xml gnome ssl"
+
+DEPEND="virtual/libc
+ gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+ xml? ( >=dev-libs/libxml2-2.4.0 )
+ !xml? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-misc/curl )"
+RDEPEND="virtual/libc
+ gnome? ( >=dev-libs/glib-2.2.1 )
+ xml? ( >=dev-libs/libxml2-2.4.0 )
+ !xml? ( dev-libs/expat )
+ ssl? ( dev-libs/openssl )
+ curl? ( net-misc/curl )"
+
+# compilation with libwww currently breaks and for using libfetch I didn't find the right USE flag
+#IUSE="curl xml libwww gnome"
+#DEPEND="virtual/libc
+# gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
+# xml? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-misc/curl ) : ( !xml? ( libwww? ( net-libs/libwww ) ) )
+# "
+#RDEPEND="virtual/libc
+# gnome? ( >=dev-libs/glib-2.2.1 )
+# xml? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# ssl? ( dev-libs/openssl )
+# curl? ( net-misc/curl ) : ( !xml? ( libwww? ( net-libs/libwww ) ) )"
+
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+}
+
+src_compile() {
+ local myraptorconf=""
+
+ use xml \
+ && myraptorconf="${myraptorconf} --with-xml-parser=libxml" \
+ || myraptorconf="${myraptorconf} --with-xml-parser=expat"
+
+ if use curl ; then
+ myraptorconf="${myraptorconf} --with-www=curl"
+ elif use xml ; then
+ myraptorconf="${myraptorconf} --with-www=xml"
+# elif use libwww ;
+# myraptorconf="${myraptorconf} --with-www=libwww"
+ else
+ myraptorconf="${myraptorconf} --with-www=none"
+ fi
+ econf \
+ $(use_enable gnome nfc-check) \
+ ${myraptorconf} \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ dohtml NEWS.html README.html
+}