summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-02 20:13:44 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-02 20:13:44 +0000
commitc296fe3755d7a81901a68ca9e0c036bdff7375ca (patch)
treec707a954cc7c64752bc6487557d19a4c853859ac /media-libs/raptor
parentChange USE=xml2 to USE=xml #116346. (diff)
downloadgentoo-2-c296fe3755d7a81901a68ca9e0c036bdff7375ca.tar.gz
gentoo-2-c296fe3755d7a81901a68ca9e0c036bdff7375ca.tar.bz2
gentoo-2-c296fe3755d7a81901a68ca9e0c036bdff7375ca.zip
Change USE=xml2 to USE=xml #116346.
(Portage version: 2.1_pre7-r3)
Diffstat (limited to 'media-libs/raptor')
-rw-r--r--media-libs/raptor/ChangeLog6
-rw-r--r--media-libs/raptor/raptor-1.4.7.ebuild26
-rw-r--r--media-libs/raptor/raptor-1.4.8.ebuild26
3 files changed, 31 insertions, 27 deletions
diff --git a/media-libs/raptor/ChangeLog b/media-libs/raptor/ChangeLog
index c034a5d347fa..35618dd518b7 100644
--- a/media-libs/raptor/ChangeLog
+++ b/media-libs/raptor/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/raptor
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.32 2006/01/08 09:10:45 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/ChangeLog,v 1.33 2006/04/02 20:13:44 vapier Exp $
+
+ 02 Apr 2006; Mike Frysinger <vapier@gentoo.org> raptor-1.4.7.ebuild,
+ raptor-1.4.8.ebuild:
+ Change USE=xml2 to USE=xml #116346.
08 Jan 2006; Tobias Scherbaum <dertobi123@gentoo.org> raptor-1.4.7.ebuild:
ppc stable, bug #117678
diff --git a/media-libs/raptor/raptor-1.4.7.ebuild b/media-libs/raptor/raptor-1.4.7.ebuild
index 3c42300b376b..86fc8136b19a 100644
--- a/media-libs/raptor/raptor-1.4.7.ebuild
+++ b/media-libs/raptor/raptor-1.4.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.7.ebuild,v 1.9 2006/01/08 09:10:45 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.7.ebuild,v 1.10 2006/04/02 20:13:44 vapier Exp $
inherit eutils
@@ -11,34 +11,34 @@ SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
LICENSE="LGPL-2 Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ia64 ppc ~ppc-macos ppc64 sparc x86"
-IUSE="curl xml2 gnome ssl"
+IUSE="curl xml gnome ssl"
DEPEND="virtual/libc
gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
- xml2? ( >=dev-libs/libxml2-2.4.0 )
- !xml2? ( dev-libs/expat )
+ xml? ( >=dev-libs/libxml2-2.4.0 )
+ !xml? ( dev-libs/expat )
ssl? ( dev-libs/openssl )
curl? ( net-misc/curl )"
RDEPEND="virtual/libc
gnome? ( >=dev-libs/glib-2.2.1 )
- xml2? ( >=dev-libs/libxml2-2.4.0 )
- !xml2? ( dev-libs/expat )
+ xml? ( >=dev-libs/libxml2-2.4.0 )
+ !xml? ( dev-libs/expat )
ssl? ( dev-libs/openssl )
curl? ( net-misc/curl )"
# compilation with libwww currently breaks and for using libfetch I didn't find the right USE flag
-#IUSE="curl xml2 libwww gnome"
+#IUSE="curl xml libwww gnome"
#DEPEND="virtual/libc
# gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
-# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# xml? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
# ssl? ( dev-libs/openssl )
-# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )
+# curl? ( net-misc/curl ) : ( !xml? ( libwww? ( net-libs/libwww ) ) )
# "
#RDEPEND="virtual/libc
# gnome? ( >=dev-libs/glib-2.2.1 )
-# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# xml? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
# ssl? ( dev-libs/openssl )
-# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )"
+# curl? ( net-misc/curl ) : ( !xml? ( libwww? ( net-libs/libwww ) ) )"
src_unpack() {
unpack ${A}
@@ -48,13 +48,13 @@ src_unpack() {
src_compile() {
local myraptorconf=""
- use xml2 \
+ use xml \
&& myraptorconf="${myraptorconf} --with-xml-parser=libxml" \
|| myraptorconf="${myraptorconf} --with-xml-parser=expat"
if use curl ; then
myraptorconf="${myraptorconf} --with-www=curl"
- elif use xml2 ; then
+ elif use xml ; then
myraptorconf="${myraptorconf} --with-www=xml"
# elif use libwww ;
# myraptorconf="${myraptorconf} --with-www=libwww"
diff --git a/media-libs/raptor/raptor-1.4.8.ebuild b/media-libs/raptor/raptor-1.4.8.ebuild
index b1369141a471..0798802abcda 100644
--- a/media-libs/raptor/raptor-1.4.8.ebuild
+++ b/media-libs/raptor/raptor-1.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.8.ebuild,v 1.1 2006/01/04 00:28:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raptor/raptor-1.4.8.ebuild,v 1.2 2006/04/02 20:13:44 vapier Exp $
inherit eutils
@@ -11,34 +11,34 @@ SRC_URI="http://download.librdf.org/source/${P}.tar.gz"
LICENSE="LGPL-2 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~ppc-macos ~sparc ~x86"
-IUSE="curl xml2 gnome ssl"
+IUSE="curl xml gnome ssl"
DEPEND="virtual/libc
gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
- xml2? ( >=dev-libs/libxml2-2.4.0 )
- !xml2? ( dev-libs/expat )
+ xml? ( >=dev-libs/libxml2-2.4.0 )
+ !xml? ( dev-libs/expat )
ssl? ( dev-libs/openssl )
curl? ( net-misc/curl )"
RDEPEND="virtual/libc
gnome? ( >=dev-libs/glib-2.2.1 )
- xml2? ( >=dev-libs/libxml2-2.4.0 )
- !xml2? ( dev-libs/expat )
+ xml? ( >=dev-libs/libxml2-2.4.0 )
+ !xml? ( dev-libs/expat )
ssl? ( dev-libs/openssl )
curl? ( net-misc/curl )"
# compilation with libwww currently breaks and for using libfetch I didn't find the right USE flag
-#IUSE="curl xml2 libwww gnome"
+#IUSE="curl xml libwww gnome"
#DEPEND="virtual/libc
# gnome? ( >=dev-libs/glib-2.2.1 dev-util/pkgconfig )
-# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# xml? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
# ssl? ( dev-libs/openssl )
-# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )
+# curl? ( net-misc/curl ) : ( !xml? ( libwww? ( net-libs/libwww ) ) )
# "
#RDEPEND="virtual/libc
# gnome? ( >=dev-libs/glib-2.2.1 )
-# xml2? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
+# xml? ( >=dev-libs/libxml2-2.4.0 ) : ( dev-libs/expat )
# ssl? ( dev-libs/openssl )
-# curl? ( net-misc/curl ) : ( !xml2? ( libwww? ( net-libs/libwww ) ) )"
+# curl? ( net-misc/curl ) : ( !xml? ( libwww? ( net-libs/libwww ) ) )"
src_unpack() {
unpack ${A}
@@ -48,13 +48,13 @@ src_unpack() {
src_compile() {
local myraptorconf=""
- use xml2 \
+ use xml \
&& myraptorconf="${myraptorconf} --with-xml-parser=libxml" \
|| myraptorconf="${myraptorconf} --with-xml-parser=expat"
if use curl ; then
myraptorconf="${myraptorconf} --with-www=curl"
- elif use xml2 ; then
+ elif use xml ; then
myraptorconf="${myraptorconf} --with-www=xml"
# elif use libwww ;
# myraptorconf="${myraptorconf} --with-www=libwww"