summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-09-03 22:28:11 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-09-03 22:28:11 +0000
commit526a62efa8290c88215b604d036d585bd1ca810c (patch)
tree8af183fc38e5d8adc01dde2cc7b3798fa9d1802b /media-libs/raspberrypi-userland
parentMask latest raspberrypi-userland snapshot (diff)
downloadgentoo-2-526a62efa8290c88215b604d036d585bd1ca810c.tar.gz
gentoo-2-526a62efa8290c88215b604d036d585bd1ca810c.tar.bz2
gentoo-2-526a62efa8290c88215b604d036d585bd1ca810c.zip
New snapshot.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'media-libs/raspberrypi-userland')
-rw-r--r--media-libs/raspberrypi-userland/ChangeLog8
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/media-libs/raspberrypi-userland/ChangeLog b/media-libs/raspberrypi-userland/ChangeLog
index 3baf8da6184f..f332ca2f9e32 100644
--- a/media-libs/raspberrypi-userland/ChangeLog
+++ b/media-libs/raspberrypi-userland/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/raspberrypi-userland
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/ChangeLog,v 1.5 2014/01/23 13:33:18 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/ChangeLog,v 1.6 2014/09/03 22:28:11 chithanh Exp $
+
+*raspberrypi-userland-0_pre20140830 (03 Sep 2014)
+
+ 03 Sep 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +raspberrypi-userland-0_pre20140830.ebuild:
+ New snapshot.
*raspberrypi-userland-0_pre20130705-r1 (23 Jan 2014)
*raspberrypi-userland-0_pre20140117 (23 Jan 2014)
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild
new file mode 100644
index 000000000000..9cbf357169ed
--- /dev/null
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20140830.ebuild,v 1.1 2014/09/03 22:28:11 chithanh Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/userland"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# TODO:
+# * port vcfiled init script
+# * stuff is still installed to hardcoded /opt/vc location, investigate whether
+# anything else depends on it being there
+# * live ebuild
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv userland-*/ ${P}/ || die
+ fi
+}
+
+src_prepare() {
+ # init script for Debian, not useful on Gentoo
+ sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
+}
+
+src_configure() {
+ # toolchain file not needed, but build fails if it is not specified
+ local mycmakeargs="-DCMAKE_TOOLCHAIN_FILE=/dev/null"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doenvd "${FILESDIR}"/04${PN}
+
+ # enable dynamic switching of the GL implementation
+ dodir /usr/lib/opengl
+ dosym ../../../opt/vc /usr/lib/opengl/${PN}
+
+ # tell eselect opengl that we do not have libGL
+ touch "${ED}"/opt/vc/.gles-only
+}