summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-02-02 00:57:27 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-02-02 00:57:27 +0000
commitf50e17b88a59cecfd9d8d911040b53ca7b2be5fd (patch)
tree34105159b6c51bd2fe8f954944fb37a871c7491a /media-libs/raspberrypi-userland
parentRevbump to fix LDFLAGS (thanks Chris Mayo, bug 333495) (diff)
downloadgentoo-2-f50e17b88a59cecfd9d8d911040b53ca7b2be5fd.tar.gz
gentoo-2-f50e17b88a59cecfd9d8d911040b53ca7b2be5fd.tar.bz2
gentoo-2-f50e17b88a59cecfd9d8d911040b53ca7b2be5fd.zip
New snapshot for new firmware, bug #453352. Add live ebuild.
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs/raspberrypi-userland')
-rw-r--r--media-libs/raspberrypi-userland/ChangeLog11
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130131.ebuild54
-rw-r--r--media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild54
3 files changed, 117 insertions, 2 deletions
diff --git a/media-libs/raspberrypi-userland/ChangeLog b/media-libs/raspberrypi-userland/ChangeLog
index 83b24d2e6234..32d560c0adae 100644
--- a/media-libs/raspberrypi-userland/ChangeLog
+++ b/media-libs/raspberrypi-userland/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/raspberrypi-userland
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/ChangeLog,v 1.2 2012/10/25 01:10:45 chithanh Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/ChangeLog,v 1.3 2013/02/02 00:57:27 chithanh Exp $
+
+*raspberrypi-userland-9999 (02 Feb 2013)
+*raspberrypi-userland-0_pre20130131 (02 Feb 2013)
+
+ 02 Feb 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +raspberrypi-userland-0_pre20130131.ebuild, +raspberrypi-userland-9999.ebuild:
+ New snapshot for new firmware, bug #453352. Add live ebuild.
25 Oct 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
raspberrypi-userland-0_pre20121024.ebuild:
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130131.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130131.ebuild
new file mode 100644
index 000000000000..3072bdd2e567
--- /dev/null
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130131.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/raspberrypi-userland-0_pre20130131.ebuild,v 1.1 2013/02/02 00:57:27 chithanh Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/userland"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# TODO:
+# * port vcfiled init script
+# * stuff is still installed to hardcoded /opt/vc location, investigate whether
+# anything else depends on it being there
+# * live ebuild
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv userland-*/ ${P}/ || die
+ fi
+}
+
+src_prepare() {
+ # init script for Debian, not useful on Gentoo
+ sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
+}
+
+src_configure() {
+ # toolchain file not needed, but build fails if it is not specified
+ local mycmakeargs="-DCMAKE_TOOLCHAIN_FILE=/dev/null"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doenvd "${FILESDIR}"/04${PN}
+}
diff --git a/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
new file mode 100644
index 000000000000..2a9176f1f299
--- /dev/null
+++ b/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/raspberrypi-userland/raspberrypi-userland-9999.ebuild,v 1.1 2013/02/02 00:57:27 chithanh Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Raspberry Pi userspace tools and libraries"
+HOMEPAGE="https://github.com/raspberrypi/userland"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+# TODO:
+# * port vcfiled init script
+# * stuff is still installed to hardcoded /opt/vc location, investigate whether
+# anything else depends on it being there
+# * live ebuild
+
+src_unpack() {
+ if [[ ${PV} == 9999* ]]; then
+ git-2_src_unpack
+ else
+ default
+ mv userland-*/ ${P}/ || die
+ fi
+}
+
+src_prepare() {
+ # init script for Debian, not useful on Gentoo
+ sed -i "/DESTINATION \/etc\/init.d/,+2d" interface/vmcs_host/linux/vcfiled/CMakeLists.txt || die
+}
+
+src_configure() {
+ # toolchain file not needed, but build fails if it is not specified
+ local mycmakeargs="-DCMAKE_TOOLCHAIN_FILE=/dev/null"
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ doenvd "${FILESDIR}"/04${PN}
+}