summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-10 11:17:25 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-10 11:17:25 +0000
commit1e1d5883fc2e7a0456b0b8534b05cd685327e0e0 (patch)
tree140ba0b6d70f14bed0cdf86b231b6d2d3bf138b1 /media-libs/smpeg
parentMaintainence and FHS 2.1 fixes for RC4 (diff)
downloadgentoo-2-1e1d5883fc2e7a0456b0b8534b05cd685327e0e0.tar.gz
gentoo-2-1e1d5883fc2e7a0456b0b8534b05cd685327e0e0.tar.bz2
gentoo-2-1e1d5883fc2e7a0456b0b8534b05cd685327e0e0.zip
*** empty log message ***
Diffstat (limited to 'media-libs/smpeg')
-rw-r--r--media-libs/smpeg/files/digest-smpeg-0.4.21
-rw-r--r--media-libs/smpeg/smpeg-0.4.2.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/smpeg/files/digest-smpeg-0.4.2 b/media-libs/smpeg/files/digest-smpeg-0.4.2
new file mode 100644
index 000000000000..cc51f0f49207
--- /dev/null
+++ b/media-libs/smpeg/files/digest-smpeg-0.4.2
@@ -0,0 +1 @@
+MD5 36fe3c2799faee25b79db88fe3699755 smpeg-0.4.2.tar.gz
diff --git a/media-libs/smpeg/smpeg-0.4.2.ebuild b/media-libs/smpeg/smpeg-0.4.2.ebuild
new file mode 100644
index 000000000000..d15a527bbdce
--- /dev/null
+++ b/media-libs/smpeg/smpeg-0.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-libs/smpeg/smpeg-0.4.2.ebuild,v 1.1 2001/02/10 11:17:24 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="SDL MPEG Player Library"
+SRC_URI="ftp://ftp.lokigames.com/pub/open-source/smpeg/${A}"
+HOMEPAGE="http://www.lokigames.com/development/smpeg.php3"
+
+DEPEND=">=sys-apps/bash-2.04
+ >=sys-libs/glibc-2.1.3
+ >=media-libs/libsdl-1.1.5
+ >=media-libs/mesa-3.4
+ >=dev-libs/glib-1.2.8
+ >=x11-libs/gtk+-1.2.8"
+
+src_compile() {
+
+ cd ${S}
+ try ./configure --prefix=/usr --host=${CHOST}
+#--disable-opengl-player
+ try make
+
+}
+
+src_install () {
+
+ cd ${S}
+ try make DESTDIR=${D} install
+ prepman
+ dodoc CHANGES COPYING README* TODO
+}
+
+
+
+