summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-25 10:34:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-25 10:34:21 +0000
commit57acddbc66a047c2383a24446c1bc1907aa6fc71 (patch)
tree94137ab5e0a6df5097efac6aed4623e5fb712c9e /media-libs/soxr
parentBump (diff)
downloadgentoo-2-57acddbc66a047c2383a24446c1bc1907aa6fc71.tar.gz
gentoo-2-57acddbc66a047c2383a24446c1bc1907aa6fc71.tar.bz2
gentoo-2-57acddbc66a047c2383a24446c1bc1907aa6fc71.zip
Initial import. Ebuild by me. Standalone resampling library from SoX, which is fast and good quality according to some studies.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/soxr')
-rw-r--r--media-libs/soxr/ChangeLog12
-rw-r--r--media-libs/soxr/files/libsuffix.patch13
-rw-r--r--media-libs/soxr/files/nodoc.patch19
-rw-r--r--media-libs/soxr/files/noexamples.patch9
-rw-r--r--media-libs/soxr/metadata.xml5
-rw-r--r--media-libs/soxr/soxr-0.1.0.ebuild36
6 files changed, 94 insertions, 0 deletions
diff --git a/media-libs/soxr/ChangeLog b/media-libs/soxr/ChangeLog
new file mode 100644
index 000000000000..7bb2d68e4076
--- /dev/null
+++ b/media-libs/soxr/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for media-libs/soxr
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/soxr/ChangeLog,v 1.1 2013/01/25 10:34:21 aballier Exp $
+
+*soxr-0.1.0 (25 Jan 2013)
+
+ 25 Jan 2013; Alexis Ballier <aballier@gentoo.org> +soxr-0.1.0.ebuild,
+ +files/libsuffix.patch, +files/nodoc.patch, +files/noexamples.patch,
+ +metadata.xml:
+ Initial import. Ebuild by me. Standalone resampling library from SoX, which
+ is fast and good quality according to some studies.
+
diff --git a/media-libs/soxr/files/libsuffix.patch b/media-libs/soxr/files/libsuffix.patch
new file mode 100644
index 000000000000..e22512b78188
--- /dev/null
+++ b/media-libs/soxr/files/libsuffix.patch
@@ -0,0 +1,13 @@
+Index: soxr-0.1.0-Source/CMakeLists.txt
+===================================================================
+--- soxr-0.1.0-Source.orig/CMakeLists.txt
++++ soxr-0.1.0-Source/CMakeLists.txt
+@@ -180,7 +180,7 @@ if (NOT DEFINED BIN_INSTALL_DIR)
+ set (BIN_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/bin")
+ endif ()
+ if (NOT DEFINED LIB_INSTALL_DIR)
+- set (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib")
++ set (LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
+ endif ()
+ if (NOT DEFINED INCLUDE_INSTALL_DIR)
+ set (INCLUDE_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/include")
diff --git a/media-libs/soxr/files/nodoc.patch b/media-libs/soxr/files/nodoc.patch
new file mode 100644
index 000000000000..0d64e1aba0f9
--- /dev/null
+++ b/media-libs/soxr/files/nodoc.patch
@@ -0,0 +1,19 @@
+Index: soxr-0.1.0-Source/CMakeLists.txt
+===================================================================
+--- soxr-0.1.0-Source.orig/CMakeLists.txt
++++ soxr-0.1.0-Source/CMakeLists.txt
+@@ -217,14 +217,6 @@ if (BUILD_TESTS OR BUILD_LSR_TESTS)
+ enable_testing ()
+ endif ()
+
+-install (FILES
+- ${CMAKE_CURRENT_SOURCE_DIR}/README
+- ${CMAKE_CURRENT_SOURCE_DIR}/LICENCE
+- ${CMAKE_CURRENT_SOURCE_DIR}/NEWS
+- DESTINATION ${DOC_INSTALL_DIR})
+-
+-
+-
+ # Subdirectories:
+
+ include_directories (${PROJECT_SOURCE_DIR}/src)
diff --git a/media-libs/soxr/files/noexamples.patch b/media-libs/soxr/files/noexamples.patch
new file mode 100644
index 000000000000..c66c0b1e5b19
--- /dev/null
+++ b/media-libs/soxr/files/noexamples.patch
@@ -0,0 +1,9 @@
+Index: soxr-0.1.0-Source/examples/CMakeLists.txt
+===================================================================
+--- soxr-0.1.0-Source.orig/examples/CMakeLists.txt
++++ soxr-0.1.0-Source/examples/CMakeLists.txt
+@@ -34,4 +34,3 @@ if (${BUILD_TESTS} AND ${WITH_LSR_BINDIN
+ endif ()
+
+ file (GLOB INSTALL_SOURCES ${CMAKE_CURRENT_SOURCE_DIR}/*.[cCh])
+-install (FILES ${INSTALL_SOURCES} ${CMAKE_CURRENT_SOURCE_DIR}/README DESTINATION ${DOC_INSTALL_DIR}/examples)
diff --git a/media-libs/soxr/metadata.xml b/media-libs/soxr/metadata.xml
new file mode 100644
index 000000000000..3bf6bcfeb512
--- /dev/null
+++ b/media-libs/soxr/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-libs/soxr/soxr-0.1.0.ebuild b/media-libs/soxr/soxr-0.1.0.ebuild
new file mode 100644
index 000000000000..2fc8e875aaf3
--- /dev/null
+++ b/media-libs/soxr/soxr-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/soxr/soxr-0.1.0.ebuild,v 1.1 2013/01/25 10:34:21 aballier Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+MY_P=${P}-Source
+DESCRIPTION="The SoX Resampler library"
+HOMEPAGE="https://sourceforge.net/p/soxr/wiki/Home/"
+SRC_URI="mirror://sourceforge/soxr/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README" "TODO" "NEWS" "AUTHORS" )
+PATCHES=(
+ "${FILESDIR}/libsuffix.patch"
+ "${FILESDIR}/nodoc.patch"
+ "${FILESDIR}/noexamples.patch"
+ )
+
+src_install() {
+ cmake-utils_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.[cCh] examples/README
+ fi
+}