summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-06 12:03:00 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-06 12:03:00 +0000
commitcd922311bbe282c46e3c2832b60264da5d794479 (patch)
tree419865380b3af0dca57b95fb50084babc44cc575 /media-libs/soxr
parenteapi5: define subslot, use slotdeps, remove useless || die, do not compress e... (diff)
downloadgentoo-2-cd922311bbe282c46e3c2832b60264da5d794479.tar.gz
gentoo-2-cd922311bbe282c46e3c2832b60264da5d794479.tar.bz2
gentoo-2-cd922311bbe282c46e3c2832b60264da5d794479.zip
version bump
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs/soxr')
-rw-r--r--media-libs/soxr/ChangeLog7
-rw-r--r--media-libs/soxr/soxr-0.1.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/media-libs/soxr/ChangeLog b/media-libs/soxr/ChangeLog
index 497e6ed63443..dc90ad105542 100644
--- a/media-libs/soxr/ChangeLog
+++ b/media-libs/soxr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/soxr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/soxr/ChangeLog,v 1.4 2013/03/06 11:57:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/soxr/ChangeLog,v 1.5 2013/03/06 12:03:00 aballier Exp $
+
+*soxr-0.1.1 (06 Mar 2013)
+
+ 06 Mar 2013; Alexis Ballier <aballier@gentoo.org> +soxr-0.1.1.ebuild:
+ version bump
06 Mar 2013; Alexis Ballier <aballier@gentoo.org> soxr-0.1.0.ebuild:
do not compress examples, they are pointless compressed
diff --git a/media-libs/soxr/soxr-0.1.1.ebuild b/media-libs/soxr/soxr-0.1.1.ebuild
new file mode 100644
index 000000000000..dbd0503a2f5f
--- /dev/null
+++ b/media-libs/soxr/soxr-0.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/soxr/soxr-0.1.1.ebuild,v 1.1 2013/03/06 12:03:00 aballier Exp $
+
+EAPI=5
+
+inherit cmake-multilib
+
+MY_P=${P}-Source
+DESCRIPTION="The SoX Resampler library"
+HOMEPAGE="https://sourceforge.net/p/soxr/wiki/Home/"
+SRC_URI="mirror://sourceforge/soxr/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~mips"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README" "TODO" "NEWS" "AUTHORS" )
+PATCHES=(
+ "${FILESDIR}/nodoc.patch"
+ "${FILESDIR}/noexamples.patch"
+ )
+
+src_install() {
+ cmake-multilib_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}