summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-07-30 16:56:30 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-07-30 16:56:30 +0000
commitc5694148b926829a08e635ca559b3f7c54cff6ef (patch)
tree7863db41a6d387bbf456121a4fe1af86a118a248 /media-libs/tse3
parentnot yet. (diff)
downloadgentoo-2-c5694148b926829a08e635ca559b3f7c54cff6ef.tar.gz
gentoo-2-c5694148b926829a08e635ca559b3f7c54cff6ef.tar.bz2
gentoo-2-c5694148b926829a08e635ca559b3f7c54cff6ef.zip
GCC 4 patch, closes bug #100708.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'media-libs/tse3')
-rw-r--r--media-libs/tse3/ChangeLog8
-rw-r--r--media-libs/tse3/files/tse3-0.2.7-gcc4.patch36
-rw-r--r--media-libs/tse3/tse3-0.2.7.ebuild4
3 files changed, 45 insertions, 3 deletions
diff --git a/media-libs/tse3/ChangeLog b/media-libs/tse3/ChangeLog
index d8c71e646c66..0eabbafb8fb4 100644
--- a/media-libs/tse3/ChangeLog
+++ b/media-libs/tse3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/tse3
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.10 2004/10/08 09:51:50 eradicator Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/ChangeLog,v 1.11 2005/07/30 16:56:30 chainsaw Exp $
+
+ 30 Jul 2005; Tony Vroon <chainsaw@gentoo.org>
+ +files/tse3-0.2.7-gcc4.patch, tse3-0.2.7.ebuild:
+ GCC 4 patch by Håvard Wall <haavardw@ifi.uio.no>, closes bug #100708.
08 Oct 2004; Jeremy Huddleston <eradicator@gentoo.org> tse3-0.2.7.ebuild:
multilib fixes.
diff --git a/media-libs/tse3/files/tse3-0.2.7-gcc4.patch b/media-libs/tse3/files/tse3-0.2.7-gcc4.patch
new file mode 100644
index 000000000000..7f32076323b6
--- /dev/null
+++ b/media-libs/tse3/files/tse3-0.2.7-gcc4.patch
@@ -0,0 +1,36 @@
+--- ./src/tse3/cmd/Phrase.h~ 2002-07-28 17:17:11.000000000 +0200
++++ ./src/tse3/cmd/Phrase.h 2005-07-29 15:45:03.000000000 +0200
+@@ -19,6 +19,7 @@
+
+ #include "tse3/cmd/Command.h"
+ #include "tse3/Phrase.h"
++#include "tse3/PhraseEdit.h"
+ #include "tse3/DisplayParams.h"
+
+ #include <vector>
+--- ./src/tse3/file/XML.h~ 2005-07-29 15:37:31.000000000 +0200
++++ ./src/tse3/file/XML.h 2005-07-29 15:50:03.000000000 +0200
+@@ -154,7 +154,6 @@
+ void element(const std::string &name, const char *value);
+ void element(const std::string &name, int value);
+ void element(const std::string &name, unsigned int value);
+- void element(const std::string &name, size_t value);
+ void element(const std::string &name, bool value);
+
+ void comment(const std::string &comment);
+--- ./src/tse3/file/XML.cpp~ 2005-07-29 15:37:31.000000000 +0200
++++ ./src/tse3/file/XML.cpp 2005-07-29 15:49:55.000000000 +0200
+@@ -116,13 +116,6 @@
+ out << "<" << name << " value=\"" << value << "\"/>\n";
+ }
+
+-void TSE3::File::XmlFileWriter::element(const std::string &name, size_t value)
+-{
+- indent(out);
+- out << "<" << name << " value=\"" << value << "\"/>\n";
+-}
+-
+-
+ void TSE3::File::XmlFileWriter::element(const std::string &name, bool value)
+ {
+ indent(out);
diff --git a/media-libs/tse3/tse3-0.2.7.ebuild b/media-libs/tse3/tse3-0.2.7.ebuild
index f794cf50699a..ca6b639df83d 100644
--- a/media-libs/tse3/tse3-0.2.7.ebuild
+++ b/media-libs/tse3/tse3-0.2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.14 2005/05/05 02:38:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/tse3/tse3-0.2.7.ebuild,v 1.15 2005/07/30 16:56:30 chainsaw Exp $
inherit eutils
@@ -24,6 +24,8 @@ src_unpack() {
epatch ${FILESDIR}/${P}-size_t-64bit.patch
# gcc-3.4 patch
epatch ${FILESDIR}/${P}-gcc34.patch
+ # gcc-4 patch (bug #100708)
+ epatch ${FILESDIR}/${P}-gcc4.patch
}
src_compile() {