summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2013-10-12 06:12:29 +0000
committerMatt Turner <mattst88@gentoo.org>2013-10-12 06:12:29 +0000
commit70eaaac6487fc9d108a94ad0336720df7cdd0951 (patch)
tree31d64f6dd7f0e0d44beb1c212be908e536833ccc /media-libs/waffle
parentSome cleanups to tcc-9999 configure/make (diff)
downloadgentoo-2-70eaaac6487fc9d108a94ad0336720df7cdd0951.tar.gz
gentoo-2-70eaaac6487fc9d108a94ad0336720df7cdd0951.tar.bz2
gentoo-2-70eaaac6487fc9d108a94ad0336720df7cdd0951.zip
Add waffle-1.3.0 to the tree.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'media-libs/waffle')
-rw-r--r--media-libs/waffle/ChangeLog10
-rw-r--r--media-libs/waffle/metadata.xml11
-rw-r--r--media-libs/waffle/waffle-1.3.0.ebuild49
3 files changed, 70 insertions, 0 deletions
diff --git a/media-libs/waffle/ChangeLog b/media-libs/waffle/ChangeLog
new file mode 100644
index 000000000000..2ef759d10dad
--- /dev/null
+++ b/media-libs/waffle/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for media-libs/waffle
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/waffle/ChangeLog,v 1.1 2013/10/12 06:12:29 mattst88 Exp $
+
+*waffle-1.3.0 (12 Oct 2013)
+
+ 12 Oct 2013; Matt Turner <mattst88@gentoo.org> +waffle-1.3.0.ebuild,
+ +metadata.xml:
+ Add waffle-1.3.0 to the tree.
+
diff --git a/media-libs/waffle/metadata.xml b/media-libs/waffle/metadata.xml
new file mode 100644
index 000000000000..dfd7cc8587d7
--- /dev/null
+++ b/media-libs/waffle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+<use>
+ <flag name="egl">Enable EGL support</flag>
+ <flag name="gbm">Enable support for the Generic Buffer Manager (gbm)</flag>
+ <flag name="wayland">Enable Wayland support</flag>
+</use>
+</pkgmetadata>
+
diff --git a/media-libs/waffle/waffle-1.3.0.ebuild b/media-libs/waffle/waffle-1.3.0.ebuild
new file mode 100644
index 000000000000..12f7b1c33006
--- /dev/null
+++ b/media-libs/waffle/waffle-1.3.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/waffle/waffle-1.3.0.ebuild,v 1.1 2013/10/12 06:12:29 mattst88 Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
+HOMEPAGE="http://people.freedesktop.org/~chadversary/waffle/"
+SRC_URI="http://people.freedesktop.org/~chadversary/waffle/files/release/${P}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc egl gbm test wayland"
+
+RDEPEND="
+ media-libs/mesa[egl?,gbm?]
+ virtual/opengl
+ wayland? ( >=dev-libs/wayland-1.0 )
+ gbm? ( virtual/udev )
+ x11-libs/libX11
+ x11-libs/libxcb"
+DEPEND="${RDEPEND}
+ x11-proto/xcb-proto
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xml-dtd:4.2
+ )"
+
+src_configure() {
+ mycmakeargs=(
+ -Dwaffle_has_glx=ON
+ -Dwaffle_build_examples=OFF
+ $(cmake-utils_use doc waffle_build_manpages)
+ $(cmake-utils_use egl waffle_has_x11_egl)
+ $(cmake-utils_use gbm waffle_has_gbm)
+ $(cmake-utils_use test waffle_build_tests)
+ $(cmake-utils_use wayland waffle_has_wayland)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${WORKDIR}/${P}_build"
+ emake check
+}