summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-22 11:27:29 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-22 11:27:29 +0000
commite6eb17e1f555693f100b49e3529f34b2f88c9f7c (patch)
tree8cd88cf2e68f8020e02c6075b7b8d9bf19214eb3 /media-libs/x264
parentFix Emacs support, bug 234898. (diff)
downloadgentoo-2-e6eb17e1f555693f100b49e3529f34b2f88c9f7c.tar.gz
gentoo-2-e6eb17e1f555693f100b49e3529f34b2f88c9f7c.tar.bz2
gentoo-2-e6eb17e1f555693f100b49e3529f34b2f88c9f7c.zip
New x264 snapshot
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-hh1 i686)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/x264-0.0.20080819.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 4040d732e643..adbb6ddf880c 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.4 2008/04/14 22:24:52 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.5 2008/08/22 11:27:29 yngwin Exp $
+
+*x264-0.0.20080819 (22 Aug 2008)
+
+ 22 Aug 2008; Ben de Groot <yngwin@gentoo.org> +x264-0.0.20080819.ebuild:
+ Version bump
14 Apr 2008; Ben de Groot <yngwin@gentoo.org> x264-0.0.20080406.ebuild:
Fix typo
diff --git a/media-libs/x264/x264-0.0.20080819.ebuild b/media-libs/x264/x264-0.0.20080819.ebuild
new file mode 100644
index 000000000000..56c5a48a1684
--- /dev/null
+++ b/media-libs/x264/x264-0.0.20080819.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-0.0.20080819.ebuild,v 1.1 2008/08/22 11:27:29 yngwin Exp $
+
+EAPI="1"
+inherit multilib eutils toolchain-funcs versionator
+
+MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+SRC_URI="ftp://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +threads"
+
+RDEPEND=""
+DEPEND="amd64? ( >=dev-lang/yasm-0.6.2 )
+ x86? ( >=dev-lang/yasm-0.6.2 )
+ x86-fbsd? ( >=dev-lang/yasm-0.6.2 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-nostrip.patch"
+ epatch "${FILESDIR}/${PN}-onlylib-20080406.patch"
+}
+
+src_compile() {
+ local myconf=""
+ use debug && myconf="${myconf} --enable-debug"
+ ./configure --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --enable-pic --enable-shared \
+ "--extra-cflags=${CFLAGS}" \
+ "--extra-ldflags=${LDFLAGS}" \
+ "--extra-asflags=${ASFLAGS}" \
+ $(use_enable threads pthread) \
+ ${myconf} \
+ --disable-mp4-output \
+ || die "configure failed"
+ emake CC="$(tc-getCC)" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS doc/*.txt
+}
+
+pkg_postinst() {
+ elog "Please note that this package now only installs"
+ elog "${PN} libraries. In order to have the encoder,"
+ elog "please emerge media-video/x264-encoder."
+}