summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-08-24 20:46:16 +0000
committerMarinus Schraal <foser@gentoo.org>2003-08-24 20:46:16 +0000
commit9ab66aad3a5c0a7bd670eb7d1c2a81600f597d26 (patch)
tree9edb041d803fad0be19a7560ec2b8484e5a9845a /media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild
parentfixed emacs dependency with use emacs && inherit elisp (diff)
downloadgentoo-2-9ab66aad3a5c0a7bd670eb7d1c2a81600f597d26.tar.gz
gentoo-2-9ab66aad3a5c0a7bd670eb7d1c2a81600f597d26.tar.bz2
gentoo-2-9ab66aad3a5c0a7bd670eb7d1c2a81600f597d26.zip
add gcc2 compilation fixing patch
Diffstat (limited to 'media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild')
-rw-r--r--media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild18
1 files changed, 15 insertions, 3 deletions
diff --git a/media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild b/media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild
index 9e423d171ef4..59633e18324a 100644
--- a/media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild
+++ b/media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild,v 1.1 2003/08/18 18:02:01 agenkin Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/xine-lib/xine-lib-1_rc0-r3.ebuild,v 1.2 2003/08/24 20:46:05 foser Exp $
+
+inherit eutils
# this build doesn't play nice with -maltivec (gcc 3.2 only option) on ppc
# Commenting this out in this ebuild, because CFLAGS and CXXFLAGS are unset
@@ -27,7 +29,7 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~hppa ~sparc"
IUSE="arts esd avi nls dvd aalib X directfb oggvorbis alsa gnome sdl"
-DEPEND="oggvorbis? ( media-libs/libvorbis )
+RDEPEND="oggvorbis? ( media-libs/libvorbis )
X? ( virtual/x11 )
avi? ( x86? ( >=media-libs/win32codecs-0.50
media-libs/divx4linux ) )
@@ -45,11 +47,21 @@ DEPEND="oggvorbis? ( media-libs/libvorbis )
>=media-libs/libfame-0.9.0
>=media-libs/xvid-0.9.0
media-libs/speex"
-RDEPEND="${DEPEND}
+
+DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
S=${WORKDIR}/${PN}-${PV/_/-}${MY_PKG_SUFFIX}
+src_unpack() {
+
+ unpack ${A}
+
+ # gcc2 fixes provided by <T.Henderson@cs.ucl.ac.uk> in #26534
+ epatch ${FILESDIR}/${P}-gcc2_fix.patch
+
+}
+
src_compile() {
# Make sure that the older libraries are not installed (bug #15081).
if [ -f /usr/lib/libxine.so.0 ]