summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2015-05-01 21:45:14 +0000
committerJames Le Cuirot <chewi@gentoo.org>2015-05-01 21:45:14 +0000
commit0084149320e0028778cd48d601e8cd3ed28aaa78 (patch)
tree0529bcd33804b6fb59bd16d55f2e25f38e78cf81 /media-libs
parentVersion bump (diff)
downloadgentoo-2-0084149320e0028778cd48d601e8cd3ed28aaa78.tar.gz
gentoo-2-0084149320e0028778cd48d601e8cd3ed28aaa78.tar.bz2
gentoo-2-0084149320e0028778cd48d601e8cd3ed28aaa78.zip
Forwardport some fixes from 1.5.2. Make doxygen docs actually install
for 1.5.2. Install doxygen docs in right directory for later versions. Convert 2.1.0 to multilib. Unfortunately 2.0.0 has ABI header conflicts. Closes bug #548076. (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 9C6D7DE4)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/openjpeg/ChangeLog16
-rw-r--r--media-libs/openjpeg/files/openjpeg-2.0.0-build.patch14
-rw-r--r--media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild75
-rw-r--r--media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild73
-rw-r--r--media-libs/openjpeg/openjpeg-2.1.0-r1.ebuild71
5 files changed, 233 insertions, 16 deletions
diff --git a/media-libs/openjpeg/ChangeLog b/media-libs/openjpeg/ChangeLog
index 790b81fdaf35..231d94784376 100644
--- a/media-libs/openjpeg/ChangeLog
+++ b/media-libs/openjpeg/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for media-libs/openjpeg
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/ChangeLog,v 1.117 2014/11/01 17:46:51 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/ChangeLog,v 1.118 2015/05/01 21:45:13 chewi Exp $
+
+*openjpeg-2.0.0-r1 (01 May 2015)
+*openjpeg-2.1.0-r1 (01 May 2015)
+*openjpeg-1.5.2-r1 (01 May 2015)
+
+ 01 May 2015; James Le Cuirot <chewi@gentoo.org> +openjpeg-1.5.2-r1.ebuild,
+ +openjpeg-2.0.0-r1.ebuild, +openjpeg-2.1.0-r1.ebuild,
+ -files/openjpeg-2.0.0-build.patch:
+ Forwardport some fixes from 1.5.2. Make doxygen docs actually install for
+ 1.5.2. Install doxygen docs in right directory for later versions. Convert
+ 2.1.0 to multilib. Unfortunately 2.0.0 has ABI header conflicts. Closes bug
+ #548076.
01 Nov 2014; Agostino Sarubbo <ago@gentoo.org> openjpeg-2.1.0.ebuild:
Stable for ppc, wrt bug #527182
diff --git a/media-libs/openjpeg/files/openjpeg-2.0.0-build.patch b/media-libs/openjpeg/files/openjpeg-2.0.0-build.patch
deleted file mode 100644
index 31ae12f213cb..000000000000
--- a/media-libs/openjpeg/files/openjpeg-2.0.0-build.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- openjpeg-2.0.0/CMakeLists.txt
-+++ openjpeg-2.0.0/CMakeLists.txt
-@@ -279,11 +279,4 @@
- DESTINATION ${OPENJPEG_INSTALL_PACKAGE_DIR}
- )
-
--#-----------------------------------------------------------------------------
--# install CHANGES and LICENSE
--if(EXISTS ${OPENJPEG_SOURCE_DIR}/CHANGES)
-- install(FILES CHANGES DESTINATION ${OPENJPEG_INSTALL_DOC_DIR})
--endif()
--install(FILES LICENSE DESTINATION ${OPENJPEG_INSTALL_DOC_DIR})
--
- include (cmake/OpenJPEGCPack.cmake)
diff --git a/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild b/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..04cdf8c23265
--- /dev/null
+++ b/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/openjpeg-1.5.2-r1.ebuild,v 1.1 2015/05/01 21:45:13 chewi Exp $
+
+EAPI=5
+inherit multilib cmake-multilib
+
+DESCRIPTION="An open-source JPEG 2000 library"
+HOMEPAGE="http://code.google.com/p/openjpeg/"
+SRC_URI="mirror://sourceforge/${PN}.mirror/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/5" # based on SONAME
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lcms:2=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS CHANGES NEWS README THANKS )
+
+RESTRICT="test" #409263
+
+src_prepare() {
+ # Stop installing LICENSE file, and install CHANGES from DOCS instead:
+ sed -i -e '/INSTALL.*FILES.*DESTINATION.*OPENJPEG_INSTALL_DOC_DIR/d' CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_DOC=$(multilib_native_usex doc ON OFF)
+ -DBUILD_CODEC=$(multilib_is_native_abi && echo ON || echo OFF)
+ )
+
+ cmake-utils_src_configure
+
+ if use static-libs; then
+ mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_CODEC=OFF
+ )
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_compile
+ fi
+}
+
+multilib_src_install() {
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_install
+ fi
+
+ cmake-utils_src_install
+
+ dosym openjpeg-1.5/openjpeg.h /usr/include/openjpeg.h
+ dosym libopenjpeg1.pc /usr/$(get_libdir)/pkgconfig/libopenjpeg.pc
+
+ if use doc && multilib_is_native_abi; then
+ dodoc -r doc/html
+ fi
+}
diff --git a/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild b/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..586e49f4abd4
--- /dev/null
+++ b/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/openjpeg-2.0.0-r1.ebuild,v 1.1 2015/05/01 21:45:13 chewi Exp $
+
+EAPI=5
+inherit cmake-utils multilib
+
+DESCRIPTION="An open-source JPEG 2000 library"
+HOMEPAGE="http://code.google.com/p/openjpeg/"
+SRC_URI="mirror://sourceforge/${PN}.mirror/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lcms:2=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS CHANGES NEWS README THANKS )
+
+PATCHES=( "${FILESDIR}"/${P}-pkgconfig.patch
+ "${FILESDIR}"/${P}-pkgconfig-static.patch )
+
+RESTRICT="test" #409263
+
+src_prepare() {
+ # Stop installing LICENSE file, and install CHANGES from DOCS instead:
+ sed -i -e '/install.*FILES.*DESTINATION.*OPENJPEG_INSTALL_DOC_DIR/d' CMakeLists.txt || die
+
+ # Install doxygen docs to the right directory:
+ sed -i -e "s:DESTINATION\s*share/doc:\0/${PF}:" doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_build test TESTING)
+ )
+
+ cmake-utils_src_configure
+
+ if use static-libs; then
+ mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_CODEC=OFF
+ )
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_compile
+ fi
+}
+
+src_install() {
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_install
+ fi
+
+ cmake-utils_src_install
+}
diff --git a/media-libs/openjpeg/openjpeg-2.1.0-r1.ebuild b/media-libs/openjpeg/openjpeg-2.1.0-r1.ebuild
new file mode 100644
index 000000000000..8d0ca5d2f7bc
--- /dev/null
+++ b/media-libs/openjpeg/openjpeg-2.1.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/openjpeg/openjpeg-2.1.0-r1.ebuild,v 1.1 2015/05/01 21:45:13 chewi Exp $
+
+EAPI=5
+inherit multilib cmake-multilib
+
+DESCRIPTION="An open-source JPEG 2000 library"
+HOMEPAGE="http://code.google.com/p/openjpeg/"
+SRC_URI="mirror://sourceforge/${PN}.mirror/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="2/7" # based on SONAME
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc static-libs test"
+
+RDEPEND="media-libs/lcms:2=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+DOCS=( AUTHORS CHANGES NEWS README THANKS )
+
+RESTRICT="test" #409263
+
+src_prepare() {
+ # Stop installing LICENSE file, and install CHANGES from DOCS instead:
+ sed -i -e '/install.*FILES.*DESTINATION.*OPENJPEG_INSTALL_DOC_DIR/d' CMakeLists.txt || die
+
+ # Install doxygen docs to the right directory:
+ sed -i -e "s:DESTINATION\s*share/doc:\0/${PF}:" doc/CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_DOC=$(multilib_native_usex doc ON OFF)
+ -DBUILD_CODEC=$(multilib_is_native_abi && echo ON || echo OFF)
+ )
+
+ cmake-utils_src_configure
+
+ if use static-libs; then
+ mycmakeargs=(
+ -DOPENJPEG_INSTALL_LIB_DIR="$(get_libdir)"
+ $(cmake-utils_use_build test TESTING)
+ -DBUILD_SHARED_LIBS=OFF
+ -DBUILD_CODEC=OFF
+ )
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_compile
+ fi
+}
+
+multilib_src_install() {
+ if use static-libs; then
+ BUILD_DIR=${BUILD_DIR}_static cmake-utils_src_install
+ fi
+
+ cmake-utils_src_install
+}