summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-22 13:26:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-22 13:26:17 +0000
commit066109f4f77361fd1c84dba843d75293e40cf29a (patch)
treeb648b70c7602d94174d4cf4d00717dd3b895d58b /media-libs
parentVersion Bump (diff)
downloadgentoo-2-066109f4f77361fd1c84dba843d75293e40cf29a.tar.gz
gentoo-2-066109f4f77361fd1c84dba843d75293e40cf29a.tar.bz2
gentoo-2-066109f4f77361fd1c84dba843d75293e40cf29a.zip
Convert to multilib, bug #463942 by Michał Górny and further modifications by me.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/nas/ChangeLog10
-rw-r--r--media-libs/nas/nas-1.9.3-r1.ebuild98
2 files changed, 106 insertions, 2 deletions
diff --git a/media-libs/nas/ChangeLog b/media-libs/nas/ChangeLog
index 1c2b65ff63d3..a4203beacf73 100644
--- a/media-libs/nas/ChangeLog
+++ b/media-libs/nas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/nas
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/nas/ChangeLog,v 1.76 2012/12/09 16:16:36 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/nas/ChangeLog,v 1.77 2013/08/22 13:26:17 aballier Exp $
+
+*nas-1.9.3-r1 (22 Aug 2013)
+
+ 22 Aug 2013; Alexis Ballier <aballier@gentoo.org> +nas-1.9.3-r1.ebuild:
+ Convert to multilib, bug #463942 by Michał Górny and further modifications
+ by me.
09 Dec 2012; Julian Ospald <hasufell@gentoo.org> nas-1.9.3.ebuild:
respect CC and RANLIB wrt #446598 and #446600
diff --git a/media-libs/nas/nas-1.9.3-r1.ebuild b/media-libs/nas/nas-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..7e06b5f66385
--- /dev/null
+++ b/media-libs/nas/nas-1.9.3-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/nas/nas-1.9.3-r1.ebuild,v 1.1 2013/08/22 13:26:17 aballier Exp $
+
+EAPI=5
+inherit eutils multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="Network Audio System"
+HOMEPAGE="http://radscan.com/nas.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+
+LICENSE="HPND MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc static-libs"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau[${MULTILIB_USEDEP}]
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-text/rman
+ x11-misc/gccmakedep
+ x11-misc/imake
+ x11-proto/xproto[${MULTILIB_USEDEP}]"
+
+DOCS=( BUILDNOTES FAQ HISTORY README RELEASE TODO )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.9.2-asneeded.patch \
+ "${FILESDIR}"/${PN}-1.9.2-implicit-inet_ntoa-amd64.patch
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ xmkmf -a || die
+}
+
+multilib_src_compile() {
+ # EXTRA_LDOPTIONS, SHLIBGLOBALSFLAGS #336564#c2
+ local emakeopts=(
+ AR="$(tc-getAR) clq"
+ AS="$(tc-getAS)"
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
+ CXX="$(tc-getCXX)"
+ CXXDEBUFLAGS="${CXXFLAGS}"
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+ LD="$(tc-getLD)"
+ MAKE="${MAKE:-gmake}"
+ RANLIB="$(tc-getRANLIB)"
+ SHLIBGLOBALSFLAGS="${LDFLAGS}"
+ WORLDOPTS=
+ )
+
+ if multilib_is_native_abi ; then
+ # dumb fix for parallel make issue wrt #446598, Imake sux
+ emake "${emakeopts[@]}" -C server/dia all
+ emake "${emakeopts[@]}" -C server/dda/voxware all
+ emake "${emakeopts[@]}" -C server/os all
+ else
+ sed -i \
+ -e 's/SUBDIRS =.*/SUBDIRS = include lib config/' \
+ Makefile || die
+ fi
+
+ emake "${emakeopts[@]}" World
+}
+
+multilib_src_install() {
+ # ranlib is used at install phase too wrt #446600
+ emake RANLIB="$(tc-getRANLIB)" \
+ DESTDIR="${D}" USRLIBDIR=/usr/$(get_libdir) \
+ install install.man
+}
+
+multilib_src_install_all() {
+ if use doc; then
+ docinto doc
+ dodoc doc/{actions,protocol.txt,README}
+ docinto pdf
+ dodoc doc/pdf/*.pdf
+ fi
+
+ mv -vf "${D}"/etc/nas/nasd.conf{.eg,} || die
+
+ newconfd "${FILESDIR}"/nas.conf.d nas
+ newinitd "${FILESDIR}"/nas.init.d nas
+
+ use static-libs || rm -f "${D}"/usr/lib*/libaudio.a
+}