summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-02 08:38:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-02 08:38:39 +0000
commit170f3b05a4665485e0084caebeeaf6a2f4e5a211 (patch)
treea0a9837a04485b62c0b9e0b7a40dde90af177201 /media-libs
parentAdd dependency on app-text/gnome-doc-utils, bug #448636 (diff)
downloadgentoo-2-170f3b05a4665485e0084caebeeaf6a2f4e5a211.tar.gz
gentoo-2-170f3b05a4665485e0084caebeeaf6a2f4e5a211.tar.bz2
gentoo-2-170f3b05a4665485e0084caebeeaf6a2f4e5a211.zip
build with clang (bug #448696)
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sdl-mixer/ChangeLog12
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch11
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch15
-rw-r--r--media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch5
-rw-r--r--media-libs/sdl-mixer/sdl-mixer-1.2.12-r3.ebuild105
5 files changed, 134 insertions, 14 deletions
diff --git a/media-libs/sdl-mixer/ChangeLog b/media-libs/sdl-mixer/ChangeLog
index 5f85662e6ea5..940f3dae6cfa 100644
--- a/media-libs/sdl-mixer/ChangeLog
+++ b/media-libs/sdl-mixer/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/sdl-mixer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.112 2012/12/17 01:35:51 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/ChangeLog,v 1.113 2013/01/02 08:38:39 mr_bones_ Exp $
+
+*sdl-mixer-1.2.12-r3 (02 Jan 2013)
+
+ 02 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/sdl-mixer-1.2.12-clang.patch, +sdl-mixer-1.2.12-r3.ebuild,
+ files/sdl-mixer-1.2.12-mikmod-r587.patch,
+ files/sdl-mixer-1.2.12-mikmod-r588.patch, files/sdl-mixer-1.2.12-wav.patch:
+ build with clang (bug #448696)
*sdl-mixer-1.2.12-r2 (17 Dec 2012)
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch
new file mode 100644
index 000000000000..3c462bd97088
--- /dev/null
+++ b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-clang.patch
@@ -0,0 +1,11 @@
+--- SDL_mixer-1.2.12.orig/music_mad.c
++++ SDL_mixer-1.2.12/music_mad.c
+@@ -224,7 +224,7 @@
+ if ((mp3_mad->status & MS_playing) == 0) {
+ /* We're not supposed to be playing, so send silence instead. */
+ memset(stream, 0, len);
+- return;
++ return 0;
+ }
+
+ out = stream;
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch
index 4763da11413f..d99609f8ab25 100644
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch
+++ b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r587.patch
@@ -8,9 +8,8 @@ https://bugs.gentoo.org/445980
# Parent c92001a2c18f628698c58aa4e05a7335d10d0e9e
Paul P Komkoff Jr fixed malloc/free mismatch in the MikMod driver
-diff -r c92001a2c18f -r 56cad6484b04 dynamic_mod.c
---- a/dynamic_mod.c Sun Mar 04 21:32:47 2012 +0000
-+++ b/dynamic_mod.c Sun Jul 22 16:13:27 2012 -0700
+--- a/dynamic_mod.c
++++ b/dynamic_mod.c
@@ -93,6 +93,13 @@
SDL_UnloadObject(mikmod.handle);
return -1;
@@ -25,9 +24,8 @@ diff -r c92001a2c18f -r 56cad6484b04 dynamic_mod.c
mikmod.Player_Active =
(BOOL (*)(void))
SDL_LoadFunction(mikmod.handle, "Player_Active");
-diff -r c92001a2c18f -r 56cad6484b04 dynamic_mod.h
---- a/dynamic_mod.h Sun Mar 04 21:32:47 2012 +0000
-+++ b/dynamic_mod.h Sun Jul 22 16:13:27 2012 -0700
+--- a/dynamic_mod.h
++++ b/dynamic_mod.h
@@ -35,6 +35,7 @@
void (*MikMod_RegisterDriver)(struct MDRIVER*);
int* MikMod_errno;
@@ -36,9 +34,8 @@ diff -r c92001a2c18f -r 56cad6484b04 dynamic_mod.h
BOOL (*Player_Active)(void);
void (*Player_Free)(MODULE*);
MODULE* (*Player_LoadGeneric)(MREADER*,int,BOOL);
-diff -r c92001a2c18f -r 56cad6484b04 music_mod.c
---- a/music_mod.c Sun Mar 04 21:32:47 2012 +0000
-+++ b/music_mod.c Sun Jul 22 16:13:27 2012 -0700
+--- a/music_mod.c
++++ b/music_mod.c
@@ -109,13 +109,13 @@
list = mikmod.MikMod_InfoDriver();
diff --git a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch
index a4469c056dd9..d47a8d4534c8 100644
--- a/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch
+++ b/media-libs/sdl-mixer/files/sdl-mixer-1.2.12-mikmod-r588.patch
@@ -8,9 +8,8 @@ https://bugs.gentoo.org/445980
# Parent 56cad6484b04f83c8d42428c755a046678506436
Fixed normal linking with libmikmod and linking with earlier versions of libmikmod.
-diff -r 56cad6484b04 -r 2ebb0d016f27 dynamic_mod.c
---- a/dynamic_mod.c Sun Jul 22 16:13:27 2012 -0700
-+++ b/dynamic_mod.c Sun Jul 22 16:33:37 2012 -0700
+--- a/dynamic_mod.c
++++ b/dynamic_mod.c
@@ -97,8 +97,8 @@
(void (*)(void*))
SDL_LoadFunction(mikmod.handle, "MikMod_free");
diff --git a/media-libs/sdl-mixer/sdl-mixer-1.2.12-r3.ebuild b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r3.ebuild
new file mode 100644
index 000000000000..062e52cd5fb3
--- /dev/null
+++ b/media-libs/sdl-mixer/sdl-mixer-1.2.12-r3.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-mixer/sdl-mixer-1.2.12-r3.ebuild,v 1.1 2013/01/02 08:38:39 mr_bones_ Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P=${P/sdl-/SDL_}
+DESCRIPTION="Simple Direct Media Layer Mixer Library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_mixer/"
+SRC_URI="http://www.libsdl.org/projects/SDL_mixer/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="flac fluidsynth mad midi mikmod mod modplug mp3 playtools smpeg static-libs timidity vorbis +wav"
+REQUIRED_USE="
+ midi? ( || ( timidity fluidsynth ) )
+ timidity? ( midi )
+ fluidsynth? ( midi )
+ mp3? ( || ( smpeg mad ) )
+ smpeg? ( mp3 )
+ mad? ( mp3 )
+ mod? ( || ( mikmod modplug ) )
+ mikmod? ( mod )
+ modplug? ( mod )
+ "
+
+DEPEND=">=media-libs/libsdl-1.2.10
+ flac? ( media-libs/flac )
+ midi? (
+ fluidsynth? ( media-sound/fluidsynth )
+ timidity? ( media-sound/timidity++ )
+ )
+ mp3? (
+ mad? ( media-libs/libmad )
+ smpeg? ( >=media-libs/smpeg-0.4.4-r1 )
+ )
+ mod? (
+ modplug? ( media-libs/libmodplug )
+ mikmod? ( >=media-libs/libmikmod-3.1.10 )
+ )
+ vorbis? ( >=media-libs/libvorbis-1.0_beta4 media-libs/libogg )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-wav.patch \
+ "${FILESDIR}"/${P}-clang.patch \
+ "${FILESDIR}"/${P}-mikmod-r58{7,8}.patch #445980
+ sed -i \
+ -e '/link.*play/s/-o/$(LDFLAGS) -o/' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-music-flac-shared \
+ --disable-music-fluidsynth-shared \
+ --disable-music-mod-shared \
+ --disable-music-mp3-shared \
+ --disable-music-ogg-shared \
+ $(use_enable wav music-wave) \
+ $(use_enable vorbis music-ogg) \
+ $(use_enable mikmod music-mod) \
+ $(use_enable modplug music-mod-modplug) \
+ $(use_enable flac music-flac) \
+ $(use_enable static-libs static) \
+ $(use_enable smpeg music-mp3) \
+ $(use_enable mad music-mp3-mad-gpl) \
+ $(use_enable timidity music-timidity-midi) \
+ $(use_enable fluidsynth music-fluidsynth-midi)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ if use playtools; then
+ emake DESTDIR="${D}" install-bin
+ fi
+ dodoc CHANGES README
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + || die
+ fi
+}
+
+pkg_postinst() {
+ # bug 412035
+ # https://bugs.gentoo.org/show_bug.cgi?id=412035
+ if use midi ; then
+ if use fluidsynth; then
+ ewarn "FluidSynth support requires you to set the SDL_SOUNDFONTS"
+ ewarn "environment variable to the location of a SoundFont file"
+ ewarn "unless the game or application happens to do this for you."
+
+ if use timidity; then
+ ewarn "Failing to do so will result in Timidity being used instead."
+ else
+ ewarn "Failing to do so will result in silence."
+ fi
+ fi
+ fi
+}