summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-04-18 19:08:23 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-04-18 19:08:23 +0000
commit379f36951e04b999463adcb9ceac2e7393d1f90c (patch)
treefb70cc401c78cf1fdd82b5eed518c819f72c40e6 /media-libs
parentmask >=media-libs/sdl-image-1.2.12-r1 for multilib conversion (diff)
downloadgentoo-2-379f36951e04b999463adcb9ceac2e7393d1f90c.tar.gz
gentoo-2-379f36951e04b999463adcb9ceac2e7393d1f90c.tar.bz2
gentoo-2-379f36951e04b999463adcb9ceac2e7393d1f90c.zip
add multilib support
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/sdl-image/ChangeLog9
-rw-r--r--media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/media-libs/sdl-image/ChangeLog b/media-libs/sdl-image/ChangeLog
index 5355ebfad4f6..4cf6c8674ea0 100644
--- a/media-libs/sdl-image/ChangeLog
+++ b/media-libs/sdl-image/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/sdl-image
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/ChangeLog,v 1.87 2012/06/08 19:56:50 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/ChangeLog,v 1.88 2014/04/18 19:08:23 hasufell Exp $
+
+*sdl-image-1.2.12-r1 (18 Apr 2014)
+
+ 18 Apr 2014; Julian Ospald <hasufell@gentoo.org> +sdl-image-1.2.12-r1.ebuild:
+ add multilib support
08 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> sdl-image-1.2.12.ebuild:
use prune_libtool_files instead of rolling our own
diff --git a/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild b/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild
new file mode 100644
index 000000000000..f461b10a7c21
--- /dev/null
+++ b/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-image/sdl-image-1.2.12-r1.ebuild,v 1.1 2014/04/18 19:08:23 hasufell Exp $
+
+EAPI=5
+inherit eutils multilib-minimal
+
+MY_P="${P/sdl-/SDL_}"
+DESCRIPTION="image file loading library"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_image/"
+SRC_URI="http://www.libsdl.org/projects/SDL_image/release/${MY_P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="gif jpeg png static-libs tiff webp"
+
+RDEPEND="
+ abi_x86_32? (
+ !app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ !<=app-emulation/emul-linux-x86-sdl-20140406
+ )
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ media-libs/libsdl[${MULTILIB_USEDEP}]
+ png? ( media-libs/libpng:0[${MULTILIB_USEDEP}] )
+ jpeg? ( virtual/jpeg[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff[${MULTILIB_USEDEP}] )
+ webp? ( media-libs/libwebp[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-jpg-shared \
+ --disable-png-shared \
+ --disable-tif-shared \
+ --disable-webp-shared \
+ $(use_enable static-libs static) \
+ $(use_enable gif) \
+ $(use_enable jpeg jpg) \
+ $(use_enable tiff tif) \
+ $(use_enable png) \
+ $(use_enable webp) \
+ --enable-bmp \
+ --enable-lbm \
+ --enable-pcx \
+ --enable-pnm \
+ --enable-tga \
+ --enable-xcf \
+ --enable-xpm \
+ --enable-xv
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+ dobin .libs/showimage
+}
+
+multilib_src_install_all() {
+ dodoc CHANGES README
+ use static-libs || prune_libtool_files --all
+}