summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-03-03 18:07:48 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-03-03 18:07:48 +0000
commit3e3f6d83c928681613acda811f8fe7674dfd6ae3 (patch)
treeb4972e01b2ae042c7acccc1d138a2ef6ee589783 /media-libs
parentRemoved versions older than the current stable one. (diff)
downloadgentoo-2-3e3f6d83c928681613acda811f8fe7674dfd6ae3.tar.gz
gentoo-2-3e3f6d83c928681613acda811f8fe7674dfd6ae3.tar.bz2
gentoo-2-3e3f6d83c928681613acda811f8fe7674dfd6ae3.zip
Migrate to generation 2 java eclasses and add the doc use flag for javadocs. Thanks to Alistair Bush <alistair.bush@gmail.com>. Fixes bug #120264.
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/pdflib/ChangeLog9
-rw-r--r--media-libs/pdflib/files/digest-pdflib-6.0.3-r13
-rw-r--r--media-libs/pdflib/files/fix-java-compile.patch11
-rw-r--r--media-libs/pdflib/pdflib-6.0.3-r1.ebuild116
4 files changed, 138 insertions, 1 deletions
diff --git a/media-libs/pdflib/ChangeLog b/media-libs/pdflib/ChangeLog
index 3e5b6ca3dcdf..7e2cdc42391b 100644
--- a/media-libs/pdflib/ChangeLog
+++ b/media-libs/pdflib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/pdflib
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.61 2007/03/01 17:27:03 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/ChangeLog,v 1.62 2007/03/03 18:07:48 betelgeuse Exp $
+
+*pdflib-6.0.3-r1 (03 Mar 2007)
+
+ 03 Mar 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/fix-java-compile.patch, +pdflib-6.0.3-r1.ebuild:
+ Migrate to generation 2 java eclasses and add the doc use flag for javadocs.
+ Thanks to Alistair Bush <alistair.bush@gmail.com>. Fixes bug #120264.
01 Mar 2007; <genstef@gentoo.org> pdflib-5.0.4_p1-r1.ebuild,
pdflib-6.0.3.ebuild:
diff --git a/media-libs/pdflib/files/digest-pdflib-6.0.3-r1 b/media-libs/pdflib/files/digest-pdflib-6.0.3-r1
new file mode 100644
index 000000000000..101dd33ba572
--- /dev/null
+++ b/media-libs/pdflib/files/digest-pdflib-6.0.3-r1
@@ -0,0 +1,3 @@
+MD5 799aeaa3f0f9a13d7a661d730327e9d0 PDFlib-Lite-6.0.3.tar.gz 3763292
+RMD160 c8d74b31f30156be0280865aaa9985883fba6c21 PDFlib-Lite-6.0.3.tar.gz 3763292
+SHA256 7ebd0f907283800e757bf27b038e4f18786c16577f51a547e55da014f9f248ff PDFlib-Lite-6.0.3.tar.gz 3763292
diff --git a/media-libs/pdflib/files/fix-java-compile.patch b/media-libs/pdflib/files/fix-java-compile.patch
new file mode 100644
index 000000000000..8a5e21a5e85d
--- /dev/null
+++ b/media-libs/pdflib/files/fix-java-compile.patch
@@ -0,0 +1,11 @@
+--- bind/pdflib/java/Makefile.orig 2007-01-30 17:30:46.000000000 +1300
++++ bind/pdflib/java/Makefile 2007-01-30 17:32:04.000000000 +1300
+@@ -38,7 +38,7 @@
+ pdflib.jar:: pdflib.java PDFlibException.java
+ $(RM) com
+ mkdir -p com/pdflib
+- javac PDFlibException.java pdflib.java && mv pdflib.class com/pdflib\
++ javac ${JAVACFLAGS} PDFlibException.java pdflib.java && mv pdflib.class com/pdflib\
+ && mv PDFlibException.class com/pdflib/PDFlibException.class
+ jar cvf pdflib.jar com/pdflib/pdflib.class \
+ com/pdflib/PDFlibException.class
diff --git a/media-libs/pdflib/pdflib-6.0.3-r1.ebuild b/media-libs/pdflib/pdflib-6.0.3-r1.ebuild
new file mode 100644
index 000000000000..6d1fa0e2167b
--- /dev/null
+++ b/media-libs/pdflib/pdflib-6.0.3-r1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/pdflib/pdflib-6.0.3-r1.ebuild,v 1.1 2007/03/03 18:07:48 betelgeuse Exp $
+
+# eutils must be inherited since get_libdir() is only
+# globally available on baselayout-1.11 (still on ~arch)
+inherit base eutils java-pkg-opt-2 flag-o-matic
+
+MY_PN="${PN/pdf/PDF}-Lite"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A library for generating PDF on the fly."
+HOMEPAGE="http://www.pdflib.com/"
+SRC_URI="http://www.pdflib.com/products/pdflib/download/${PV//./}src/${MY_P}.tar.gz"
+LICENSE="Aladdin"
+SLOT="5"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="doc tcl perl python java"
+
+COMMON_DEP="
+ >=sys-apps/sed-4
+ tcl? ( >=dev-lang/tcl-8.2 )
+ perl? ( >=dev-lang/perl-5.1 )
+ python? ( >=dev-lang/python-2.2 )"
+
+DEPEND="
+ ${COMMON_DEP}
+ java? ( >=virtual/jdk-1.4 )"
+
+RDEPEND="
+ ${COMMON_DEP}
+ java? ( >=virtual/jre-1.4 )"
+
+PATCHES="${FILESDIR}/fix-java-compile.patch"
+
+src_compile() {
+ local myconf
+
+ # Bug #87004
+ filter-flags -mcpu=*
+ filter-flags -mtune=*
+
+ PYVER="$(/usr/bin/python -V 2>&1 | cut -d ' ' -f 2 | cut -d '.' -f 1,2)"
+ # Necessary for multilib on amd64. Please keep this in future releases.
+ # BUG #81197
+ # Danny van Dyk <kugelfang@gentoo.org> 2005/02/14
+ TCLVER="$(echo 'puts [info tclversion]' | $(which tclsh))"
+ use tcl \
+ && myconf="--with-tclpkg=/usr/$(get_libdir)/tcl${TCLVER}/" \
+ || myconf="--with-tcl=no"
+ use perl || myconf="${myconf} --with-perl=no"
+ use python \
+ && myconf="${myconf} --with-py=/usr --with-pyincl=/usr/include/python${PYVER}" \
+ || myconf="${myconf} --with-py=no"
+ use java \
+ && myconf="${myconf} --with-java=${JAVA_HOME}" \
+ || myconf="${myconf} --with-java=no"
+
+ econf \
+ --enable-cxx \
+ ${myconf} || die
+
+ JAVACFLAGS="$(java-pkg_javac-args)" emake || die "emake failed"
+ if use java && use doc; then
+ cd ./bind/pdflib/java || die
+ emake javadoc || die "Failed to generate javadoc"
+ fi
+}
+
+src_install() {
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/perl/Makefile" \
+ || die "sed bind/pdflib/perl/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/python/Makefile" \
+ || die "sed bind/pdflib/python/Makefile failed"
+
+ sed -i \
+ -e "s:^\(LANG_LIBDIR\).*= \(.*\):\1\t = ${D}/\2:" \
+ "${S}/bind/pdflib/tcl/Makefile" \
+ || die "sed bind/pdflib/tcl/Makefile failed"
+
+ # ok, this should create the correct lib dirs for perl and python.
+ # yes, i know it is messy, but as i see it, a ebuild should be generic
+ # ... ie. you should be able to just use cp to update it
+ if use perl && [ -x /usr/bin/perl ] ; then
+ local perlmajver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4 |cut -d '.' -f 1`"
+ local perlver="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 4`"
+ local perlarch="`/usr/bin/perl -v |grep 'This is perl' \
+ |cut -d ' ' -f 7`"
+ dodir /usr/$(get_libdir)/perl${perlmajver/v/}/site_perl/${perlver/v/}/${perlarch}
+ fi
+ if use python && [ -x /usr/bin/python ] ; then
+ dodir /usr/$(get_libdir)/python${PYVER}/lib-dynload
+ fi
+ #next line required for proper install
+ dodir /usr/bin
+ einstall || die
+
+ dodoc readme.txt doc/*
+ docinto pdflib
+ dodoc doc/pdflib/*
+
+ # seemant: seems like the makefiles for pdflib generate the .jar file
+ # anyway
+ use java && java-pkg_dojar bind/pdflib/java/pdflib.jar
+ if use java && use doc; then
+ java-pkg_dojavadoc ./bind/pdflib/java/javadoc
+ fi
+}