summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-06-21 03:37:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-06-21 03:37:29 +0000
commit5238a651c49a3738f7a79641681787d8f80cd168 (patch)
tree40160c0322f7a93c87c855b77a29769233659860 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-5238a651c49a3738f7a79641681787d8f80cd168.tar.gz
gentoo-2-5238a651c49a3738f7a79641681787d8f80cd168.tar.bz2
gentoo-2-5238a651c49a3738f7a79641681787d8f80cd168.zip
Build and install png2theora (and other binaries) if USE examples is used.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libtheora/ChangeLog6
-rw-r--r--media-libs/libtheora/libtheora-1.1_alpha1.ebuild56
-rw-r--r--media-libs/libtheora/libtheora-1.1_alpha2.ebuild30
3 files changed, 26 insertions, 66 deletions
diff --git a/media-libs/libtheora/ChangeLog b/media-libs/libtheora/ChangeLog
index da2c27c55c9b..a497173ed33b 100644
--- a/media-libs/libtheora/ChangeLog
+++ b/media-libs/libtheora/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libtheora
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.92 2009/06/09 16:55:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/ChangeLog,v 1.93 2009/06/21 03:37:29 ssuominen Exp $
+
+ 21 Jun 2009; Samuli Suominen <ssuominen@gentoo.org>
+ libtheora-1.1_alpha2.ebuild:
+ Build and install png2theora (and other binaries) if USE examples is used.
*libtheora-1.1_alpha2 (09 Jun 2009)
diff --git a/media-libs/libtheora/libtheora-1.1_alpha1.ebuild b/media-libs/libtheora/libtheora-1.1_alpha1.ebuild
deleted file mode 100644
index 48532cdcfe99..000000000000
--- a/media-libs/libtheora/libtheora-1.1_alpha1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1_alpha1.ebuild,v 1.1 2009/05/07 08:38:39 ssuominen Exp $
-
-EAPI=2
-inherit autotools eutils flag-o-matic
-
-DESCRIPTION="The Theora Video Compression Codec"
-HOMEPAGE="http://www.theora.org"
-SRC_URI="http://downloads.xiph.org/releases/theora/${P/_}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="doc encode examples"
-
-RDEPEND="media-libs/libogg
- encode? ( media-libs/libvorbis )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- dev-util/pkgconfig"
-
-VARTEXFONTS=${T}/fonts
-S=${WORKDIR}/${P/_}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0_beta2-flags.patch
- AT_M4DIR="m4" eautoreconf
-}
-
-src_configure() {
- use x86 && filter-flags -fforce-addr -frename-registers #200549
- use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
-
- # Don't build specs even with doc enabled, just a few people would need
- # it and causes sandbox violations.
- export ac_cv_prog_HAVE_PDFLATEX="false"
-
- econf \
- --disable-dependency-tracking \
- --disable-sdltest \
- $(use_enable encode) \
- --disable-examples
-}
-
-src_install() {
- emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} \
- install || die "emake install failed"
- dodoc AUTHORS CHANGES README
- prepalldocs
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.[ch]
- fi
-}
diff --git a/media-libs/libtheora/libtheora-1.1_alpha2.ebuild b/media-libs/libtheora/libtheora-1.1_alpha2.ebuild
index e299888123a2..508f70c75c34 100644
--- a/media-libs/libtheora/libtheora-1.1_alpha2.ebuild
+++ b/media-libs/libtheora/libtheora-1.1_alpha2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1_alpha2.ebuild,v 1.1 2009/06/09 16:55:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libtheora/libtheora-1.1_alpha2.ebuild,v 1.2 2009/06/21 03:37:29 ssuominen Exp $
EAPI=2
inherit autotools eutils flag-o-matic
@@ -15,7 +15,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-
IUSE="doc encode examples"
RDEPEND="media-libs/libogg
- encode? ( media-libs/libvorbis )"
+ encode? ( media-libs/libvorbis )
+ examples? ( media-libs/libpng
+ media-libs/libvorbis
+ media-libs/libsdl )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )
dev-util/pkgconfig"
@@ -32,25 +35,34 @@ src_configure() {
use x86 && filter-flags -fforce-addr -frename-registers #200549
use doc || export ac_cv_prog_HAVE_DOXYGEN="false"
- # Don't build specs even with doc enabled, just a few people would need
- # it and causes sandbox violations.
- export ac_cv_prog_HAVE_PDFLATEX="false"
+ local myconf
+ use examples && myconf="--enable-encode"
+ # --disable-spec because LaTeX documentation has been prebuilt
econf \
--disable-dependency-tracking \
- --disable-sdltest \
+ --disable-spec \
$(use_enable encode) \
- --disable-examples
+ $(use_enable examples) \
+ ${myconf}
}
src_install() {
emake DESTDIR="${D}" docdir=/usr/share/doc/${PF} \
install || die "emake install failed"
+
dodoc AUTHORS CHANGES README
prepalldocs
if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins examples/*.[ch]
+ if use doc; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.[ch]
+ fi
+
+ dobin examples/.libs/png2theora || die "dobin failed"
+ for bin in dump_{psnr,video} {encoder,player}_example; do
+ newbin examples/.libs/${bin} theora_${bin} || die "newbin failed"
+ done
fi
}