summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-11-10 23:17:08 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-11-10 23:17:08 +0000
commit55cf4500220fbb6f0b8f3af16248127cd778ec8b (patch)
treeec053fbea95a9da57fe6039906005e03b96fb758 /media-libs
parentStable on x86 wrt bug #198489 (diff)
downloadgentoo-2-55cf4500220fbb6f0b8f3af16248127cd778ec8b.tar.gz
gentoo-2-55cf4500220fbb6f0b8f3af16248127cd778ec8b.tar.bz2
gentoo-2-55cf4500220fbb6f0b8f3af16248127cd778ec8b.zip
Bump to 7.0.2, with lots of bugfixes. I removed all keywords because I can't get any 3D apps running besides glxgears, but I'd like to get reports from others to help figure out whether my system's just broken.
(Portage version: 2.1.3.17)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog10
-rw-r--r--media-libs/mesa/files/7.0.2-glw.pc.in11
-rw-r--r--media-libs/mesa/files/digest-mesa-7.0.23
-rw-r--r--media-libs/mesa/mesa-7.0.2.ebuild324
4 files changed, 347 insertions, 1 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index e0305ad3d95d..8c499ab8986d 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.160 2007/10/09 08:30:11 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.161 2007/11/10 23:17:07 dberkholz Exp $
+
+*mesa-7.0.2 (10 Nov 2007)
+
+ 10 Nov 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/7.0.2-glw.pc.in, +mesa-7.0.2.ebuild:
+ Bump to 7.0.2, with lots of bugfixes. I removed all keywords because I can't
+ get any 3D apps running besides glxgears, but I'd like to get reports from
+ others to help figure out whether my system's just broken.
09 Oct 2007; Donnie Berkholz <dberkholz@gentoo.org>;
-files/mesa-6.5.3-pthread.patch, -mesa-6.5.2.ebuild, -mesa-6.5.3.ebuild:
diff --git a/media-libs/mesa/files/7.0.2-glw.pc.in b/media-libs/mesa/files/7.0.2-glw.pc.in
new file mode 100644
index 000000000000..951e2dc2af5d
--- /dev/null
+++ b/media-libs/mesa/files/7.0.2-glw.pc.in
@@ -0,0 +1,11 @@
+prefix=@INSTALL_DIR@
+exec_prefix=${prefix}
+libdir=${exec_prefix}/@LIB_DIR@
+includedir=${prefix}/include
+
+Name: glw
+Description: Mesa OpenGL widget library
+Requires: gl
+Version: @VERSION@
+Libs: -L${libdir} -lGLU
+Cflags: -I${includedir}
diff --git a/media-libs/mesa/files/digest-mesa-7.0.2 b/media-libs/mesa/files/digest-mesa-7.0.2
new file mode 100644
index 000000000000..2ee6fc9f2437
--- /dev/null
+++ b/media-libs/mesa/files/digest-mesa-7.0.2
@@ -0,0 +1,3 @@
+MD5 93e6ed7924ff069a4f883b4fce5349dc MesaLib-7.0.2.tar.bz2 3353217
+RMD160 3d471062b60889baef48a1a4596de6e32e1530cf MesaLib-7.0.2.tar.bz2 3353217
+SHA256 9d4707b556960f6aef14480f91fcd4f868720f64321947ab1b2fd20e85ce7f9e MesaLib-7.0.2.tar.bz2 3353217
diff --git a/media-libs/mesa/mesa-7.0.2.ebuild b/media-libs/mesa/mesa-7.0.2.ebuild
new file mode 100644
index 000000000000..a74ae028d0b6
--- /dev/null
+++ b/media-libs/mesa/mesa-7.0.2.ebuild
@@ -0,0 +1,324 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.0.2.ebuild,v 1.1 2007/11/10 23:17:07 dberkholz Exp $
+
+inherit eutils toolchain-funcs multilib flag-o-matic portability versionator
+
+OPENGL_DIR="xorg-x11"
+
+MY_PN="${PN/m/M}"
+MY_P="${MY_PN}-${PV//_}"
+MY_SRC_P="${MY_PN}Lib-${PV//_}"
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+if [[ $PV = *_rc* ]]; then
+ SRC_URI="http://www.mesa3d.org/beta/${MY_SRC_P}.tar.gz"
+else
+ SRC_URI="mirror://sourceforge/mesa3d/${MY_SRC_P}.tar.bz2"
+fi
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE_VIDEO_CARDS="
+ video_cards_i810
+ video_cards_mach64
+ video_cards_mga
+ video_cards_none
+ video_cards_r128
+ video_cards_radeon
+ video_cards_s3virge
+ video_cards_savage
+ video_cards_sis
+ video_cards_sunffb
+ video_cards_tdfx
+ video_cards_trident
+ video_cards_via"
+IUSE="${IUSE_VIDEO_CARDS}
+ debug
+ doc
+ hardened
+ motif
+ nptl
+ xcb
+ kernel_FreeBSD"
+
+RDEPEND="dev-libs/expat
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXxf86vm
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXdamage
+ >=x11-libs/libdrm-2.2
+ x11-libs/libICE
+ motif? ( virtual/motif )
+ doc? ( app-doc/opengl-manpages )
+ !<=x11-base/xorg-x11-6.9
+ xcb? ( x11-libs/libxcb )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ x11-misc/makedepend
+ x11-proto/inputproto
+ x11-proto/xextproto
+ app-admin/eselect-opengl
+ !hppa? ( x11-proto/xf86driproto )
+ x11-proto/xf86vidmodeproto
+ >=x11-proto/glproto-1.4.8
+ motif? ( x11-proto/printproto )"
+
+S="${WORKDIR}/${MY_P}"
+
+# Think about: ggi, svga, fbcon, no-X configs
+
+pkg_setup() {
+ if use xcb; then
+ if ! built_with_use x11-libs/libX11 xcb; then
+ msg="You must build libX11 with xcb enabled."
+ eerror ${msg}
+ die ${msg}
+ fi
+ fi
+
+ if use debug; then
+ strip-flags
+ append-flags -g
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
+ if use x86-fbsd; then
+ CONFIG="freebsd-dri-x86"
+ elif use amd64-fbsd; then
+ CONFIG="freebsd-dri-amd64"
+ elif use kernel_FreeBSD; then
+ CONFIG="freebsd-dri"
+ elif use x86; then
+ CONFIG="linux-dri-x86"
+ elif use amd64; then
+ [[ ${ABI} == "amd64" ]] && CONFIG="linux-dri-x86-64"
+ [[ ${ABI} == "x86" ]] && CONFIG="linux-dri-x86"
+ elif use ppc; then
+ CONFIG="linux-dri-ppc"
+ else
+ CONFIG="linux-dri"
+ fi
+}
+
+src_unpack() {
+ HOSTCONF="${S}/configs/${CONFIG}"
+
+ unpack ${A}
+ cd "${S}"
+
+ # Upstream forgot to include this file in tarball for 7.0.2
+ # but it's in git, so this is a copy from the git repository
+ cp "${FILESDIR}"/${PV}-glw.pc.in "${S}"/src/glw/glw.pc.in || die
+
+ # FreeBSD 6.* doesn't have posix_memalign().
+ [[ ${CHOST} == *-freebsd6.* ]] && sed -i -e "s/-DHAVE_POSIX_MEMALIGN//" configs/freebsd{,-dri}
+
+ # Don't compile debug code with USE=-debug - bug #125004
+ if ! use debug; then
+ einfo "Removing DO_DEBUG defs in dri drivers..."
+ find src/mesa/drivers/dri -name *.[hc] -exec egrep -l "\#define\W+DO_DEBUG\W+1" {} \; | xargs sed -i -re "s/\#define\W+DO_DEBUG\W+1/\#define DO_DEBUG 0/" ;
+ fi
+
+ # Set up libdir
+ echo "LIB_DIR = $(get_libdir)" >> "${HOSTCONF}"
+
+ # Set default dri drivers directory
+ echo 'DRI_DRIVER_SEARCH_DIR = /usr/$(LIB_DIR)/dri' >> "${HOSTCONF}"
+
+ # Do we want thread-local storage (TLS)?
+ if use nptl; then
+ echo "ARCH_FLAGS += -DGLX_USE_TLS" >> "${HOSTCONF}"
+ fi
+
+ echo "X11_INCLUDES = `pkg-config --cflags-only-I x11`" >> "${HOSTCONF}"
+ if use xcb; then
+ echo "DEFINES += -DUSE_XCB" >> "${HOSTCONF}"
+ echo "X11_INCLUDES += `pkg-config --cflags-only-I xcb` `pkg-config --cflags-only-I x11-xcb` `pkg-config --cflags-only-I xcb-glx`" >> "${HOSTCONF}"
+ echo "GL_LIB_DEPS += `pkg-config --libs xcb` `pkg-config --libs x11-xcb` `pkg-config --libs xcb-glx`" >> "${HOSTCONF}"
+ fi
+
+ # Configurable DRI drivers
+ driver_enable video_cards_i810 i810 i915 i915tex i965
+ driver_enable video_cards_mach64 mach64
+ driver_enable video_cards_mga mga
+ driver_enable video_cards_r128 r128
+ driver_enable video_cards_radeon radeon r200 r300
+ driver_enable video_cards_s3virge s3v
+ driver_enable video_cards_savage savage
+ driver_enable video_cards_sis sis
+ driver_enable video_cards_sunffb ffb
+ driver_enable video_cards_tdfx tdfx
+ driver_enable video_cards_trident trident
+ driver_enable video_cards_via unichrome
+
+ # Set drivers to everything on which we ran driver_enable()
+ echo "DRI_DIRS = ${DRI_DRIVERS}" >> "${HOSTCONF}"
+
+ if use hardened; then
+ einfo "Deactivating assembly code for hardened build"
+ echo "ASM_FLAGS =" >> "${HOSTCONF}"
+ echo "ASM_SOURCES =" >> "${HOSTCONF}"
+ echo "ASM_API =" >> "${HOSTCONF}"
+ fi
+
+ if use sparc; then
+ einfo "Sparc assembly code is not working; deactivating"
+ echo "ASM_FLAGS =" >> "${HOSTCONF}"
+ echo "ASM_SOURCES =" >> "${HOSTCONF}"
+ fi
+
+ # Replace hardcoded /usr/X11R6 with this
+ echo "EXTRA_LIB_PATH = `pkg-config --libs-only-L x11`" >> "${HOSTCONF}"
+
+ echo 'CFLAGS = $(OPT_FLAGS) $(PIC_FLAGS) $(ARCH_FLAGS) $(DEFINES) $(ASM_FLAGS)' >> "${HOSTCONF}"
+ echo "OPT_FLAGS = ${CFLAGS}" >> "${HOSTCONF}"
+ echo "CC = $(tc-getCC)" >> "${HOSTCONF}"
+ echo "CXX = $(tc-getCXX)" >> "${HOSTCONF}"
+ # bug #110840 - Build with PIC, since it hasn't been shown to slow it down
+ echo "PIC_FLAGS = -fPIC" >> "${HOSTCONF}"
+
+ # Removed glut, since we have separate freeglut/glut ebuilds
+ # Remove EGL, since Brian Paul says it's not ready for a release
+ echo "SRC_DIRS = glx/x11 mesa glu glw" >> "${HOSTCONF}"
+
+ # Get rid of glut includes
+ rm -f "${S}"/include/GL/glut*h
+
+ # Documented in configs/default
+ if use motif; then
+ # Add -lXm
+ echo "GLW_LIB_DEPS += -lXm" >> "${HOSTCONF}"
+ # Add GLwMDrawA.c
+ echo "GLW_SOURCES += GLwMDrawA.c" >> "${HOSTCONF}"
+ fi
+
+ # Shut up pointless warnings
+# echo "MKDEP = gcc -M" >> "${HOSTCONF}"
+# echo "MKDEP_OPTIONS = -MF depend" >> "${HOSTCONF}"
+ echo "MKDEP_OPTIONS = -fdepend -I$(gcc-config -L)/include" >> "${HOSTCONF}"
+ echo "INSTALL_DIR = /usr" >> "${HOSTCONF}"
+ echo 'DRI_DRIVER_INSTALL_DIR = /usr/$(LIB_DIR)/dri' >> "${HOSTCONF}"
+}
+
+src_compile() {
+ emake -j1 ${CONFIG} || die "Build failed"
+}
+
+src_install() {
+ dodir /usr
+ emake -j1 \
+ DESTDIR="${D}" \
+ install || die "Installation failed"
+
+ if ! use motif; then
+ rm "${D}"/usr/include/GL/GLwMDrawA.h
+ fi
+
+ # Don't install private headers
+ rm -f "${D}"/usr/include/GL/GLw*P.h
+
+ fix_opengl_symlinks
+ dynamic_libgl_install
+
+ # Install libtool archives
+ insinto /usr/$(get_libdir)
+ # (#67729) Needs to be lib, not $(get_libdir)
+ doins "${FILESDIR}"/lib/libGLU.la
+ sed -e "s:\${libdir}:$(get_libdir):g" "${FILESDIR}"/lib/libGL.la \
+ > "${D}"/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
+
+ # On *BSD libcs dlopen() and similar functions are present directly in
+ # libc.so and does not require linking to libdl. portability eclass takes
+ # care of finding the needed library (if needed) witht the dlopen_lib
+ # function.
+ sed -i -e 's:-ldl:'$(dlopen_lib)':g' \
+ "${D}"/usr/$(get_libdir)/libGLU.la \
+ "${D}"/usr/$(get_libdir)/opengl/xorg-x11/lib/libGL.la
+
+ # Create the two-number versioned libs (.so.#.#), since only .so.# and
+ # .so.#.#.# were made
+ local MAJOR_2="$(printf "%.2i" $(get_version_component_range 1 ${PV}))"
+ local MINOR_2="$(printf "%.2i" $(get_version_component_range 2 ${PV}))"
+ local MICRO_2="$(printf "%.2i" $(get_version_component_range 3 ${PV}))"
+ dosym \
+ libGLU.so.1.3.${MAJOR_2}${MINOR_2}${MICRO_2} \
+ /usr/$(get_libdir)/libGLU.so.1.3
+ dosym libGLw.so.1.0.0 /usr/$(get_libdir)/libGLw.so.1.0
+
+ # libGLU doesn't get the plain .so symlink either
+ dosym libGLU.so.1 /usr/$(get_libdir)/libGLU.so
+
+ # Figure out why libGL.so.1.5 is built (directfb), and why it's linked to
+ # as the default libGL.so.1
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+fix_opengl_symlinks() {
+ # Remove invalid symlinks
+ local LINK
+ for LINK in $(find "${D}"/usr/$(get_libdir) \
+ -name libGL\.* -type l); do
+ rm -f ${LINK}
+ done
+ # Create required symlinks
+ if [[ ${CHOST} == *-freebsd* ]]; then
+ # FreeBSD doesn't use major.minor versioning, so the library is only
+ # libGL.so.1 and no libGL.so.1.2 is ever used there, thus only create
+ # libGL.so symlink and leave libGL.so.1 being the real thing
+ dosym libGL.so.1 /usr/$(get_libdir)/libGL.so
+ else
+ dosym libGL.so.1.2 /usr/$(get_libdir)/libGL.so
+ dosym libGL.so.1.2 /usr/$(get_libdir)/libGL.so.1
+ fi
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving libGL and friends for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
+ local x=""
+ for x in "${D}"/usr/$(get_libdir)/libGL.so* \
+ "${D}"/usr/$(get_libdir)/libGL.la \
+ "${D}"/usr/$(get_libdir)/libGL.a; do
+ if [ -f ${x} -o -L ${x} ]; then
+ # libGL.a cause problems with tuxracer, etc
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib
+ fi
+ done
+ # glext.h added for #54984
+ for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}
+
+# $1 - VIDEO_CARDS flag
+# other args - names of DRI drivers to enable
+driver_enable() {
+ if use $1; then
+ shift
+ DRI_DRIVERS="${DRI_DRIVERS} $@"
+ fi
+}