summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-12-20 23:22:45 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-12-20 23:22:45 +0000
commit7f6c91d1c211b7b2f8ac98a5843607198af652d4 (patch)
treeab63dd3561f842cf5f5d993816b47b75e064b2ca /media-libs
parentAdded an upstream patch to fix 64-bit issues causing problems in some applica... (diff)
downloadgentoo-2-7f6c91d1c211b7b2f8ac98a5843607198af652d4.tar.gz
gentoo-2-7f6c91d1c211b7b2f8ac98a5843607198af652d4.tar.bz2
gentoo-2-7f6c91d1c211b7b2f8ac98a5843607198af652d4.zip
Revision bump. Added PDEPEND on app-admin/eselect-fontconfig.
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/fontconfig/ChangeLog7
-rw-r--r--media-libs/fontconfig/files/digest-fontconfig-2.5.0-r13
-rw-r--r--media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild90
3 files changed, 99 insertions, 1 deletions
diff --git a/media-libs/fontconfig/ChangeLog b/media-libs/fontconfig/ChangeLog
index dac4fbe855cd..0e6e2c9a9e84 100644
--- a/media-libs/fontconfig/ChangeLog
+++ b/media-libs/fontconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/fontconfig
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.99 2007/11/14 23:11:57 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/ChangeLog,v 1.100 2007/12/20 23:22:45 dirtyepic Exp $
+
+*fontconfig-2.5.0-r1 (20 Dec 2007)
+
+ 20 Dec 2007; Ryan Hill <dirtyepic@gentoo.org> +fontconfig-2.5.0-r1.ebuild:
+ Revision bump. Added PDEPEND on app-admin/eselect-fontconfig.
*fontconfig-2.5.0 (14 Nov 2007)
diff --git a/media-libs/fontconfig/files/digest-fontconfig-2.5.0-r1 b/media-libs/fontconfig/files/digest-fontconfig-2.5.0-r1
new file mode 100644
index 000000000000..7b3b51ab0763
--- /dev/null
+++ b/media-libs/fontconfig/files/digest-fontconfig-2.5.0-r1
@@ -0,0 +1,3 @@
+MD5 21d14af8ecf645ef76211c782cdd7aeb fontconfig-2.5.0.tar.gz 1385058
+RMD160 2c61ba3adc49aa5dd4eb081e13a849cc1d62d9da fontconfig-2.5.0.tar.gz 1385058
+SHA256 34c6badb4cb7eb496779d30616903de400fa244838ea39c2a7f63eaa5fdf0efe fontconfig-2.5.0.tar.gz 1385058
diff --git a/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild b/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..63a01d0c477e
--- /dev/null
+++ b/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.5.0-r1.ebuild,v 1.1 2007/12/20 23:22:45 dirtyepic Exp $
+
+inherit eutils libtool autotools
+
+DESCRIPTION="A library for configuring and customizing font access"
+HOMEPAGE="http://fontconfig.org/"
+SRC_URI="http://fontconfig.org/release/${P}.tar.gz"
+
+LICENSE="fontconfig"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc xml"
+
+RDEPEND=">=media-libs/freetype-2.1.4
+ !xml? ( >=dev-libs/expat-1.95.3 )
+ xml? ( >=dev-libs/libxml2-2.6 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )"
+PDEPEND="app-admin/eselect-fontconfig"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # add docbook switch so we can disable it
+ epatch "${FILESDIR}"/${PN}-2.3.2-docbook.patch
+
+ eautoreconf
+ epunt_cxx #74077
+}
+
+src_compile() {
+ # I'm thinking this should be removed
+ [[ ${ARCH} == alpha && ${CC} == ccc ]] && \
+ die "Dont compile fontconfig with ccc, it doesnt work very well"
+
+ # disable docs only disables local docs generation, they come with the tarball
+ econf $(use_enable doc docs) \
+ $(use_enable doc docbook) \
+ --localstatedir=/var \
+ --with-docdir=/usr/share/doc/${PF} \
+ --with-default-fonts=/usr/share/fonts \
+ --with-add-fonts=/usr/local/share/fonts \
+ $(use_enable xml libxml2) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ insinto /etc/fonts
+ doins "${S}"/fonts.conf
+
+ newman doc/fonts-conf.5 fonts.conf.5
+ dohtml doc/fontconfig-user.html
+ dodoc doc/fontconfig-user.{txt,pdf}
+
+ if use doc; then
+ doman doc/Fc*.3
+ dohtml doc/fontconfig-devel.html doc
+ dohtml -r doc/fontconfig-devel
+ dodoc doc/fontconfig-devel.{txt,pdf}
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Changes should be made to /etc/fonts/local.conf, and as we had
+ # too much problems with broken fonts.conf, we force update it ...
+ # <azarah@gentoo.org> (11 Dec 2002)
+ echo 'CONFIG_PROTECT_MASK="/etc/fonts/fonts.conf"' > "${T}"/37fontconfig
+ doenvd "${T}"/37fontconfig
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Please make fontconfig configuration changes in /etc/fonts/conf.d/"
+ ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
+ echo
+
+ if [[ ${ROOT} = / ]]; then
+ ebegin "Creating global font cache..."
+ /usr/bin/fc-cache -sr
+ eend $?
+ fi
+}