summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-11-17 03:44:14 +0000
committerMart Raudsepp <leio@gentoo.org>2009-11-17 03:44:14 +0000
commit985b54fe997417270f0d6969416d163b473ebee0 (patch)
treebca5f475b22cd9d2ef780d8dbaf16e4ecfab8053 /media-libs
parentVersion bump, also use internal ffmpeg, the system one is not from the same b... (diff)
downloadgentoo-2-985b54fe997417270f0d6969416d163b473ebee0.tar.gz
gentoo-2-985b54fe997417270f0d6969416d163b473ebee0.tar.bz2
gentoo-2-985b54fe997417270f0d6969416d163b473ebee0.zip
Version bump. Quicktime demuxer, FLV demuxer and RTP improvements; audio noise fixes in equalizer plugin; AVI demuxer push mode fixes and performance improvements, muxer fixes; automatic cropping support in videobox; interlaced Y4M file output support; various other bug fixes and improvements
(Portage version: 2.2_rc22/cvs/Linux 2.6.31-gentoo-r6 x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-good/ChangeLog12
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-0.10.17.ebuild58
2 files changed, 69 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-good/ChangeLog b/media-libs/gst-plugins-good/ChangeLog
index 1cd0a050371b..ad344666793f 100644
--- a/media-libs/gst-plugins-good/ChangeLog
+++ b/media-libs/gst-plugins-good/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-libs/gst-plugins-good
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.72 2009/11/10 16:09:55 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/ChangeLog,v 1.73 2009/11/17 03:44:14 leio Exp $
+
+*gst-plugins-good-0.10.17 (17 Nov 2009)
+
+ 17 Nov 2009; Mart Raudsepp <leio@gentoo.org>
+ +gst-plugins-good-0.10.17.ebuild:
+ Version bump. Quicktime demuxer, FLV demuxer and RTP improvements; audio
+ noise fixes in equalizer plugin; AVI demuxer push mode fixes and
+ performance improvements, muxer fixes; automatic cropping support in
+ videobox; interlaced Y4M file output support; various other bug fixes and
+ improvements
10 Nov 2009; Olivier Crête <tester@gentoo.org>
gst-plugins-good-0.10.16.ebuild:
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-0.10.17.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-0.10.17.ebuild
new file mode 100644
index 000000000000..acded390c643
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-0.10.17.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-good/gst-plugins-good-0.10.17.ebuild,v 1.1 2009/11/17 03:44:14 leio Exp $
+
+# order is important, gnome2 after gst-plugins
+inherit gst-plugins-good gst-plugins10 gnome2 eutils flag-o-matic libtool
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.net/"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=media-libs/gst-plugins-base-0.10.25
+ >=media-libs/gstreamer-0.10.25
+ >=dev-libs/liboil-0.3.14"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.11.5
+ dev-util/pkgconfig
+ !<media-libs/gst-plugins-bad-0.10.14"
+
+src_compile() {
+ # gst doesnt handle optimisations well
+ strip-flags
+ replace-flags "-O3" "-O2"
+ filter-flags "-fprefetch-loop-arrays" # see bug 22249
+
+ gst-plugins-good_src_configure \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ emake || die "emake failed."
+}
+
+# override eclass
+src_install() {
+ gnome2_src_install
+}
+
+DOCS="AUTHORS README RELEASE"
+
+pkg_postinst () {
+ gnome2_pkg_postinst
+
+ echo
+ elog "The Gstreamer plugins setup has changed quite a bit on Gentoo,"
+ elog "applications now should provide the basic plugins needed."
+ echo
+ elog "The new seperate plugins are all named 'gst-plugins-<plugin>'."
+ elog "To get a listing of currently available plugins execute 'emerge -s gst-plugins-'."
+ elog "In most cases it shouldn't be needed though to emerge extra plugins."
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}