summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-12-11 17:46:46 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2010-12-11 17:46:46 +0000
commitae9e7585b52edf03dcc8e4ff17a0d5f6488c1256 (patch)
tree7310c559661315a1320e631b66260ce261b00269 /media-libs
parentVersion bump. (diff)
downloadgentoo-2-ae9e7585b52edf03dcc8e4ff17a0d5f6488c1256.tar.gz
gentoo-2-ae9e7585b52edf03dcc8e4ff17a0d5f6488c1256.tar.bz2
gentoo-2-ae9e7585b52edf03dcc8e4ff17a0d5f6488c1256.zip
Add patch for nouveau libdrm-2.4.23 API changes.
(Portage version: 2.2.0_alpha5/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/mesa/ChangeLog9
-rw-r--r--media-libs/mesa/files/mesa-7.9-libdrm-2.4.23-nouveau-api.patch89
-rw-r--r--media-libs/mesa/mesa-7.9-r1.ebuild326
-rw-r--r--media-libs/mesa/mesa-7.9.ebuild3
4 files changed, 425 insertions, 2 deletions
diff --git a/media-libs/mesa/ChangeLog b/media-libs/mesa/ChangeLog
index beeb5ad7e031..0b797bba4ded 100644
--- a/media-libs/mesa/ChangeLog
+++ b/media-libs/mesa/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/mesa
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.297 2010/12/05 17:19:14 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/ChangeLog,v 1.298 2010/12/11 17:46:46 chithanh Exp $
+
+*mesa-7.9-r1 (11 Dec 2010)
+
+ 11 Dec 2010; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ mesa-7.9.ebuild, +mesa-7.9-r1.ebuild,
+ +files/mesa-7.9-libdrm-2.4.23-nouveau-api.patch:
+ Add patch for nouveau libdrm-2.4.23 API changes.
05 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
mesa-7.9.ebuild:
diff --git a/media-libs/mesa/files/mesa-7.9-libdrm-2.4.23-nouveau-api.patch b/media-libs/mesa/files/mesa-7.9-libdrm-2.4.23-nouveau-api.patch
new file mode 100644
index 000000000000..d0ce04d2682a
--- /dev/null
+++ b/media-libs/mesa/files/mesa-7.9-libdrm-2.4.23-nouveau-api.patch
@@ -0,0 +1,89 @@
+diff -ur a/src/gallium/drivers/nouveau/nouveau_screen.c b/src/gallium/drivers/nouveau/nouveau_screen.c
+--- a/src/gallium/drivers/nouveau/nouveau_screen.c 2010-10-02 00:51:28.000000000 +0200
++++ b/src/gallium/drivers/nouveau/nouveau_screen.c 2010-12-11 18:18:20.527000045 +0100
+@@ -236,7 +236,7 @@
+ int ret;
+
+ ret = nouveau_channel_alloc(dev, 0xbeef0201, 0xbeef0202,
+- &screen->channel);
++ 512*1024, &screen->channel);
+ if (ret)
+ return ret;
+ screen->device = dev;
+diff -ur a/src/mesa/drivers/dri/nouveau/nouveau_context.c b/src/mesa/drivers/dri/nouveau/nouveau_context.c
+--- a/src/mesa/drivers/dri/nouveau/nouveau_context.c 2010-10-05 03:58:00.000000000 +0200
++++ b/src/mesa/drivers/dri/nouveau/nouveau_context.c 2010-12-11 18:18:20.528000045 +0100
+@@ -129,7 +129,7 @@
+
+ /* Allocate a hardware channel. */
+ ret = nouveau_channel_alloc(context_dev(ctx), 0xbeef0201, 0xbeef0202,
+- &nctx->hw.chan);
++ 512*1024, &nctx->hw.chan);
+ if (ret) {
+ nouveau_error("Error initializing the FIFO.\n");
+ return GL_FALSE;
+Nur in b/src/mesa/drivers/dri/nouveau: nouveau_context.c.orig.
+diff -ur a/src/mesa/drivers/dri/nouveau/nouveau_surface.c b/src/mesa/drivers/dri/nouveau/nouveau_surface.c
+--- a/src/mesa/drivers/dri/nouveau/nouveau_surface.c 2010-04-27 23:41:21.000000000 +0200
++++ b/src/mesa/drivers/dri/nouveau/nouveau_surface.c 2010-12-11 18:09:19.750000046 +0100
+@@ -34,8 +34,8 @@
+ unsigned flags, unsigned format,
+ unsigned width, unsigned height)
+ {
+- unsigned tile_mode, cpp = _mesa_get_format_bytes(format);
+- int ret;
++ unsigned tile_mode = 0, tile_flags = 0;
++ int ret, cpp = _mesa_get_format_bytes(format);
+
+ nouveau_bo_ref(NULL, &s->bo);
+
+@@ -51,13 +51,21 @@
+ if (layout == TILED) {
+ s->pitch = align(s->pitch, 256);
+ tile_mode = s->pitch;
++
++ if (cpp == 4)
++ tile_flags = NOUVEAU_BO_TILE_32BPP;
++ else if (cpp == 2)
++ tile_flags = NOUVEAU_BO_TILE_16BPP;
++
++ if (_mesa_get_format_bits(format, GL_DEPTH_BITS))
++ tile_flags |= NOUVEAU_BO_TILE_ZETA;
++
+ } else {
+ s->pitch = align(s->pitch, 64);
+- tile_mode = 0;
+ }
+
+ ret = nouveau_bo_new_tile(context_dev(ctx), flags, 0, s->pitch * height,
+- tile_mode, 0, &s->bo);
++ tile_mode, tile_flags, &s->bo);
+ assert(!ret);
+ }
+
+diff -ur a/src/mesa/drivers/dri/nouveau/nouveau_vbo_t.c b/src/mesa/drivers/dri/nouveau/nouveau_vbo_t.c
+--- a/src/mesa/drivers/dri/nouveau/nouveau_vbo_t.c 2010-10-05 03:58:00.000000000 +0200
++++ b/src/mesa/drivers/dri/nouveau/nouveau_vbo_t.c 2010-12-11 18:18:20.528000045 +0100
+@@ -32,7 +32,7 @@
+
+ /* Arbitrary pushbuf length we can assume we can get with a single
+ * WAIT_RING. */
+-#define PUSHBUF_DWORDS 2048
++#define PUSHBUF_DWORDS 65536
+
+ /* Functions to set up struct nouveau_array_state from something like
+ * a GL array or index buffer. */
+diff -ur a/src/mesa/drivers/dri/nouveau/nv10_state_fb.c b/src/mesa/drivers/dri/nouveau/nv10_state_fb.c
+--- a/src/mesa/drivers/dri/nouveau/nv10_state_fb.c 2010-10-05 03:58:00.000000000 +0200
++++ b/src/mesa/drivers/dri/nouveau/nv10_state_fb.c 2010-12-11 18:15:17.756000046 +0100
+@@ -64,8 +64,8 @@
+
+ if (!nfb->lma_bo || nfb->lma_bo->size != size) {
+ nouveau_bo_ref(NULL, &nfb->lma_bo);
+- nouveau_bo_new(context_dev(ctx), NOUVEAU_BO_VRAM, 0, size,
+- &nfb->lma_bo);
++ nouveau_bo_new_tile(context_dev(ctx), NOUVEAU_BO_VRAM, 0, size,
++ 0, NOUVEAU_BO_TILE_ZETA, &nfb->lma_bo);
+ }
+
+ nouveau_bo_markl(bctx, celsius, NV17TCL_LMA_DEPTH_BUFFER_OFFSET,
diff --git a/media-libs/mesa/mesa-7.9-r1.ebuild b/media-libs/mesa/mesa-7.9-r1.ebuild
new file mode 100644
index 000000000000..999f4b7d90a6
--- /dev/null
+++ b/media-libs/mesa/mesa-7.9-r1.ebuild
@@ -0,0 +1,326 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.9-r1.ebuild,v 1.1 2010/12/11 17:46:46 chithanh Exp $
+
+EAPI=3
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/mesa"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git"
+ EXPERIMENTAL="true"
+fi
+
+inherit base autotools multilib flag-o-matic python toolchain-funcs ${GIT_ECLASS}
+
+OPENGL_DIR="xorg-x11"
+
+MY_PN="${PN/m/M}"
+MY_P="${MY_PN}-${PV/_/-}"
+MY_SRC_P="${MY_PN}Lib-${PV/_/-}"
+
+FOLDER="${PV/_rc*/}"
+[[ ${PV/_rc*/} == ${PV} ]] || FOLDER+="/RC"
+
+DESCRIPTION="OpenGL-like graphic library for Linux"
+HOMEPAGE="http://mesa3d.sourceforge.net/"
+
+#SRC_PATCHES="mirror://gentoo/${P}-gentoo-patches-01.tar.bz2"
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${FOLDER}/${MY_SRC_P}.tar.bz2
+ ${SRC_PATCHES}"
+fi
+
+LICENSE="LGPL-2 kilgard"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+
+INTEL_CARDS="intel"
+RADEON_CARDS="radeon"
+VIDEO_CARDS="${INTEL_CARDS} ${RADEON_CARDS} mach64 mga nouveau r128 savage sis vmware tdfx via"
+for card in ${VIDEO_CARDS}; do
+ IUSE_VIDEO_CARDS+=" video_cards_${card}"
+done
+
+IUSE="${IUSE_VIDEO_CARDS}
+ +classic debug +gallium gles llvm motif +nptl pic selinux kernel_FreeBSD"
+
+LIBDRM_DEPSTRING=">=x11-libs/libdrm-2.4.23"
+# keep correct libdrm and dri2proto dep
+# keep blocks in rdepend for binpkg
+RDEPEND="
+ !<x11-base/xorg-server-1.7
+ !<=x11-proto/xf86driproto-2.0.3
+ >=app-admin/eselect-mesa-0.0.3
+ >=app-admin/eselect-opengl-1.1.1-r2
+ dev-libs/expat
+ dev-libs/libxml2[python]
+ sys-libs/talloc
+ x11-libs/libICE
+ >=x11-libs/libX11-1.3.99.901
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ motif? ( x11-libs/openmotif )
+ gallium? (
+ llvm? (
+ amd64? ( dev-libs/udis86 )
+ x86? ( dev-libs/udis86 )
+ x86-fbsd? ( dev-libs/udis86 )
+ sys-devel/llvm
+ )
+ )
+ ${LIBDRM_DEPSTRING}[video_cards_nouveau?,video_cards_vmware?]
+"
+for card in ${INTEL_CARDS}; do
+ RDEPEND="${RDEPEND}
+ video_cards_${card}? ( ${LIBDRM_DEPSTRING}[video_cards_intel] )
+ "
+done
+
+for card in ${RADEON_CARDS}; do
+ RDEPEND="${RDEPEND}
+ video_cards_${card}? ( ${LIBDRM_DEPSTRING}[video_cards_radeon] )
+ "
+done
+
+DEPEND="${RDEPEND}
+ =dev-lang/python-2*
+ dev-util/pkgconfig
+ x11-misc/makedepend
+ >=x11-proto/dri2proto-2.2
+ >=x11-proto/glproto-1.4.11
+ x11-proto/inputproto
+ >=x11-proto/xextproto-7.0.99.1
+ x11-proto/xf86driproto
+ x11-proto/xf86vidmodeproto
+"
+
+S="${WORKDIR}/${MY_P}"
+
+# It is slow without texrels, if someone wants slow
+# mesa without texrels +pic use is worth the shot
+QA_EXECSTACK="usr/lib*/opengl/xorg-x11/lib/libGL.so*"
+QA_WX_LOAD="usr/lib*/opengl/xorg-x11/lib/libGL.so*"
+
+# Think about: ggi, fbcon, no-X configs
+
+pkg_setup() {
+ # gcc 4.2 has buggy ivopts
+ if [[ $(gcc-version) = "4.2" ]]; then
+ append-flags -fno-ivopts
+ fi
+
+ # recommended by upstream
+ append-flags -ffast-math
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_unpack() {
+ [[ $PV = 9999* ]] && git_src_unpack || base_src_unpack
+}
+
+src_prepare() {
+ # apply patches
+ if [[ ${PV} != 9999* && -n ${SRC_PATCHES} ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+ epatch "${FILESDIR}/${P}-libdrm-2.4.23-nouveau-api.patch"
+ # FreeBSD 6.* doesn't have posix_memalign().
+ if [[ ${CHOST} == *-freebsd6.* ]]; then
+ sed -i \
+ -e "s/-DHAVE_POSIX_MEMALIGN//" \
+ configure.ac || die
+ fi
+
+ # In order for mesa to complete it's build process we need to use a tool
+ # that it compiles. When we cross compile this clearly does not work
+ # so we require mesa to be built on the host system first. -solar
+ if tc-is-cross-compiler; then
+ sed -i -e "s#^GLSL_CL = .*\$#GLSL_CL = glsl_compiler#g" \
+ "${S}"/src/mesa/shader/slang/library/Makefile || die
+ fi
+
+ [[ $PV = 9999* ]] && git_src_prepare
+ base_src_prepare
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use classic; then
+ # Configurable DRI drivers
+ driver_enable swrast
+
+ # Intel code
+ driver_enable video_cards_intel i810 i915 i965
+
+ # Nouveau code
+ driver_enable video_cards_nouveau nouveau
+
+ # ATI code
+ driver_enable video_cards_radeon radeon r200 r300 r600
+
+ driver_enable video_cards_savage savage
+ driver_enable video_cards_sis sis
+ driver_enable video_cards_tdfx tdfx
+ driver_enable video_cards_via unichrome
+ fi
+
+ myconf="${myconf} $(use_enable gallium)"
+ if use !gallium && use !classic; then
+ ewarn "You enabled neither classic nor gallium USE flags. No hardware"
+ ewarn "drivers will be built."
+ fi
+ if use gallium; then
+ elog "You have enabled gallium infrastructure."
+ elog "This infrastructure currently support these drivers:"
+ elog " Intel: works only i915 and i965 somehow."
+ elog " LLVMpipe: Software renderer."
+ elog " Nouveau: Support for nVidia NV30 and later cards."
+ elog " Radeon: Newest implementation of r300-r700 driver."
+ elog " Svga: VMWare Virtual GPU driver."
+ echo
+ myconf="${myconf}
+ --with-state-trackers=glx,dri,egl,vega
+ $(use_enable llvm gallium-llvm)
+ $(use_enable gles gles1)
+ $(use_enable gles gles2)
+ $(use_enable gles gles-overlay)
+ $(use_enable video_cards_vmware gallium-svga)
+ $(use_enable video_cards_nouveau gallium-nouveau)
+ $(use_enable video_cards_intel gallium-i915)
+ $(use_enable video_cards_intel gallium-i965)
+ $(use_enable video_cards_radeon gallium-radeon)
+ $(use_enable video_cards_radeon gallium-r600)"
+ else
+ if use video_cards_nouveau || use video_cards_vmware; then
+ elog "SVGA and nouveau drivers are available only via gallium interface."
+ elog "Enable gallium useflag if you want to use them."
+ fi
+ fi
+
+ # --with-driver=dri|xlib|osmesa || do we need osmesa?
+ econf \
+ --disable-option-checking \
+ --with-driver=dri \
+ --disable-glut \
+ --without-demos \
+ --enable-xcb \
+ $(use_enable debug) \
+ $(use_enable motif glw) \
+ $(use_enable motif) \
+ $(use_enable nptl glx-tls) \
+ $(use_enable !pic asm) \
+ --with-dri-drivers=${DRI_DRIVERS} \
+ ${myconf}
+}
+
+src_install() {
+ base_src_install
+
+ # Save the glsl-compiler for later use
+ if ! tc-is-cross-compiler; then
+ dobin "${S}"/src/glsl/glsl_compiler || die
+ fi
+ # Remove redundant headers
+ # GLUT thing
+ rm -f "${D}"/usr/include/GL/glut*.h || die "Removing glut include failed."
+ # Glew includes
+ rm -f "${D}"/usr/include/GL/{glew,glxew,wglew}.h \
+ || die "Removing glew includes failed."
+
+ # Install config file for eselect mesa
+ insinto /usr/share/mesa
+ newins "${FILESDIR}/eselect-mesa.conf.7.9" eselect-mesa.conf || die
+
+ # Move libGL and others from /usr/lib to /usr/lib/opengl/blah/lib
+ # because user can eselect desired GL provider.
+ ebegin "Moving libGL and friends for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/{lib,extensions,include}
+ local x
+ for x in "${D}"/usr/$(get_libdir)/libGL.{la,a,so*}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f "${x}" "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/lib \
+ || die "Failed to move ${x}"
+ fi
+ done
+ for x in "${D}"/usr/include/GL/{gl.h,glx.h,glext.h,glxext.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f "${x}" "${D}"/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include \
+ || die "Failed to move ${x}"
+ fi
+ done
+ eend $?
+
+ if use classic || use gallium; then
+ ebegin "Moving DRI/Gallium drivers for dynamic switching"
+ local gallium_drivers=( i915_dri.so i965_dri.so r300_dri.so r600_dri.so swrast_dri.so )
+ dodir /usr/$(get_libdir)/mesa
+ for x in ${gallium_drivers[@]}; do
+ if [ -f "${S}/$(get_libdir)/gallium/${x}" ]; then
+ mv -f "${D}/usr/$(get_libdir)/dri/${x}" "${D}/usr/$(get_libdir)/dri/${x/_dri.so/g_dri.so}" \
+ || die "Failed to move ${x}"
+ insinto "/usr/$(get_libdir)/dri/"
+ if [ -f "${S}/$(get_libdir)/${x}" ]; then
+ insopts -m0755
+ doins "${S}/$(get_libdir)/${x}" || die "failed to install ${x}"
+ fi
+ fi
+ done
+ for x in "${D}"/usr/$(get_libdir)/dri/*.so; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f "${x}" "${x/dri/mesa}" \
+ || die "Failed to move ${x}"
+ fi
+ done
+ pushd "${D}"/usr/$(get_libdir)/dri || die "pushd failed"
+ ln -s ../mesa/*.so . || die "Creating symlink failed"
+ # remove symlinks to drivers known to eselect
+ for x in ${gallium_drivers[@]}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ rm "${x}" || die "Failed to remove ${x}"
+ fi
+ done
+ popd
+ eend $?
+ fi
+}
+
+pkg_postinst() {
+ # Switch to the xorg implementation.
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+ # Select classic/gallium drivers
+ eselect mesa set --auto
+}
+
+# $1 - VIDEO_CARDS flag
+# other args - names of DRI drivers to enable
+driver_enable() {
+ case $# in
+ # for enabling unconditionally
+ 1)
+ DRI_DRIVERS+=",$1"
+ ;;
+ *)
+ if use $1; then
+ shift
+ for i in $@; do
+ DRI_DRIVERS+=",${i}"
+ done
+ fi
+ ;;
+ esac
+}
diff --git a/media-libs/mesa/mesa-7.9.ebuild b/media-libs/mesa/mesa-7.9.ebuild
index 20b7f0711b55..e4a6105ea63d 100644
--- a/media-libs/mesa/mesa-7.9.ebuild
+++ b/media-libs/mesa/mesa-7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.9.ebuild,v 1.3 2010/12/05 17:19:14 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-7.9.ebuild,v 1.4 2010/12/11 17:46:46 chithanh Exp $
EAPI=3
@@ -75,6 +75,7 @@ RDEPEND="
)
)
${LIBDRM_DEPSTRING}[video_cards_nouveau?,video_cards_vmware?]
+ video_cards_nouveau? ( <x11-libs/libdrm-2.4.23 )
"
for card in ${INTEL_CARDS}; do
RDEPEND="${RDEPEND}