summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-09-01 16:46:58 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-09-01 16:46:58 +0000
commitd1bf5c18c4b6bce247bdab54466a505ff47227d7 (patch)
tree830d2e3f3f1178f3a84b1c6247a22f4a6803a2a1 /media-libs
parentVersion bump, with a backported patch from upstream fixing build with GCC 4.8... (diff)
downloadgentoo-2-d1bf5c18c4b6bce247bdab54466a505ff47227d7.tar.gz
gentoo-2-d1bf5c18c4b6bce247bdab54466a505ff47227d7.tar.bz2
gentoo-2-d1bf5c18c4b6bce247bdab54466a505ff47227d7.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-base/ChangeLog8
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.0.10.ebuild90
2 files changed, 97 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-base/ChangeLog b/media-libs/gst-plugins-base/ChangeLog
index c62c57aa3003..1d418aaf3ef4 100644
--- a/media-libs/gst-plugins-base/ChangeLog
+++ b/media-libs/gst-plugins-base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/gst-plugins-base
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.223 2013/08/26 21:26:12 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/ChangeLog,v 1.224 2013/09/01 16:46:58 eva Exp $
+
+*gst-plugins-base-1.0.10 (01 Sep 2013)
+
+ 01 Sep 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +gst-plugins-base-1.0.10.ebuild:
+ Version bump.
*gst-plugins-base-1.0.8 (26 Aug 2013)
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.0.10.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.0.10.ebuild
new file mode 100644
index 000000000000..b523ba4e194c
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.0.10.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gst-plugins-base/gst-plugins-base-1.0.10.ebuild,v 1.1 2013/09/01 16:46:58 eva Exp $
+
+EAPI="5"
+
+inherit gst-plugins-base gst-plugins10
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa +introspection ivorbis +ogg +orc +pango theora +vorbis X"
+REQUIRED_USE="
+ ivorbis? ( ogg )
+ theora? ( ogg )
+ vorbis? ( ogg )
+"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.32:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ sys-libs/zlib
+ alsa? ( >=media-libs/alsa-lib-0.9.1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+ ivorbis? ( media-libs/tremor )
+ ogg? ( >=media-libs/libogg-1 )
+ orc? ( >=dev-lang/orc-0.4.16 )
+ pango? ( >=x11-libs/pango-1.22 )
+ theora? ( >=media-libs/libtheora-1.1[encode] )
+ vorbis? ( >=media-libs/libvorbis-1 )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXv )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ X? (
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xproto )
+"
+
+src_prepare() {
+ # The AC_PATH_XTRA macro unnecessarily pulls in libSM and libICE even
+ # though they are not actually used. This needs to be fixed upstream by
+ # replacing AC_PATH_XTRA with PKG_CONFIG calls.
+ sed -i -e 's:X_PRE_LIBS -lSM -lICE:X_PRE_LIBS:' "${S}"/configure || die
+}
+
+src_configure() {
+ gst-plugins10_src_configure \
+ $(use_enable alsa) \
+ $(use_enable introspection) \
+ $(use_enable ivorbis) \
+ $(use_enable ogg) \
+ $(use_enable orc) \
+ $(use_enable pango) \
+ $(use_enable theora) \
+ $(use_enable vorbis) \
+ $(use_enable X x) \
+ $(use_enable X xshm) \
+ $(use_enable X xvideo) \
+ --disable-debug \
+ --disable-examples \
+ --disable-freetypetest \
+ --disable-static
+ # cdparanoia and libvisual are split out, per leio's request
+
+ # bug #366931, flag-o-matic for the whole thing is overkill
+ if [[ ${CHOST} == *86-*-darwin* ]] ; then
+ sed -i \
+ -e '/FLAGS = /s|-O[23]|-O1|g' \
+ gst/audioconvert/Makefile \
+ gst/volume/Makefile || die
+ fi
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ DOCS="AUTHORS NEWS README RELEASE"
+ default
+ prune_libtool_files --modules
+}