summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 22:16:39 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-10-28 22:16:39 +0000
commitee8e9e3d67851bbb23a534f936de70d1898e3e51 (patch)
tree67f61018d98cd2daeea77fc0e72df10191cc9245 /media-libs
parentCosmetic: unneeded newline. (diff)
downloadgentoo-2-ee8e9e3d67851bbb23a534f936de70d1898e3e51.tar.gz
gentoo-2-ee8e9e3d67851bbb23a534f936de70d1898e3e51.tar.bz2
gentoo-2-ee8e9e3d67851bbb23a534f936de70d1898e3e51.zip
Add clutter-1.8 from the gnome overlay, needed for gnome-3.2. Notable changes: cogl split off into a separate package; new actions added; a11y improvements; font rendering improvements.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/clutter/ChangeLog10
-rw-r--r--media-libs/clutter/clutter-1.8.2.ebuild84
2 files changed, 93 insertions, 1 deletions
diff --git a/media-libs/clutter/ChangeLog b/media-libs/clutter/ChangeLog
index f7033bd405ec..f50f97a42e57 100644
--- a/media-libs/clutter/ChangeLog
+++ b/media-libs/clutter/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-libs/clutter
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.43 2011/10/21 14:28:09 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/ChangeLog,v 1.44 2011/10/28 22:16:39 tetromino Exp $
+
+*clutter-1.8.2 (28 Oct 2011)
+
+ 28 Oct 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +clutter-1.8.2.ebuild:
+ Add clutter-1.8 from the gnome overlay, needed for gnome-3.2. Notable
+ changes: cogl split off into a separate package; new actions added; a11y
+ improvements; font rendering improvements.
21 Oct 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> clutter-1.6.20.ebuild:
x86 stable wrt bug #385699
diff --git a/media-libs/clutter/clutter-1.8.2.ebuild b/media-libs/clutter/clutter-1.8.2.ebuild
new file mode 100644
index 000000000000..b0e1ea69d074
--- /dev/null
+++ b/media-libs/clutter/clutter-1.8.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/clutter/clutter-1.8.2.ebuild,v 1.1 2011/10/28 22:16:39 tetromino Exp $
+
+EAPI="4"
+CLUTTER_LA_PUNT="yes"
+WANT_AUTOMAKE="1.11"
+
+# Inherit gnome2 after clutter to download sources from gnome.org
+# since clutter-project.org doesn't provide .xz tarballs
+inherit clutter gnome2
+
+DESCRIPTION="Clutter is a library for creating graphical user interfaces"
+
+SLOT="1.0"
+IUSE="debug doc +introspection"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+# NOTE: glx flavour uses libdrm + >=mesa-7.3
+# XXX: uprof needed for profiling
+# >=libX11-1.3.1 needed for X Generic Event support
+RDEPEND="
+ >=dev-libs/glib-2.28:2
+ >=dev-libs/atk-2.1.5[introspection?]
+ >=dev-libs/json-glib-0.12[introspection?]
+ >=media-libs/cogl-1.8.0:1.0[introspection?,pango]
+ media-libs/fontconfig
+ >=x11-libs/cairo-1.10[glib]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/pango-1.20[introspection?]
+
+ virtual/opengl
+ x11-libs/libdrm
+ >=x11-libs/libX11-1.3.1
+ x11-libs/libXext
+ x11-libs/libXdamage
+ x11-proto/inputproto
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXfixes-3
+ >=x11-libs/libXcomposite-0.4
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig
+ >=dev-util/gtk-doc-am-1.13
+ doc? (
+ >=dev-util/gtk-doc-1.13
+ >=app-text/docbook-sgml-utils-0.6.14[jadetex]
+ dev-libs/libxslt )"
+
+pkg_setup() {
+ DOCS="README NEWS ChangeLog*"
+
+ # XXX: Conformance test suite (and clutter itself) does not work under Xvfb
+ # XXX: Profiling, coverage disabled for now
+ # XXX: What about eglx/eglnative/opengl-egl-xlib/osx/wayland/etc flavours?
+ # Uses gudev-1.0 and libxkbcommon for eglnative/cex1000
+ myconf="--enable-debug=minimum"
+ use debug && myconf="--enable-debug=yes"
+ G2CONF="${G2CONF} ${myconf}
+ --enable-conformance=no
+ --disable-gcov
+ --enable-profile=no
+ --enable-maintainer-flags=no
+ --enable-xinput
+ --with-flavour=glx
+ $(use_enable introspection)
+ $(use_enable doc docs)"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # We only need conformance tests, the rest are useless for us
+ sed -e 's/^\(SUBDIRS =\).*/\1/g' \
+ -i tests/Makefile.am || die "am tests sed failed"
+ sed -e 's/^\(SUBDIRS =\)[^\]*/\1/g' \
+ -i tests/Makefile.in || die "in tests sed failed"
+}
+
+src_install() {
+ clutter_src_install
+}