summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-06-28 08:49:51 +0000
committerTim Harder <radhermit@gentoo.org>2012-06-28 08:49:51 +0000
commitf23fb8c073899207e288d97bc28db2b1db7703fe (patch)
tree58d549611291a48b25c25dfa8bf32d9fd3a31384 /media-libs
parentBump (diff)
downloadgentoo-2-f23fb8c073899207e288d97bc28db2b1db7703fe.tar.gz
gentoo-2-f23fb8c073899207e288d97bc28db2b1db7703fe.tar.bz2
gentoo-2-f23fb8c073899207e288d97bc28db2b1db7703fe.zip
Version bump.
(Portage version: 2.2.0_alpha112/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libraw/ChangeLog8
-rw-r--r--media-libs/libraw/files/libraw-0.14.7-pkgconfig.patch9
-rw-r--r--media-libs/libraw/libraw-0.14.7.ebuild59
3 files changed, 75 insertions, 1 deletions
diff --git a/media-libs/libraw/ChangeLog b/media-libs/libraw/ChangeLog
index b72e551adb97..510e4e26d7d8 100644
--- a/media-libs/libraw/ChangeLog
+++ b/media-libs/libraw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/libraw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.27 2012/05/05 08:02:37 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/ChangeLog,v 1.28 2012/06/28 08:49:50 radhermit Exp $
+
+*libraw-0.14.7 (28 Jun 2012)
+
+ 28 Jun 2012; Tim Harder <radhermit@gentoo.org> +libraw-0.14.7.ebuild,
+ +files/libraw-0.14.7-pkgconfig.patch:
+ Version bump.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> libraw-0.14.5.ebuild,
libraw-0.14.6.ebuild:
diff --git a/media-libs/libraw/files/libraw-0.14.7-pkgconfig.patch b/media-libs/libraw/files/libraw-0.14.7-pkgconfig.patch
new file mode 100644
index 000000000000..b059c2b83fa3
--- /dev/null
+++ b/media-libs/libraw/files/libraw-0.14.7-pkgconfig.patch
@@ -0,0 +1,9 @@
+--- LibRaw-0.14.7/libraw_r.pc.in
++++ LibRaw-0.14.7/libraw_r.pc.in
+@@ -7,5 +7,5 @@
+ Description: Raw image decoder library (thread-safe)
+ Requires: @PACKAGE_REQUIRES@
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -lraw -lstdc++@PC_OPENMP@
++Libs: -L${libdir} -lraw_r -lstdc++@PC_OPENMP@
+ Cflags: -I${includedir}/libraw
diff --git a/media-libs/libraw/libraw-0.14.7.ebuild b/media-libs/libraw/libraw-0.14.7.ebuild
new file mode 100644
index 000000000000..6db0c4b265c8
--- /dev/null
+++ b/media-libs/libraw/libraw-0.14.7.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libraw/libraw-0.14.7.ebuild,v 1.1 2012/06/28 08:49:51 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils autotools toolchain-funcs
+
+MY_P="LibRaw-${PV}"
+DESCRIPTION="LibRaw is a library for reading RAW files obtained from digital photo cameras"
+HOMEPAGE="http://www.libraw.org/"
+SRC_URI="http://www.libraw.org/data/${MY_P}.tar.gz
+ demosaic? ( http://www.libraw.org/data/LibRaw-demosaic-pack-GPL2-${PV}.tar.gz
+ http://www.libraw.org/data/LibRaw-demosaic-pack-GPL3-${PV}.tar.gz )"
+
+# Libraw also has it's own license, which is a pdf file and
+# can be obtained from here:
+# http://www.libraw.org/data/LICENSE.LibRaw.pdf
+LICENSE="LGPL-2.1 CDDL GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="demosaic examples jpeg2k +lcms openmp static-libs"
+
+RDEPEND="jpeg2k? ( media-libs/jasper )
+ lcms? ( media-libs/lcms:2 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS=( Changelog.txt README )
+
+pkg_setup() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.13.4-docs.patch
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable demosaic demosaic-pack-gpl2) \
+ $(use_enable demosaic demosaic-pack-gpl3) \
+ $(use_enable examples) \
+ $(use_enable jpeg2k jasper) \
+ $(use_enable lcms) \
+ $(use_enable openmp) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}