summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-29 08:10:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-29 08:10:53 +0000
commitf2b0039ac52aeb8edbee326b554a872913e600af (patch)
tree562e906303a424ba987c64b1fc335fa21f52224b /media-libs
parentVersion bump. (diff)
downloadgentoo-2-f2b0039ac52aeb8edbee326b554a872913e600af.tar.gz
gentoo-2-f2b0039ac52aeb8edbee326b554a872913e600af.tar.bz2
gentoo-2-f2b0039ac52aeb8edbee326b554a872913e600af.zip
Grab some updates from upstream cvs to add support for SuperH.
(Portage version: 2.1_pre2)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libsdl/ChangeLog7
-rw-r--r--media-libs/libsdl/files/libsdl-1.2.9-endian-cvs-updates.patch48
-rw-r--r--media-libs/libsdl/libsdl-1.2.8-r1.ebuild5
-rw-r--r--media-libs/libsdl/libsdl-1.2.9-r1.ebuild5
-rw-r--r--media-libs/libsdl/libsdl-1.2.9.ebuild5
5 files changed, 63 insertions, 7 deletions
diff --git a/media-libs/libsdl/ChangeLog b/media-libs/libsdl/ChangeLog
index d8a26868e04b..d21c48dfe88b 100644
--- a/media-libs/libsdl/ChangeLog
+++ b/media-libs/libsdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libsdl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.94 2005/12/14 05:57:39 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/ChangeLog,v 1.95 2005/12/29 08:10:53 vapier Exp $
+
+ 29 Dec 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/libsdl-1.2.9-endian-cvs-updates.patch, libsdl-1.2.8-r1.ebuild,
+ libsdl-1.2.9.ebuild, libsdl-1.2.9-r1.ebuild:
+ Grab some updates from upstream cvs to add support for SuperH.
14 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
libsdl-1.2.9-r1.ebuild:
diff --git a/media-libs/libsdl/files/libsdl-1.2.9-endian-cvs-updates.patch b/media-libs/libsdl/files/libsdl-1.2.9-endian-cvs-updates.patch
new file mode 100644
index 000000000000..cd6121a6a091
--- /dev/null
+++ b/media-libs/libsdl/files/libsdl-1.2.9-endian-cvs-updates.patch
@@ -0,0 +1,48 @@
+grab some updates from upstream cvs to support some more architectures
+
+Index: include/SDL_byteorder.h
+===================================================================
+RCS file: /home/sdlweb/libsdl.org/cvs/SDL12/include/SDL_byteorder.h,v
+retrieving revision 1.9
+retrieving revision 1.11
+diff -u -p -r1.9 -r1.11
+--- include/SDL_byteorder.h 12 Nov 2004 22:09:17 -0000 1.9
++++ include/SDL_byteorder.h 23 Nov 2005 07:29:53 -0000 1.11
+@@ -34,6 +34,16 @@ static char rcsid =
+ #define SDL_LIL_ENDIAN 1234
+ #define SDL_BIG_ENDIAN 4321
+
++#ifdef __linux__
++# include <endian.h>
++# if BYTE_ORDER == LITTLE_ENDIAN
++# define SDL_BYTEORDER SDL_LIL_ENDIAN
++# else
++# define SDL_BYTEORDER SDL_BIG_ENDIAN
++# endif
++
++#else
++
+ /* Pardon the mess, I'm trying to determine the endianness of this host.
+ I'm doing it by preprocessor defines rather than some sort of configure
+ script so that application code can use this too. The "right" way would
+@@ -42,14 +52,16 @@ static char rcsid =
+ #if (defined(__i386__) || defined(__i386)) || \
+ defined(__ia64__) || defined(WIN32) || \
+ (defined(__alpha__) || defined(__alpha)) || \
+- defined(__arm__) || \
++ (defined(__arm__) || defined(__thumb__)) || \
++ (defined(__sh__) || defined(__sh64__)) || \
+ (defined(__mips__) && defined(__MIPSEL__)) || \
+- defined(__SYMBIAN32__) || \
+- defined(__x86_64__) || \
+- defined(__LITTLE_ENDIAN__)
++ defined(__SYMBIAN32__) || defined(__x86_64__) || \
++ defined(__OS2__) || defined(__LITTLE_ENDIAN__)
+ #define SDL_BYTEORDER SDL_LIL_ENDIAN
+ #else
+ #define SDL_BYTEORDER SDL_BIG_ENDIAN
+ #endif
+
++#endif /* __linux__ */
++
+ #endif /* _SDL_byteorder_h */
diff --git a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
index 88a6b542c001..34e3e1307c00 100644
--- a/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.24 2005/12/17 03:31:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.8-r1.ebuild,v 1.25 2005/12/29 08:10:53 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 sparc x86"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ~ppc-macos ppc64 sh sparc x86"
# WARNING:
# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
# in USE and something breaks, you pick up the pieces. Be prepared for
@@ -60,6 +60,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-sdl-config.patch
epatch "${FILESDIR}"/${P}-no-cxx.patch
epatch "${FILESDIR}"/libsdl-1.2.9-dlvsym-check.patch #105160
+ epatch "${FILESDIR}"/libsdl-1.2.9-endian-cvs-updates.patch
# This patch breaks compiling >-O0 on gcc4 ; bug #87809
[ "`gcc-major-version`" -lt "4" ] && epatch "${FILESDIR}"/${P}-gcc2.patch.bz2 #86481
diff --git a/media-libs/libsdl/libsdl-1.2.9-r1.ebuild b/media-libs/libsdl/libsdl-1.2.9-r1.ebuild
index c08b3d256515..f035d404a45b 100644
--- a/media-libs/libsdl/libsdl-1.2.9-r1.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9-r1.ebuild,v 1.6 2005/12/14 05:57:39 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9-r1.ebuild,v 1.7 2005/12/29 08:10:53 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
# WARNING:
# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
# in USE and something breaks, you pick up the pieces. Be prepared for
@@ -75,6 +75,7 @@ src_unpack() {
[[ $(gcc-major-version) != "2" ]] && epatch "${FILESDIR}"/libsdl-1.2.9-PIC-yuv-mmx.patch
epatch "${FILESDIR}"/${P}-sdl-blit-mmx-check.patch #104533
epatch "${FILESDIR}"/${P}-DirectFB-updates.patch
+ epatch "${FILESDIR}"/${P}-endian-cvs-updates.patch
./autogen.sh || die "autogen failed"
epunt_cxx
diff --git a/media-libs/libsdl/libsdl-1.2.9.ebuild b/media-libs/libsdl/libsdl-1.2.9.ebuild
index 08a79c65c5ae..5138fe34434f 100644
--- a/media-libs/libsdl/libsdl-1.2.9.ebuild
+++ b/media-libs/libsdl/libsdl-1.2.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9.ebuild,v 1.8 2005/10/29 02:47:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.2.9.ebuild,v 1.9 2005/12/29 08:10:53 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils
@@ -10,7 +10,7 @@ SRC_URI="http://www.libsdl.org/release/SDL-${PV}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sh ~sparc ~x86"
# WARNING:
# if you have the noaudio, novideo, nojoystick, or noflagstrip use flags
# in USE and something breaks, you pick up the pieces. Be prepared for
@@ -61,6 +61,7 @@ src_unpack() {
epatch "${FILESDIR}"/libsdl-1.2.9-dlvsym-check.patch #105160
epatch "${FILESDIR}"/1.2.8-gcc4.patch
epatch "${FILESDIR}"/${P}-DirectFB-updates.patch
+ epatch "${FILESDIR}"/${P}-endian-cvs-updates.patch
./autogen.sh || die "autogen failed"
epunt_cxx