summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2011-05-28 19:08:23 +0000
committerThomas Sachau <tommy@gentoo.org>2011-05-28 19:08:23 +0000
commitf79a4629c2f8fa6dd3157ceffe64b02a706e2c38 (patch)
tree375d0d4aeab4d0c01a50d69f167fda544e94bfd9 /media-libs
parentForce newer shadow versions in the whole tree #367633. (diff)
downloadgentoo-2-f79a4629c2f8fa6dd3157ceffe64b02a706e2c38.tar.gz
gentoo-2-f79a4629c2f8fa6dd3157ceffe64b02a706e2c38.tar.bz2
gentoo-2-f79a4629c2f8fa6dd3157ceffe64b02a706e2c38.zip
Adding workaround for bug 345161, forces yasm as as interpreter and adjusts the target platform for cross-compilation
(Portage version: 2.2.0_alpha37-r1/cvs/Linux x86_64)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/libvpx/ChangeLog6
-rw-r--r--media-libs/libvpx/libvpx-0.9.6.ebuild7
2 files changed, 11 insertions, 2 deletions
diff --git a/media-libs/libvpx/ChangeLog b/media-libs/libvpx/ChangeLog
index 424c807bf1d8..25d5e4f0458f 100644
--- a/media-libs/libvpx/ChangeLog
+++ b/media-libs/libvpx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-libs/libvpx
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.16 2011/05/16 16:39:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/ChangeLog,v 1.17 2011/05/28 19:08:23 tommy Exp $
+
+ 28 May 2011; Thomas Sachau (Tommy[D]) <tommy@gentoo.org> libvpx-0.9.6.ebuild:
+ Adding workaround for bug 345161, forces yasm as as interpreter and adjusts
+ the target platform for cross-compilation
16 May 2011; Kacper Kowalik <xarthisius@gentoo.org> libvpx-0.9.6.ebuild:
Marked ~ppc/~ppc64 wrt #360427
diff --git a/media-libs/libvpx/libvpx-0.9.6.ebuild b/media-libs/libvpx/libvpx-0.9.6.ebuild
index b2e699cf99e8..ba80f16a5f6e 100644
--- a/media-libs/libvpx/libvpx-0.9.6.ebuild
+++ b/media-libs/libvpx/libvpx-0.9.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-0.9.6.ebuild,v 1.2 2011/05/16 16:39:23 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libvpx/libvpx-0.9.6.ebuild,v 1.3 2011/05/28 19:08:23 tommy Exp $
EAPI=3
inherit eutils multilib toolchain-funcs
@@ -41,6 +41,10 @@ src_prepare() {
src_configure() {
tc-export CC
+ local archparams=""
+ [ "$ABI" = "x86" ] && archparams=" --target=x86-linux-gcc"
+ [ "$ABI" = "amd64" ] && archparams=" --target=x86_64-linux-gcc"
+ ( use x86 || use amd64 ) && archparams+=" --as=yasm"
./configure \
--prefix="${EPREFIX}"/usr \
--libdir="${EPREFIX}"/usr/$(get_libdir) \
@@ -58,6 +62,7 @@ src_configure() {
$(use_enable doc install-docs) \
$(use_enable postproc) \
$(use_enable threads multithread) \
+ $archparams \
|| die
}