summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Kalika <max@gentoo.org>2003-08-18 18:07:15 +0000
committerMax Kalika <max@gentoo.org>2003-08-18 18:07:15 +0000
commit526f87a364defb5717b00f056ada15a52f702a81 (patch)
tree0906d9b2dc1b89b82405b6442d1f53e257220d8c /media-plugins/mythgame
parentManifest fix. (diff)
downloadgentoo-2-526f87a364defb5717b00f056ada15a52f702a81.tar.gz
gentoo-2-526f87a364defb5717b00f056ada15a52f702a81.tar.bz2
gentoo-2-526f87a364defb5717b00f056ada15a52f702a81.zip
Bump version to 0.11.
Diffstat (limited to 'media-plugins/mythgame')
-rw-r--r--media-plugins/mythgame/ChangeLog7
-rw-r--r--media-plugins/mythgame/Manifest4
-rw-r--r--media-plugins/mythgame/files/digest-mythgame-0.111
-rw-r--r--media-plugins/mythgame/mythgame-0.11.ebuild67
4 files changed, 77 insertions, 2 deletions
diff --git a/media-plugins/mythgame/ChangeLog b/media-plugins/mythgame/ChangeLog
index 1f02dfe909aa..b71273b48fe1 100644
--- a/media-plugins/mythgame/ChangeLog
+++ b/media-plugins/mythgame/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-plugins/mythgame
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.3 2003/08/08 05:17:21 max Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/ChangeLog,v 1.4 2003/08/18 18:03:40 max Exp $
+
+*mythgame-0.11 (18 Aug 2003)
+
+ 18 Aug 2003; Max Kalika <max@gentoo.org> mythgame-0.11.ebuild:
+ Bump version to 0.11. Change make install to einstall.
07 Aug 2003; Max Kalika <max@gentoo.org> mythgame-0.10.ebuild:
Depend on either mythtv or mythfrontend.
diff --git a/media-plugins/mythgame/Manifest b/media-plugins/mythgame/Manifest
index 7a578d939f8b..9c5c6a4a10dc 100644
--- a/media-plugins/mythgame/Manifest
+++ b/media-plugins/mythgame/Manifest
@@ -1,3 +1,5 @@
+MD5 3c872516a4b019acc69a94db588fb58d mythgame-0.11.ebuild 1979
MD5 b5a65930fd5547384fa92e567bc0ee4a mythgame-0.10.ebuild 2012
-MD5 82f85b5bf0ad049ab70968a9ce694837 ChangeLog 1313
+MD5 f5a86ac164e7ed88098187d37fe7bc8b ChangeLog 1466
MD5 9b0262b1d9e5347fceb6265378d7bf2e files/digest-mythgame-0.10 65
+MD5 2bd60d4f779ab52e53d15145940b8946 files/digest-mythgame-0.11 65
diff --git a/media-plugins/mythgame/files/digest-mythgame-0.11 b/media-plugins/mythgame/files/digest-mythgame-0.11
new file mode 100644
index 000000000000..bf87bd15afb7
--- /dev/null
+++ b/media-plugins/mythgame/files/digest-mythgame-0.11
@@ -0,0 +1 @@
+MD5 c13dfb3a69afdd1cf954dfe91d8db6c3 mythgame-0.11.tar.bz2 50679
diff --git a/media-plugins/mythgame/mythgame-0.11.ebuild b/media-plugins/mythgame/mythgame-0.11.ebuild
new file mode 100644
index 000000000000..cbdb75d18e86
--- /dev/null
+++ b/media-plugins/mythgame/mythgame-0.11.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythgame/mythgame-0.11.ebuild,v 1.1 2003/08/18 18:03:40 max Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Game emulator module for MythTV."
+HOMEPAGE="http://www.mythtv.org/"
+SRC_URI="http://www.mythtv.org/mc/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="sys-libs/zlib
+ >=sys-apps/sed-4
+ || ( >=media-tv/mythtv-${PV} >=media-tv/mythfrontend-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+
+ for i in `grep -lr "usr/local" "${S}"` ; do
+ sed -e "s:/usr/local:/usr:" -i "${i}" || die "sed failed"
+ done
+}
+
+src_compile() {
+ cpu="`get-flag march`"
+ if [ ! -z "${cpu}" ] ; then
+ sed -e "s:pentiumpro:${cpu}:g" -i "${S}/settings.pro" || die "sed failed"
+ fi
+
+ qmake -o "${S}/Makefile" "${S}/${PN}.pro"
+
+ emake || die "compile problem"
+}
+
+src_install () {
+ einstall INSTALL_ROOT="${D}"
+
+ insinto "/usr/share/mythtv/database/${PN}"
+ doins gamedb/*.sql
+
+ dodoc README UPGRADING gamelist.xml
+}
+
+pkg_postinst() {
+ einfo "If this is the first time you install MythGame,"
+ einfo "you need to add /usr/share/mythtv/database/${PN}/metadata.sql"
+ einfo "/usr/share/mythtv/database/${PN}/nesdb.sql and "
+ einfo "/usr/share/mythtv/database/${PN}/snesdata.sql"
+ einfo "to your MythTV database in that order."
+ einfo
+ einfo "You might run in this order:"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/gamemetadata.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/nesdb.sql'"
+ einfo "'mysql < /usr/share/mythtv/database/${PN}/snesdata.sql'"
+ einfo
+ einfo "If you're upgrading from an older version and for more"
+ einfo "setup and usage instructions, please refer to:"
+ einfo " /usr/share/doc/${PF}/README.gz"
+ einfo " /usr/share/doc/${PF}/UPGRADING.gz"
+ ewarn "This part is important as there might be database changes"
+ ewarn "which need to be performed or this package will not work"
+ ewarn "properly."
+ echo
+}