summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2006-11-13 19:58:25 +0000
committerTom William Payne <twp@gentoo.org>2006-11-13 19:58:25 +0000
commit4253bf5d82adb8da5fa42763f11a0e04437ca8f1 (patch)
treecadcdb9cecaa94eacee6b74422b401768e098abc /media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild
parentInitial commit. Bug # 73832. (diff)
downloadgentoo-2-4253bf5d82adb8da5fa42763f11a0e04437ca8f1.tar.gz
gentoo-2-4253bf5d82adb8da5fa42763f11a0e04437ca8f1.tar.bz2
gentoo-2-4253bf5d82adb8da5fa42763f11a0e04437ca8f1.zip
Initial commit. Bug # 119891.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild')
-rw-r--r--media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild b/media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild
new file mode 100644
index 000000000000..9b94ccde3653
--- /dev/null
+++ b/media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/slimserver-alienbbc/slimserver-alienbbc-1.06.ebuild,v 1.1 2006/11/13 19:58:25 twp Exp $
+
+inherit eutils
+
+SLIMSERVER_VERSION="6.5"
+MY_P="alienbbc-linux-v${PV}_${SLIMSERVER_VERSION}"
+DESCRIPTION="A plugin for SlimServer for listening to RealAudio streams"
+HOMEPAGE="http://www.x2systems.com/AlienBBC/"
+SRC_URI="http://www.x2systems.com/AlienBBC/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RDEPEND="
+ >=media-sound/slimserver-${SLIMSERVER_VERSION}
+ >=media-video/mplayer-1.0_pre7"
+S="${WORKDIR}"
+
+pkg_preinst() {
+ if ! built_with_use media-video/mplayer live; then
+ eerror "media-video/mplayer not built with USE=live"
+ die "media-video/mplayer not built with USE=live"
+ fi
+ # FIXME does mplayer need to be built with USE=real?
+}
+
+src_install() {
+ dodir /opt/slimserver/.mplayer
+ touch ${D}/opt/slimserver/.mplayer/.config
+ cp -r * ${D}/opt/slimserver
+}