summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2006-02-27 23:30:40 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2006-02-27 23:30:40 +0000
commit230585bb5885cd624c2fc26ca2bd99383decde77 (patch)
tree6fa77601b91a23c06c0b64a344bfe5568c654b8a /media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild
parentBump 2.0.53 and 2.0.54 dependencies to >=dev-lang/python-2.3 due to usage of ... (diff)
downloadgentoo-2-230585bb5885cd624c2fc26ca2bd99383decde77.tar.gz
gentoo-2-230585bb5885cd624c2fc26ca2bd99383decde77.tar.bz2
gentoo-2-230585bb5885cd624c2fc26ca2bd99383decde77.zip
patch added to support vdr-radio, vdr-lcr on glcd; fixed pkg_preinst call; thx to C.Leuschen for the patch
(Portage version: 2.0.54)
Diffstat (limited to 'media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild')
-rw-r--r--media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild
index 96f29e0aeff1..115bb5ec33d7 100644
--- a/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild
+++ b/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild,v 1.2 2006/01/09 21:11:44 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-graphlcd/vdr-graphlcd-0.1.2_pre6-r1.ebuild,v 1.3 2006/02/27 23:30:40 hd_brummy Exp $
inherit eutils vdr-plugin
@@ -25,6 +25,8 @@ DEPEND=">=media-video/vdr-1.2.6
# DO NOT remove "!sys-apps/graphlcd-base" from DEPEND !!!
# It will fix a conflict with ebuilds in Gentoo.de OVERLAY CVS
+PATCHES="${FILESDIR}/0.1.2/*"
+
src_unpack() {
vdr-plugin_src_unpack
@@ -38,7 +40,7 @@ src_install() {
vdr-plugin_src_install
- insopts -m0644 -ovdr -gvideo
+ insopts -m0644 -ovdr -gvdr
insinto /usr/share/vdr/${VDRPLUGIN}/logos
doins -r ${VDRPLUGIN}/logos/*
@@ -68,10 +70,10 @@ src_install() {
fi
}
-pkg_preinstall() {
+pkg_preinst() {
- if [[ -e /etc/vdr/plugins/graphlcd/fonts ]] && [[ ! -L /etc/vdr/plugins/graphlcd/fonts ]] ||
- [[ -e /etc/vdr/plugins/graphlcd/logos ]] && [[ ! -L /etc/vdr/plugins/graphlcd/logos ]] ;then
+ if [[ -e /etc/vdr/plugins/graphlcd/fonts ]] && [[ ! -L /etc/vdr/plugins/graphlcd/fonts ]] \
+ || [[ -e /etc/vdr/plugins/graphlcd/logos ]] && [[ ! -L /etc/vdr/plugins/graphlcd/logos ]] ;then
einfo "Remove wrong DIR in /etc/vdr/plugins/graphlcd from prior install"
einfo "Press CTRL+C to abbort"