summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schwarzott <zzam@gentoo.org>2008-12-17 21:29:31 +0000
committerMatthias Schwarzott <zzam@gentoo.org>2008-12-17 21:29:31 +0000
commit65af03b6610512882ac9623d0bd24b43a9c16d4e (patch)
treeaa574bb8f1ce003c22561dbd66fd6dabe705b754 /media-plugins/vdr-mount
parentDropping ebuild that doesn't compile w/gcc-4.3 w.r.t bug 218349. (diff)
downloadgentoo-2-65af03b6610512882ac9623d0bd24b43a9c16d4e.tar.gz
gentoo-2-65af03b6610512882ac9623d0bd24b43a9c16d4e.tar.bz2
gentoo-2-65af03b6610512882ac9623d0bd24b43a9c16d4e.zip
Fix parallel-make issues, Bug #247800.
(Portage version: 2.1.6.1/cvs/Linux 2.6.27-gentoo-r1 i686)
Diffstat (limited to 'media-plugins/vdr-mount')
-rw-r--r--media-plugins/vdr-mount/ChangeLog6
-rw-r--r--media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff58
-rw-r--r--media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild4
3 files changed, 65 insertions, 3 deletions
diff --git a/media-plugins/vdr-mount/ChangeLog b/media-plugins/vdr-mount/ChangeLog
index 679f3aef08e9..1a30e0af9283 100644
--- a/media-plugins/vdr-mount/ChangeLog
+++ b/media-plugins/vdr-mount/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-plugins/vdr-mount
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-mount/ChangeLog,v 1.3 2008/12/14 16:56:37 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-mount/ChangeLog,v 1.4 2008/12/17 21:29:31 zzam Exp $
+
+ 17 Dec 2008; Matthias Schwarzott <zzam@gentoo.org>
+ +files/vdr-mount-0.0.2-makefile-fix.diff, vdr-mount-0.0.2.ebuild:
+ Fix parallel-make issues, Bug #247800.
14 Dec 2008; Joerg Bornkessel <hd_brummy@gentoo.org>
vdr-mount-0.0.2.ebuild:
diff --git a/media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff b/media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff
new file mode 100644
index 000000000000..ba2bcc437242
--- /dev/null
+++ b/media-plugins/vdr-mount/files/vdr-mount-0.0.2-makefile-fix.diff
@@ -0,0 +1,58 @@
+Index: mount-0.0.2/Makefile
+===================================================================
+--- mount-0.0.2.orig/Makefile
++++ mount-0.0.2/Makefile
+@@ -59,12 +59,12 @@ OBJS = $(subst .C,.o, $(shell ls *.C 2>/
+
+ ### Targets:
+
+-all: medialist libvdr-$(PLUGIN).so
++all: libvdr-$(PLUGIN).so
+
+ medialist:
+- cd MediaList; make
++ $(MAKE) -C MediaList
+
+-libvdr-$(PLUGIN).so: $(OBJS)
++libvdr-$(PLUGIN).so: $(OBJS) medialist
+ $(CXX) $(CXXFLAGS) -shared $(OBJS) -L MediaList/src -l MediaList -o $@
+ @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
+
+@@ -77,7 +77,7 @@ dist: clean
+ @echo Distribution package created as $(PACKAGE).tgz
+
+ clean:
+- cd MediaList; make clean
++ $(MAKE) -C MediaList clean
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~ *.d
+
+ -include *.d
+Index: mount-0.0.2/MediaList/Makefile
+===================================================================
+--- mount-0.0.2.orig/MediaList/Makefile
++++ mount-0.0.2/MediaList/Makefile
+@@ -6,18 +6,18 @@ $(subst .cxx,, $(shell cd prog; ls *.cxx
+
+
+ all:
+- export MYLIBNAME=$(LIBNAME);cd src; make
+- export PROGS=$(PROGRAMMS);cd prog; make
+- export MYLIBNAME=$(LIBNAME);export PROGS=$(PROGRAMMS);cd bin; make
++ $(MAKE) -C src MYLIBNAME=$(LIBNAME)
++ $(MAKE) -C prog PROGS=$(PROGRAMMS)
++ $(MAKE) -C bin MYLIBNAME=$(LIBNAME) PROGS=$(PROGRAMMS)
+
+ depend:
+ @echo target depend is obsolete --- just make
+
+
+ clean:
+- cd src; make clean
+- cd prog; make clean
+- export PROGS=$(PROGRAMMS);cd bin; make clean
++ $(MAKE) -C src clean
++ $(MAKE) -C prog clean
++ $(MAKE) -C bin clean PROGS=$(PROGRAMMS)
+
+
+ install:
diff --git a/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild b/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
index cb7fe5c44743..97379356c4ed 100644
--- a/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
+++ b/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild,v 1.3 2008/12/14 16:56:37 hd_brummy Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-mount/vdr-mount-0.0.2.ebuild,v 1.4 2008/12/17 21:29:31 zzam Exp $
inherit vdr-plugin
@@ -15,4 +15,4 @@ IUSE=""
DEPEND=">=media-video/vdr-1.2.6"
-BUILD_PARAMS="-j1" \ No newline at end of file
+PATCHES=("${FILESDIR}/${P}-makefile-fix.diff")