summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJörg Bornkessel <hd_brummy@gentoo.org>2013-06-30 10:30:01 +0000
committerJörg Bornkessel <hd_brummy@gentoo.org>2013-06-30 10:30:01 +0000
commitd5eb1376e33e7a7be1f86d01dec328a4f0df1a35 (patch)
treeb4ae650bc71d2c312b4e181855a6fc755c40a7f5 /media-plugins/vdr-music
parenttypo (diff)
downloadgentoo-2-d5eb1376e33e7a7be1f86d01dec328a4f0df1a35.tar.gz
gentoo-2-d5eb1376e33e7a7be1f86d01dec328a4f0df1a35.tar.bz2
gentoo-2-d5eb1376e33e7a7be1f86d01dec328a4f0df1a35.zip
bump, wrt bug 474888
(Portage version: 2.1.11.50/cvs/Linux i686, signed Manifest commit with key 34C2808A)
Diffstat (limited to 'media-plugins/vdr-music')
-rw-r--r--media-plugins/vdr-music/ChangeLog10
-rw-r--r--media-plugins/vdr-music/files/music.mk199
-rw-r--r--media-plugins/vdr-music/vdr-music-0.9.9.ebuild59
3 files changed, 266 insertions, 2 deletions
diff --git a/media-plugins/vdr-music/ChangeLog b/media-plugins/vdr-music/ChangeLog
index 107d90e47cb6..331b32083204 100644
--- a/media-plugins/vdr-music/ChangeLog
+++ b/media-plugins/vdr-music/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/vdr-music
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-music/ChangeLog,v 1.11 2010/12/31 14:43:39 hd_brummy Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-music/ChangeLog,v 1.12 2013/06/30 10:30:01 hd_brummy Exp $
+
+*vdr-music-0.9.9 (30 Jun 2013)
+
+ 30 Jun 2013; Joerg Bornkessel <hd_brummy@gentoo.org> +vdr-music-0.9.9.ebuild,
+ +files/music.mk:
+ bump, wrt bug 474888
*vdr-music-0.9.3 (31 Dec 2010)
diff --git a/media-plugins/vdr-music/files/music.mk b/media-plugins/vdr-music/files/music.mk
new file mode 100644
index 000000000000..c6aa3f1316b8
--- /dev/null
+++ b/media-plugins/vdr-music/files/music.mk
@@ -0,0 +1,199 @@
+#
+# Makefile for a Video Disk Recorder plugin
+#
+# $Id: music.mk,v 1.1 2013/06/30 10:30:01 hd_brummy Exp $
+
+# The official name of this plugin.
+# This name will be used in the '-P...' option of VDR to load the plugin.
+# By default the main source file also carries this name.
+
+PLUGIN = music
+
+### The version number of this plugin (taken from the main source file):
+
+VERSION = $(shell grep 'static const char \*VERSION *=' $(PLUGIN).c | awk '{ print $$6 }' | sed -e 's/[";]//g')
+
+### The directory environment:
+
+# Use package data if installed...otherwise assume we're under the VDR source directory:
+PKGCFG = $(if $(VDRDIR),$(shell pkg-config --variable=$(1) $(VDRDIR)/vdr.pc),$(shell pkg-config --variable=$(1) vdr || pkg-config --variable=$(1) ../../../vdr.pc))
+LIBDIR = $(call PKGCFG,libdir)
+LOCDIR = $(call PKGCFG,locdir)
+PLGCFG = $(call PKGCFG,plgcfg)
+#
+TMPDIR ?= /tmp
+
+### The compiler options:
+
+export CFLAGS = $(call PKGCFG,cflags)
+export CXXFLAGS = $(call PKGCFG,cxxflags)
+
+### The version number of VDR's plugin API:
+
+APIVERSION = $(call PKGCFG,apiversion)
+
+### Allow user defined options to overwrite defaults:
+
+-include $(PLGCFG)
+
+### The name of the distribution archive:
+
+ARCHIVE = $(PLUGIN)-$(VERSION)
+PACKAGE = vdr-$(ARCHIVE)
+
+### The name of the shared object file:
+
+SOFILE = libvdr-$(PLUGIN).so
+
+### Includes and Defines (add further entries here):
+
+# (Default) DO NOT UNCOMMENT IT IN DEVELOPER-VERSIONS
+HAVE_IMAGEMAGICK=1
+# Uncomment the following line, if you don't have libsndfile installed
+#WITHOUT_LIBSNDFILE=1
+
+# Uncomment the following line, if you don't have libvorbisfile installed
+#WITHOUT_LIBVORBISFILE=1
+
+#BROKEN_PCM=1
+# Uncomment if you want debug output on stdout
+##DEBUG=1
+
+# internal use
+# BUGHUNT
+#BUGHUNT=1
+
+# internal use
+# DEBUG_COVER
+#DEBUG_COVER=1
+
+###INCLUDES +=
+
+###DEFINES += -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+INCLUDES += -I$(VDRINCDIR)
+
+DEFINES += -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"$(PLUGIN)"'
+
+ifdef BROKEN_PCM
+ DEFINES += -DBROKEN_PCM
+endif
+
+ifeq ($(shell test -f $(VDRDIR)/fontsym.h ; echo $$?),0)
+ DEFINES += -DHAVE_BEAUTYPATCH
+endif
+
+ifdef DBG
+ CXXFLAGS += -g
+endif
+
+ifdef DEBUG
+ DEFINES += -DDEBUG
+else
+ DEFINES += -DNO_DEBUG
+endif
+
+ifdef BUGHUNT
+ DEFINES += -DBUGHUNT
+endif
+
+ifdef DEBUG_COVER
+ DEFINES += -DDEBUG_COVER
+endif
+
+### The object files (add further files here):
+
+OBJS = $(PLUGIN).o config.o vars.o bitmap.o \
+ commands.o options.o lyrics.o funct.o cover.o skin.o visual.o tracklist.o \
+ search.o mp3id3.o mp3id3tag.o rating.o menubrowse.o mp3control.o \
+ icons.o data.o menu.o \
+ data-mp3.o setup-mp3.o player-mp3.o stream.o network.o \
+ decoder.o decoder-mp3.o decoder-mp3-stream.o decoder-snd.o \
+ decoder-ogg.o
+
+LIBS += -lasound -lmad -lid3tag
+
+ifdef HAVE_IMAGEMAGICK
+ INCLUDES += $(shell pkg-config --cflags MagickCore)
+ LIBS += $(shell pkg-config --libs Magick++)
+ DEFINES += -DHAVE_IMAGEMAGICK
+else
+ INCLUDES += -I$(IMLIB)/src
+ LIBS += $(shell imlib2-config --libs)
+ DEFINES += -DHAVE_IMLIB2
+endif
+
+ifndef WITHOUT_LIBSNDFILE
+ LIBS += -lsndfile
+ DEFINES += -DHAVE_SNDFILE
+endif
+
+ifndef WITHOUT_LIBVORBISFILE
+ LIBS += -lvorbisfile -lvorbis
+ DEFINES += -DHAVE_VORBISFILE
+endif
+
+### The main target:
+
+all: $(SOFILE) i18n
+
+### Implicit rules:
+
+%.o: %.c
+ $(CXX) $(CXXFLAGS) -c $(DEFINES) $(INCLUDES) -o $@ $<
+
+### Dependencies:
+
+MAKEDEP = $(CXX) -MM -MG
+DEPFILE = .dependencies
+$(DEPFILE): Makefile
+ @$(MAKEDEP) $(CXXFLAGS) $(DEFINES) $(INCLUDES) $(OBJS:%.o=%.c) > $@
+
+-include $(DEPFILE)
+
+### Internationalization (I18N):
+
+PODIR = po
+I18Npo = $(wildcard $(PODIR)/*.po)
+I18Nmo = $(addsuffix .mo, $(foreach file, $(I18Npo), $(basename $(file))))
+I18Nmsgs = $(addprefix $(DESTDIR)$(LOCDIR)/, $(addsuffix /LC_MESSAGES/vdr-$(PLUGIN).mo, $(notdir $(foreach file, $(I18Npo), $(basename $(file))))))
+I18Npot = $(PODIR)/$(PLUGIN).pot
+
+%.mo: %.po
+ msgfmt -c -o $@ $<
+
+$(I18Npot): $(wildcard *.c)
+ xgettext -C -cTRANSLATORS --no-wrap --no-location -k -ktr -ktrNOOP --package-name=vdr-$(PLUGIN) --package-version=$(VERSION) --msgid-bugs-address='<see README>' -o $@ `ls $^`
+
+%.po: $(I18Npot)
+ msgmerge -U --no-wrap --no-location --backup=none -q -N $@ $<
+ @touch $@
+
+$(I18Nmsgs): $(DESTDIR)$(LOCDIR)/%/LC_MESSAGES/vdr-$(PLUGIN).mo: $(PODIR)/%.mo
+ install -D -m644 $< $@
+
+.PHONY: i18n
+i18n: $(I18Nmo) $(I18Npot)
+
+install-i18n: $(I18Nmsgs)
+
+### Targets:
+
+$(SOFILE): $(OBJS)
+ $(CXX) $(CXXFLAGS) $(LDFLAGS) -shared $(OBJS) -o $@
+
+install-lib: $(SOFILE)
+ install -D $^ $(DESTDIR)$(LIBDIR)/$^.$(APIVERSION)
+
+install: install-lib install-i18n
+
+dist: $(I18Npo) clean
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @mkdir $(TMPDIR)/$(ARCHIVE)
+ @cp -a * $(TMPDIR)/$(ARCHIVE)
+ @tar czf $(PACKAGE).tgz -C $(TMPDIR) $(ARCHIVE)
+ @-rm -rf $(TMPDIR)/$(ARCHIVE)
+ @echo Distribution package created as $(PACKAGE).tgz
+
+clean:
+ @-rm -f $(PODIR)/*.mo $(PODIR)/*.pot
+ @-rm -f $(OBJS) $(DEPFILE) *.so *.tgz core* *~
diff --git a/media-plugins/vdr-music/vdr-music-0.9.9.ebuild b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
new file mode 100644
index 000000000000..86ff409e063e
--- /dev/null
+++ b/media-plugins/vdr-music/vdr-music-0.9.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/vdr-music/vdr-music-0.9.9.ebuild,v 1.1 2013/06/30 10:30:01 hd_brummy Exp $
+
+EAPI="5"
+
+inherit vdr-plugin-2
+
+MY_P="${P}-dev2"
+S="${WORKDIR}/music-${PV}-dev2"
+
+DESCRIPTION="VDR plugin: music"
+HOMEPAGE="http://www.vdr.glaserei-franz.de/vdrplugins.htm"
+SRC_URI="http://www.glaserei-franz.de/VDR/Moronimo/files/${MY_P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE="+imagemagick debug graphtft sndfile vorbis"
+
+DEPEND=">=media-video/vdr-1.6.0
+ media-libs/libmad
+ media-libs/libid3tag
+ graphtft? ( media-gfx/imagemagick[png] )
+ imagemagick? ( media-gfx/imagemagick[png] )
+ sndfile? ( media-libs/libsndfile )
+ vorbis? ( media-libs/libvorbis )
+ !imagemagick? (
+ !graphtft? ( media-libs/imlib2[png] )
+ )"
+
+RDEPEND="sys-process/at
+ media-sound/id3v2
+ graphtft? ( >=media-plugins/vdr-graphtft-0.1.5 )"
+
+src_prepare() {
+ # prepare sources with new Makefile handling
+ cp ${FILESDIR}/music.mk "${S}"/Makefile
+
+ # clean up from untranslated .po files
+ rm "${S}"/po/{ca_ES,cs_CZ,da_DK,el_GR,es_ES,et_EE,fi_FI,fr_FR,hr_HR,hu_HU,it_IT,nl_NL,nn_NO,pl_PL,pt_PT,ro_RO,ru_RU,sl_SI,sv_SE,tr_TR}.po
+
+ vdr-plugin-2_src_prepare
+
+ use !vorbis && sed -i Makefile -e "s:#WITHOUT_LIBVORBISFILE=1:WITHOUT_LIBVORBISFILE=1:"
+ use !sndfile && sed -i Makefile -e "s:#WITHOUT_LIBSNDFILE=1:WITHOUT_LIBSNDFILE=1:"
+ use !debug && sed -i Makefile -e "s:DEBUG=1:#DEBUG=1:"
+ use graphtft || use imagemagick && sed -i Makefile \
+ -e "s:#HAVE_MAGICK=1:HAVE_MAGICK=1:" \
+ -e "s:#MAGICKDIR=:MAGICKDIR=:"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insinto /etc/vdr/plugins/music
+ doins -r moronsuite/music/*
+ chown -R vdr:vdr "${D}"/etc/vdr/plugins/music
+}