summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-23 18:59:00 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-23 18:59:00 +0000
commit4dc575982e92d34c8a9e25fb80a22158ff28cddc (patch)
tree27fbd024f9c2f75f6ebaae21dde7705ed9ed6758 /media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild
parentfix bugs #85151, #84915 (diff)
downloadgentoo-2-4dc575982e92d34c8a9e25fb80a22158ff28cddc.tar.gz
gentoo-2-4dc575982e92d34c8a9e25fb80a22158ff28cddc.tar.bz2
gentoo-2-4dc575982e92d34c8a9e25fb80a22158ff28cddc.zip
Remove config.cache file which got included in the tarball by upstream. Revbump, but keeping stable.
(Portage version: 2.0.51.19)
Diffstat (limited to 'media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild')
-rw-r--r--media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild b/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild
new file mode 100644
index 000000000000..9dcc23770491
--- /dev/null
+++ b/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-synaesthesia/xmms-synaesthesia-0.0.3_rc3-r1.ebuild,v 1.1 2005/03/23 18:59:00 eradicator Exp $
+
+IUSE=""
+
+inherit gnuconfig eutils
+
+MY_P=${PN#*-}-${PN%-*}-${PV/_rc/-rc}
+
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://staff.xmms.org/zinx/xmms/${MY_P}.tar.gz"
+HOMEPAGE="http://staff.xmms.org/zinx/xmms/"
+DESCRIPTION="Synaesthesia effect in a XMMS version."
+
+DEPEND="media-sound/xmms"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc sparc amd64"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gcc34.patch
+ use amd64 && epatch ${FILESDIR}/${P}-amd64.patch
+ gnuconfig_update
+
+ rm config.cache
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}