summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2012-02-06 12:54:39 +0000
committerThomas Beierlein <tomjbe@gentoo.org>2012-02-06 12:54:39 +0000
commitc636c4f69fc650076a46dabc8095b7f86c5a796b (patch)
tree8db76edea1090c2690f7c41697a184dfd795ad83 /media-radio/fldigi/fldigi-3.21.38.ebuild
parentVersion bump (diff)
downloadgentoo-2-c636c4f69fc650076a46dabc8095b7f86c5a796b.tar.gz
gentoo-2-c636c4f69fc650076a46dabc8095b7f86c5a796b.tar.bz2
gentoo-2-c636c4f69fc650076a46dabc8095b7f86c5a796b.zip
Version bump
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'media-radio/fldigi/fldigi-3.21.38.ebuild')
-rw-r--r--media-radio/fldigi/fldigi-3.21.38.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-radio/fldigi/fldigi-3.21.38.ebuild b/media-radio/fldigi/fldigi-3.21.38.ebuild
new file mode 100644
index 000000000000..204030cf76ce
--- /dev/null
+++ b/media-radio/fldigi/fldigi-3.21.38.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-radio/fldigi/fldigi-3.21.38.ebuild,v 1.1 2012/02/06 12:54:39 tomjbe Exp $
+
+EAPI=4
+
+DESCRIPTION="Sound card based multimode software modem for Amateur Radio use"
+HOMEPAGE="http://www.w1hkj.com/Fldigi.html"
+SRC_URI="http://www.w1hkj.com/downloads/fldigi/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hamlib nls portaudio pulseaudio sndfile xmlrpc"
+
+RDEPEND="x11-libs/fltk:1[threads,xft]
+ media-libs/libsamplerate
+ media-libs/libpng
+ x11-misc/xdg-utils
+ hamlib? ( media-libs/hamlib )
+ portaudio? ( >=media-libs/portaudio-19_pre20071207 )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndfile? ( >=media-libs/libsndfile-1.0.10 )
+ xmlrpc? ( || ( >=dev-libs/xmlrpc-c-1.18.02[abyss] <dev-libs/xmlrpc-c-1.18.02 )
+ dev-perl/RPC-XML
+ dev-perl/Term-ReadLine-Perl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf $(use_with sndfile) \
+ $(use_with portaudio) \
+ $(use_with hamlib) \
+ $(use_enable nls) \
+ $(use_with pulseaudio) \
+ $(use_with xmlrpc) \
+ --without-asciidoc
+}