summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-01-07 17:40:29 +0000
committerMichael Januszewski <spock@gentoo.org>2006-01-07 17:40:29 +0000
commit2a8b413dad46bfb526e9eb764f2a88be9de1989b (patch)
tree2e3931d1f1af8f5863435e5a550cffe583f58961 /media-sound/adplay
parentdepend on gentoo-vdr-scripts added, support for EN and DE Lang conf works now... (diff)
downloadgentoo-2-2a8b413dad46bfb526e9eb764f2a88be9de1989b.tar.gz
gentoo-2-2a8b413dad46bfb526e9eb764f2a88be9de1989b.tar.bz2
gentoo-2-2a8b413dad46bfb526e9eb764f2a88be9de1989b.zip
Added a simple hack to make adplay compile with libbinio 1.4+.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'media-sound/adplay')
-rw-r--r--media-sound/adplay/ChangeLog9
-rw-r--r--media-sound/adplay/adplay-1.4-r1.ebuild33
-rw-r--r--media-sound/adplay/files/digest-adplay-1.4-r11
3 files changed, 41 insertions, 2 deletions
diff --git a/media-sound/adplay/ChangeLog b/media-sound/adplay/ChangeLog
index 50a2e5fe7bbf..6bc6e8a41754 100644
--- a/media-sound/adplay/ChangeLog
+++ b/media-sound/adplay/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/adplay
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/ChangeLog,v 1.5 2004/11/11 10:09:58 eradicator Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/ChangeLog,v 1.6 2006/01/07 17:40:29 spock Exp $
+
+*adplay-1.4-r1 (07 Jan 2006)
+
+ 07 Jan 2006; Michał Januszewski <spock@gentoo.org> +adplay-1.4-r1.ebuild:
+ Added a simple hack to make adplay compile with libbinio 1.4+.
11 Nov 2004; Jeremy Huddleston <eradicator@gentoo.org> adplay-1.4.ebuild:
Stable amd64, sparc, x86.
diff --git a/media-sound/adplay/adplay-1.4-r1.ebuild b/media-sound/adplay/adplay-1.4-r1.ebuild
new file mode 100644
index 000000000000..17eee17aeb2c
--- /dev/null
+++ b/media-sound/adplay/adplay-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/adplay/adplay-1.4-r1.ebuild,v 1.1 2006/01/07 17:40:29 spock Exp $
+
+IUSE="oss esd sdl"
+
+DESCRIPTION="A console player for AdLib music"
+HOMEPAGE="http://adplug.sourceforge.net/"
+SRC_URI="mirror://sourceforge/adplug/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=media-libs/adplug-1.4.1"
+
+src_compile() {
+ local myconf
+
+ use oss || myconf="${myconf} --disable-output-oss"
+ use esd || myconf="${myconf} --disable-output-esound"
+ use sdl || myconf="${myconf} --disable-output-sdl"
+
+ # A simple hack to make adplay work with libbinio 1.4+
+ export CXXFLAGS="${CXXFLAGS} -I/usr/include/libbinio"
+
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+}
diff --git a/media-sound/adplay/files/digest-adplay-1.4-r1 b/media-sound/adplay/files/digest-adplay-1.4-r1
new file mode 100644
index 000000000000..2e4d5602c5fb
--- /dev/null
+++ b/media-sound/adplay/files/digest-adplay-1.4-r1
@@ -0,0 +1 @@
+MD5 d656103e456a244f8e279dd78fa327e0 adplay-1.4.tar.bz2 243047