summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-19 14:04:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-19 14:04:46 +0000
commit31062d29a00774d4f7f9a4a68b389f1b2bad75e8 (patch)
treebb963459fae805844b91f9871c689f899d814bee /media-sound/aeolus/aeolus-0.8.1.ebuild
parentAdded patch to make package compile again including gcc-4.3 (fixes bug #205223). (diff)
downloadgentoo-2-31062d29a00774d4f7f9a4a68b389f1b2bad75e8.tar.gz
gentoo-2-31062d29a00774d4f7f9a4a68b389f1b2bad75e8.tar.bz2
gentoo-2-31062d29a00774d4f7f9a4a68b389f1b2bad75e8.zip
version bump
(Portage version: 2.1.5_rc4)
Diffstat (limited to 'media-sound/aeolus/aeolus-0.8.1.ebuild')
-rw-r--r--media-sound/aeolus/aeolus-0.8.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/aeolus/aeolus-0.8.1.ebuild b/media-sound/aeolus/aeolus-0.8.1.ebuild
new file mode 100644
index 000000000000..35d0fc4dbc45
--- /dev/null
+++ b/media-sound/aeolus/aeolus-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aeolus/aeolus-0.8.1.ebuild,v 1.1 2008/04/19 14:04:46 aballier Exp $
+
+inherit versionator toolchain-funcs multilib
+
+MY_P=${PN}-$(replace_version_separator 3 '-')
+
+DESCRIPTION="A synthesised pipe organ emulator"
+HOMEPAGE="http://www.kokkinizita.net/linuxaudio/aeolus/index.html"
+SRC_URI="http://www.kokkinizita.net/linuxaudio/downloads/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=media-libs/libclalsadrv-1.2.2
+ >=media-libs/libclthreads-2.2.1
+ >=media-libs/libclxclient-3.3.2
+ x11-libs/libXft
+ x11-libs/libX11
+ >=media-sound/jack-audio-connection-kit-0.109.2
+ media-libs/alsa-lib
+ sys-libs/readline"
+
+RDEPEND="${DEPEND}
+ media-libs/stops"
+
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+
+src_compile() {
+ tc-export CXX
+ sed -i -e "s/-O3//" Makefile || die "Failed to remove forced CFLAGS"
+ sed -i -e "s:/sbin/ldconfig:true:" Makefile || die "Failed to remove ldconfig call CFLAGS"
+ sed -i -e "s/g++/$(tc-getCXX)/" Makefile || die "Failed to set correct compiler"
+ emake PREFIX="/usr" LIBDIR=$(get_libdir) || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake PREFIX="${D}/usr" install || die "make install failed"
+ dodoc README AUTHORS
+ echo "-S /usr/share/stops" > "${T}/aeolus.conf"
+ insinto /etc
+ doins "${T}/aeolus.conf"
+}