summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-05-24 01:10:35 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-05-24 01:10:35 +0000
commit66780385157f6d90626715441d94f1bde234b9c8 (patch)
tree955ce3ee8cd2bb6e843d145a28ddcb21f41c21a9 /media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
parentmodified digest (diff)
downloadgentoo-2-66780385157f6d90626715441d94f1bde234b9c8.tar.gz
gentoo-2-66780385157f6d90626715441d94f1bde234b9c8.tar.bz2
gentoo-2-66780385157f6d90626715441d94f1bde234b9c8.zip
Aliased /dev/dsp and /dev/mixer to respective OSS emulation modules.
Diffstat (limited to 'media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild')
-rw-r--r--media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
new file mode 100644
index 000000000000..9ea746bdaa59
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-0.9.0_rc1-r7.ebuild,v 1.1 2002/05/24 01:10:35 agenkin Exp $
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+
+# By default, drivers for all supported cards will be compiled.
+# If you want to only compile for specific card(s), set ALSA_CARDS
+# environment variable accordingly
+[ x${ALSA_CARDS} = x ] && ALSA_CARDS=all
+
+SRC_URI="ftp://ftp.alsa-project.org/pub/driver/${P/_rc/rc}.tar.bz2"
+S=${WORKDIR}/${P/_rc/rc}
+
+# Need the baselayout 1.7.9 or newer for the init script to work correctly.
+DEPEND="sys-devel/autoconf
+ virtual/glibc
+ >=sys-apps/portage-1.9.10
+ >=sys-apps/baselayout-1.7.9"
+RDEPEND="${DEPEND}"
+PROVIDE="virtual/alsa"
+
+src_unpack() {
+ # Some *broken* Gentoo packages install stuff in /etc/rc.d/init.d
+ # instead of /etc/init.d. However, this causes alsa's installer
+ # to do the same foolish thing. This *hack* inibits the problem.
+ # I filed a bug report about this with the ALSA people:
+ # http://sourceforge.net/tracker/?func=detail&aid=551668&group_id=27464&atid=390601
+ unpack ${A}
+ cd ${S}
+ sed -e 's:/etc/rc.d/init.d:/etc/init.d:' < Makefile > Makefile.hacked
+ mv Makefile.hacked Makefile
+}
+
+
+src_compile() {
+ # Portage should determine the version of the kernel sources
+ check_KV
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --with-kernel="${ROOT}usr/src/linux" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-oss=yes \
+ --with-cards=${ALSA_CARDS} \
+ || die "./configure failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+
+src_install () {
+ dodir /usr/include/sound
+ dodir /etc/init.d
+ make DESTDIR=${D} install || die
+
+ dodoc CARDS-STATUS COPYING FAQ INSTALL README WARNING TODO doc/*
+
+ insinto /etc/modules.d
+ newins ${FILESDIR}/alsa-modules.conf alsa
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/alsasound
+}
+
+pkg_postinst () {
+ if [ "${ROOT}" = / ]
+ then
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+ fi
+
+ einfo
+ einfo "You might want to edit file /etc/modules.d/alsa according to your"
+ einfo "hardware configuration."
+ einfo
+ einfo "If you are going to be using the 'alsasound' init script, make sure"
+ einfo "that you add it to the 'boot' runlevel (not 'default')."
+ einfo
+}