summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-08 11:12:57 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-08 11:12:57 +0000
commite32dcb491e631da9e91bcc08f8a981ab4cde129e (patch)
tree3c018066d930e5ba00a55a7dbdd0c8e0839f116c /media-sound/alsa-driver
parentFix javadoc install location wrt bug #160835 by Alistair Bush <alistair.bush@... (diff)
downloadgentoo-2-e32dcb491e631da9e91bcc08f8a981ab4cde129e.tar.gz
gentoo-2-e32dcb491e631da9e91bcc08f8a981ab4cde129e.tar.bz2
gentoo-2-e32dcb491e631da9e91bcc08f8a981ab4cde129e.zip
Merged changes from 1.0.14_rc1.
(Portage version: 2.1.2_rc4-r5)
Diffstat (limited to 'media-sound/alsa-driver')
-rw-r--r--media-sound/alsa-driver/ChangeLog6
-rw-r--r--media-sound/alsa-driver/alsa-driver-9999.ebuild87
2 files changed, 63 insertions, 30 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 88249d57c256..5ba67bea26d4 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.252 2007/01/06 20:12:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.253 2007/01/08 11:12:57 betelgeuse Exp $
+
+ 08 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+ alsa-driver-9999.ebuild:
+ Merged changes from 1.0.14_rc1.
06 Jan 2007; Diego Pettenò <flameeyes@gentoo.org>
alsa-driver-9999.ebuild:
diff --git a/media-sound/alsa-driver/alsa-driver-9999.ebuild b/media-sound/alsa-driver/alsa-driver-9999.ebuild
index 62e4abee7d09..96f3d98df69c 100644
--- a/media-sound/alsa-driver/alsa-driver-9999.ebuild
+++ b/media-sound/alsa-driver/alsa-driver-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-9999.ebuild,v 1.4 2007/01/06 20:12:15 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-9999.ebuild,v 1.5 2007/01/08 11:12:57 betelgeuse Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -16,10 +16,30 @@ SLOT="0"
KEYWORDS="-*"
IUSE="oss doc debug"
+IUSE_CARDS="seq-dummy dummy virmidi mtpav mts64 serial-u16550 mpu401 loopback
+portman2x4 pcsp ad1848-lib cs4231-lib adlib ad1816a ad1848 als100 azt2320 cmi8330
+cs4231 cs4232 cs4236 dt019x es968 es1688 es18xx gusclassic gusextreme gusmax
+interwave interwave-stb opl3sa2 opti92x-ad1848 opti92x-cs4231 opti93x miro
+sb8 sb16 sbawe sgalaxy sscape wavefront pc98-cs4232 msnd-pinnacle ad1889 als300
+als4000 ali5451 atiixp atiixp-modem au8810 au8820 au8830 azt3328 bt87x ca0106 cmipci
+cs4281 cs46xx cs5535audio darla20 gina20 layla20 darla24 gina24 layla24 mona mia
+echo3g indigo indigoio indigodj emu10k1 emu10k1x ens1370 ens1371 es1938 es1968
+fm801 fm801-tea575x hda-intel hdsp hdspm ice1712 ice1724 intel8x0 intel8x0m korg1212
+maestro3 mixart nm256 pcxhr riptide rme32 rme96 rme9652 sonicvibes trident via82xx
+via82xx-modem vx222 ymfpci pdplus asihpi powermac aoa aoa-fabric-layout aoa-onyx
+aoa-tas aoa-toonie aoa-soundbus aoa-soundbus-i2s sa11xx-uda1341 armaaci
+s3c2410 pxa2xx-i2sound au1x00 usb-audio usb-usx2y vxpocket pdaudiocf sun-amd7930
+sun-cs4231 sun-dbri harmony soc at91-soc at91-soc-eti-b1-wm8731 pxa2xx-soc
+pxa2xx-soc-corgi pxa2xx-soc-spitz pxa2xx-soc-poodle pxa2xx-soc-tosa"
+
+for iuse_card in ${IUSE_CARDS}; do
+ IUSE="${IUSE} alsa_cards_${iuse_card}"
+done
+
RDEPEND="virtual/modutils
- ~media-sound/alsa-headers-${PV}
!media-sound/snd-aoa"
DEPEND="${RDEPEND}
+ ~media-sound/alsa-headers-${PV}
virtual/linux-sources
sys-apps/debianutils"
@@ -35,28 +55,40 @@ pkg_setup() {
#
# env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
#
- ALSA_CARDS=${ALSA_CARDS:-all}
+ ALSA_CARDS=${ALSA_CARDS:-${IUSE_ALSA_CARDS}}
# Which drivers need PNP
local PNP_DRIVERS="interwave interwave-stb"
-
- CONFIG_CHECK="SOUND"
- SND_ERROR="ALSA is already compiled into the kernel."
- SOUND_ERROR="Your kernel doesn't have sound support enabled."
- SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
- PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
-
- if [[ "${ALSA_CARDS}" == "all" ]]; then
-
- # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
- if [[ ${ARCH} != "ppc" ]]; then
- CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ local PNP_ERROR="Some of the drivers you selected require PnP support in your kernel (${PNP_DRIVERS}). Either enable PnP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ local ISA_DRIVERS="cs4232 msnd-pinnacle cs4231-lib adlib ad1816a ad1848 als100 azt2320
+ cmi8330 cs4231 cs4236 dt019x es968 es1688 es18xx gusclassic gusextreme gusmax
+ interwave interwave-stb opl3sa2 opti92x-ad1848 opti92x-cs4231 opti93x miro sb8
+ sb16 sbawe sb16_csp sgalaxy sscape wavefront"
+ local ISA_ERROR="Some of the drivers you selected require ISA support in your kernel ($(echo $ISA_DRIVERS)). Either enable ISA in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ local FW_DRIVERS="darla20 gina20 layla20 darla24 gina24 layla24 mona mia echo3g indigo
+ indigoio indigodj emu10k1 korg1212 maestro3 riptide ymfpci asihpi"
+ local FW_LOADER_ERROR="Some of the drivers you selected require 'Userspace firmware loading support' in your kernel (${FW_DRIVERS}). Either enable that feature or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ local TMP_ALSA_CARDS
+ local CHECK_PNP
+ local CHECK_ISA
+ local CHECK_FW
+ for card in ${ALSA_CARDS}; do
+ if has alsa_cards_${card} ${IUSE} && use alsa_cards_${card}; then
+ TMP_ALSA_CARDS="${TMP_ALSA_CARDS} ${card}"
+ has ${card} ${PNP_DRIVERS} && CHECK_PNP="PNP"
+ has ${card} ${ISA_DRIVERS} && CHECK_ISA="ISA"
+ has ${card} ${FW_DRIVERS} && CHECK_FW="FW_LOADER"
fi
- else
- for pnpdriver in ${PNP_DRIVERS}; do
- hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
- done
- fi
+ done
+ ALSA_CARDS="${TMP_ALSA_CARDS}"
+
+ local CONFIG_CHECK="!SND SOUND ${CHECK_PNP} ${CHECK_ISA} ${CHECK_FW}"
+ local SND_ERROR="ALSA is already compiled into the kernel."
+ local SOUND_ERROR="Your kernel doesn't have sound support enabled."
+ local SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
linux-mod_pkg_setup
@@ -117,7 +149,7 @@ src_compile() {
src_install() {
- emake DESTDIR=${D} install-modules || die "make install failed"
+ emake DESTDIR="${D}" install-modules || die "make install failed"
dodoc CARDS-STATUS FAQ README WARNING TODO
@@ -136,8 +168,8 @@ src_install() {
if kernel_is 2 6; then
# mv the drivers somewhere they won't be killed by the kernel's make modules_install
- mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
- rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
+ mv "${D}/lib/modules/${KV_FULL}/kernel/sound" "${D}/lib/modules/${KV_FULL}/${PN}"
+ rmdir "${D}/lib/modules/${KV_FULL}/kernel" &> /dev/null
fi
}
@@ -148,7 +180,6 @@ pkg_postinst() {
elog "Also, remember that all mixer channels will be MUTED by default."
elog "Use the 'alsamixer' program to unmute them."
elog
- elog "Version 1.0.3 and above should work with version 2.6 kernels."
elog "If you experience problems, please report bugs to http://bugs.gentoo.org."
elog
@@ -157,14 +188,12 @@ pkg_postinst() {
elog "Check out the ALSA installation guide availible at the following URL:"
elog "http://www.gentoo.org/doc/en/alsa-guide.xml"
- if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
+ if kernel_is 2 6 && [ -e "${ROOT}/lib/modules/${KV_FULL}/kernel/sound" ]; then
# Cleanup if they had older alsa installed
- for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
+ for file in $(find "${ROOT}/lib/modules/${KV_FULL}/${PN}" -type f); do
rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
done
- for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
- rmdir ${dir} &> /dev/null
- done
+ find "${ROOT}/lib/modules/${KV_FULL}/kernel/sound" -type d -print0 | xargs rmdir
fi
}