summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2008-08-02 21:00:32 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2008-08-02 21:00:32 +0000
commit0ad51d886303554e5ae33162e1aeb2dbea26a18c (patch)
treecde816de770dfefa308180e72e706ec7c1f4b939 /media-sound/alsa-utils
parentVersion bump. Fixes bug #227043. Thanks to chutzpah for the help. (diff)
downloadgentoo-2-0ad51d886303554e5ae33162e1aeb2dbea26a18c.tar.gz
gentoo-2-0ad51d886303554e5ae33162e1aeb2dbea26a18c.tar.bz2
gentoo-2-0ad51d886303554e5ae33162e1aeb2dbea26a18c.zip
Version bump. Fixes bug #227043. Thanks to chutzpah for the help.
(Portage version: 2.2_rc4/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog12
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.17.ebuild95
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.17-seq.patch40
3 files changed, 144 insertions, 3 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 471761e559f2..c15b24b042d2 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.241 2008/06/05 07:43:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.242 2008/08/02 21:00:32 betelgeuse Exp $
+
+*alsa-utils-1.0.17 (02 Aug 2008)
+
+ 02 Aug 2008; Petteri Räty <betelgeuse@gentoo.org>
+ +files/alsa-utils-1.0.17-seq.patch, +alsa-utils-1.0.17.ebuild:
+ Version bump. Fixes bug #227043. Thanks to chutzpah for the help.
05 Jun 2008; Raúl Porcel <armin76@gentoo.org> alsa-utils-1.0.16.ebuild:
ia64 stable
@@ -930,9 +936,9 @@
11 Jul 2003; Arcady Genkin <agenkin@gentoo.org> :
Version update.
-*alsa-utils-0.9.4 (03 June 2003)
+*alsa-utils-0.9.4 (03 Jun 2003)
- 03 June 2003; Arcady Genkin <agenkin@gentoo.org> :
+ 03 Jun 2003; Arcady Genkin <agenkin@gentoo.org> :
Version update.
*alsa-utils-0.9.3 (04 May 2003)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.17.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.17.ebuild
new file mode 100644
index 000000000000..0c8321b928ec
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.17.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.17.ebuild,v 1.1 2008/08/02 21:00:32 betelgeuse Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls midi minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}"
+RDEPEND="${DEPEND}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use midi && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror ""
+ eerror "To be able to build alsa-utils with midi support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+ epatch "${FILESDIR}/${PN}-1.0.14-alsaconf-modules-update.patch"
+ epatch "${FILESDIR}/${PN}-1.0.17-seq.patch"
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_compile() {
+ econf $(use_enable nls) \
+ $(use_enable midi sequencer) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+pkg_preinst() {
+ if [[ -a /etc/modules.d/alsa ]] && [[ ! -a /etc/modprobe.d/alsa ]]; then
+ elog "Moving old alsa configuration in modules.d to new"
+ elog "location in modprobe.d in /etc/"
+ mv "${ROOT}/etc/modules.d/alsa" "${ROOT}/etc/modprobe.d/alsa"
+ fi
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+ newdoc alsamixer/README README.alsamixer || die
+
+ newinitd "${FILESDIR}/alsasound.initd" alsasound
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "loading and unloading the ALSA sound drivers as well as"
+ elog "storing and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.17-seq.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.17-seq.patch
new file mode 100644
index 000000000000..3214a01b29ee
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.17-seq.patch
@@ -0,0 +1,40 @@
+diff -ur alsa-utils-1.0.17.orig/configure.in alsa-utils-1.0.17/configure.in
+--- alsa-utils-1.0.17.orig/configure.in 2008-07-30 21:44:32.000000000 -0400
++++ alsa-utils-1.0.17/configure.in 2008-07-30 21:45:45.000000000 -0400
+@@ -102,6 +102,18 @@
+ TESTSOUND="$dir/test.wav")
+ AC_SUBST(TESTSOUND)
+
++AC_ARG_ENABLE([sequencer],
++ [AC_HELP_STRING([--disable-sequencer], [Disable sequencer utilities (aconnect, aplaymidi, aseqdump, aseqnet)])] )
++
++if test "x$enable_sequencer" != "xno"; then
++ AC_CHECK_LIB([asound], [snd_seq_open], [has_seq=yes], [has_seq=no])
++fi
++if test "x$enable_sequencer" = "xyes" && test "x$has_seq" = "xno"; then
++ AC_MSG_FAILURE([cannot find snd_seq_open. ALSA was built without sequencer support])
++fi
++
++AM_CONDITIONAL([BUILD_SEQ], [test "x$has_seq" = "xyes"])
++
+ AM_CONFIG_HEADER(include/aconfig.h)
+
+ dnl Checks for typedefs, structures, and compiler characteristics.
+Only in alsa-utils-1.0.17: configure.in.orig
+diff -ur alsa-utils-1.0.17.orig/Makefile.am alsa-utils-1.0.17/Makefile.am
+--- alsa-utils-1.0.17.orig/Makefile.am 2008-07-30 21:44:32.000000000 -0400
++++ alsa-utils-1.0.17/Makefile.am 2008-07-30 21:47:04.000000000 -0400
+@@ -4,7 +4,12 @@
+ else
+ ALSAMIXER_DIR=
+ endif
+-SUBDIRS= include alsactl alsaconf $(ALSAMIXER_DIR) amidi amixer aplay iecset seq speaker-test utils m4 po
++
++if BUILD_SEQ
++SEQ_DIR=seq
++endif
++
++SUBDIRS= include alsactl alsaconf $(ALSAMIXER_DIR) amidi amixer aplay iecset $(SEQ_DIR) speaker-test utils m4 po
+ EXTRA_DIST= config.rpath config.rpath mkinstalldirs ChangeLog INSTALL TODO README configure gitcompile depcomp
+ AUTOMAKE_OPTIONS=foreign
+ ACLOCAL_AMFLAGS = -I m4