summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-09-07 11:57:12 +0000
committerPacho Ramos <pacho@gentoo.org>2010-09-07 11:57:12 +0000
commit1b35189b0278d761ec722f0c292dcecac28cc12a (patch)
tree715663f7f4e3fa3c288635aeccfa05f479a13e0f /media-sound/alsa-utils
parentRespect LDFLAGS wrt bug 336348. Thanks to Diego for the report. Add proper pt... (diff)
downloadgentoo-2-1b35189b0278d761ec722f0c292dcecac28cc12a.tar.gz
gentoo-2-1b35189b0278d761ec722f0c292dcecac28cc12a.tar.bz2
gentoo-2-1b35189b0278d761ec722f0c292dcecac28cc12a.zip
Revision bump to fix bug #299362 following upstream indications and applying upstream patches that will be included in 1.0.24.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog10
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.23-r1.ebuild105
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output.patch15
-rw-r--r--media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output2.patch15
4 files changed, 144 insertions, 1 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 41b40b73fcc2..29537d50eba3 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.295 2010/04/16 22:21:09 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.296 2010/09/07 11:57:12 pacho Exp $
+
+*alsa-utils-1.0.23-r1 (07 Sep 2010)
+
+ 07 Sep 2010; Pacho Ramos <pacho@gentoo.org> +alsa-utils-1.0.23-r1.ebuild,
+ +files/alsa-utils-1.0.23-alsactl-output.patch,
+ +files/alsa-utils-1.0.23-alsactl-output2.patch:
+ Revision bump to fix bug #299362 following upstream indications and
+ applying upstream patches that will be included in 1.0.24.
*alsa-utils-1.0.23 (16 Apr 2010)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.23-r1.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.23-r1.ebuild
new file mode 100644
index 000000000000..474ea26befbf
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.23-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.23-r1.ebuild,v 1.1 2010/09/07 11:57:12 pacho Exp $
+
+EAPI=2
+inherit eutils
+
+MY_P=${P/_rc/rc}
+ALSA_DRIVER_VER="1.0.23"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2
+ mirror://alsaproject/driver/alsa-driver-${ALSA_DRIVER_VER}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="doc nls minimal"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ doc? ( app-text/xmlto )"
+RDEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-${PV}
+ virtual/modutils
+ !minimal? ( sys-apps/pciutils )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if [[ -e "${ROOT}etc/modules.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modules.d/alsa found."
+ die "Move /etc/modules.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+
+ if [[ -e "${ROOT}etc/modprobe.d/alsa" ]]; then
+ eerror "Obsolete config /etc/modprobe.d/alsa found."
+ die "Move /etc/modprobe.d/alsa to /etc/modprobe.d/alsa.conf."
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-modprobe.d.patch
+
+ # Exit code 99 will be the same than 0 for us per bug #299362 as suggested
+ # by upstream: http://www.spinics.net/lists/alsa-devel/msg31430.html
+ sed -i -e 's/EXIT="99"/EXIT="0"/g' alsactl/init/00main || die
+
+ # Apply upstream patches to clarify initialization
+ epatch "${FILESDIR}/${P}-alsactl-output.patch"
+ epatch "${FILESDIR}/${P}-alsactl-output2.patch"
+}
+
+src_configure() {
+ local myconf=""
+ use doc || myconf="--disable-xmlto"
+
+ econf ${myconf} \
+ $(use_enable nls)
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ${ALSA_UTILS_DOCS} || die
+
+ newbin "${WORKDIR}/alsa-driver-${ALSA_DRIVER_VER}/utils/alsa-info.sh" \
+ alsa-info
+
+ newinitd "${FILESDIR}/alsasound.initd-r4" alsasound
+ newconfd "${FILESDIR}/alsasound.confd-r3" alsasound
+ insinto /etc/modprobe.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa.conf
+
+ keepdir /var/lib/alsa
+}
+
+pkg_postinst() {
+ echo
+ elog "To take advantage of the init script, and automate the process of"
+ elog "saving and restoring sound-card mixer levels you should"
+ elog "add alsasound to the boot runlevel. You can do this as"
+ elog "root like so:"
+ elog " # rc-update add alsasound boot"
+ echo
+ elog "The script will load ALSA modules, if you choose to use a modular"
+ elog "configuration. The Gentoo ALSA developers recommend you to build"
+ elog "your audio drivers into the kernel unless the device is hotpluggable"
+ elog "or you need to supply specific options (such as model= to HD Audio)."
+ echo
+ ewarn "Automated unloading of ALSA modules is deprecated and unsupported."
+ ewarn "Should you choose to use it, bug reports will not be accepted."
+ echo
+ if use minimal; then
+ ewarn "The minimal use flag disables the dependency on pciutils that"
+ ewarn "is needed by alsaconf at runtime."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output.patch
new file mode 100644
index 000000000000..40e76d8dd3ed
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output.patch
@@ -0,0 +1,15 @@
+X-Git-Url: http://git.alsa-project.org/?p=alsa-utils.git;a=blobdiff_plain;f=alsactl%2Finit%2F00main;fp=alsactl%2Finit%2F00main;h=fb7f02cecabdc363bfb47ccdd6141415aa904f65;hp=2d26bbf1b8ff8f29a311e2fc4df25592e48fd3a0;hb=dcb90a779e74315596a4cdb4741983b21cba69c9;hpb=bb865dc10b6dcee9d428d3c5a17ee312e0aaf7e0
+
+diff --git a/alsactl/init/00main b/alsactl/init/00main
+index 2d26bbf..fb7f02c 100644
+--- a/alsactl/init/00main
++++ b/alsactl/init/00main
+@@ -37,7 +37,7 @@ CARDINFO{driver}=="Test", INCLUDE="test", GOTO="init_end"
+ LABEL="init_end"
+ ACCESS=="postinit", INCLUDE="postinit"
+ RESULT=="true", GOTO="00_mainend"
+-ERROR="Unknown hardware: \"$cardinfo{driver}\" \"$cardinfo{mixername}\" \"$cardinfo{components}\" \"$attr{subsystem_vendor}\" \"$attr{subsystem_device}\"\n"
++ERROR="Found hardware: \"$cardinfo{driver}\" \"$cardinfo{mixername}\" \"$cardinfo{components}\" \"$attr{subsystem_vendor}\" \"$attr{subsystem_device}\"\n"
+ ERROR="Hardware is initialized using a guess method\n"
+ INCLUDE="default"
+ EXIT="99"
diff --git a/media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output2.patch b/media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output2.patch
new file mode 100644
index 000000000000..e062c942b74b
--- /dev/null
+++ b/media-sound/alsa-utils/files/alsa-utils-1.0.23-alsactl-output2.patch
@@ -0,0 +1,15 @@
+X-Git-Url: http://git.alsa-project.org/?p=alsa-utils.git;a=blobdiff_plain;f=alsactl%2Finit%2F00main;fp=alsactl%2Finit%2F00main;h=660df389f3339688b0baabe3af1533fe5ced2647;hp=fb7f02cecabdc363bfb47ccdd6141415aa904f65;hb=7f6a55e203e2bb069c35006b605e1a19cfcd88cb;hpb=dcb90a779e74315596a4cdb4741983b21cba69c9
+
+diff --git a/alsactl/init/00main b/alsactl/init/00main
+index fb7f02c..660df38 100644
+--- a/alsactl/init/00main
++++ b/alsactl/init/00main
+@@ -38,7 +38,7 @@ LABEL="init_end"
+ ACCESS=="postinit", INCLUDE="postinit"
+ RESULT=="true", GOTO="00_mainend"
+ ERROR="Found hardware: \"$cardinfo{driver}\" \"$cardinfo{mixername}\" \"$cardinfo{components}\" \"$attr{subsystem_vendor}\" \"$attr{subsystem_device}\"\n"
+-ERROR="Hardware is initialized using a guess method\n"
++ERROR="Hardware is initialized using a generic method\n"
+ INCLUDE="default"
+ EXIT="99"
+