summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Dibb <beandog@gentoo.org>2008-05-15 18:16:18 +0000
committerSteve Dibb <beandog@gentoo.org>2008-05-15 18:16:18 +0000
commit65b411e50eff2164c2874488ab597894e9cb0c52 (patch)
tree6f8f465f0267036da0c1b82a11cbd4337dc56d73 /media-sound/alsa-utils
parentUse $ROOT for install of modprobe file (diff)
downloadgentoo-2-65b411e50eff2164c2874488ab597894e9cb0c52.tar.gz
gentoo-2-65b411e50eff2164c2874488ab597894e9cb0c52.tar.bz2
gentoo-2-65b411e50eff2164c2874488ab597894e9cb0c52.zip
Add conf.d option to terminate processes in init script, bug 222267
(Portage version: 2.1.5)
Diffstat (limited to 'media-sound/alsa-utils')
-rw-r--r--media-sound/alsa-utils/ChangeLog6
-rw-r--r--media-sound/alsa-utils/files/alsasound.confd9
-rw-r--r--media-sound/alsa-utils/files/alsasound.initd10
3 files changed, 20 insertions, 5 deletions
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 6952980d93fc..44ccefc62983 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.235 2008/05/15 18:14:41 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.236 2008/05/15 18:16:18 beandog Exp $
+
+ 15 May 2008; Steve Dibb <beandog@gentoo.org> files/alsasound.confd,
+ files/alsasound.initd:
+ Add conf.d option to terminate processes in init script, bug 222267
15 May 2008; Steve Dibb <beandog@gentoo.org> alsa-utils-1.0.16-r2.ebuild:
Use $ROOT for install of modprobe file
diff --git a/media-sound/alsa-utils/files/alsasound.confd b/media-sound/alsa-utils/files/alsasound.confd
index 0d63dcfe647b..9f4e2cd76d44 100644
--- a/media-sound/alsa-utils/files/alsasound.confd
+++ b/media-sound/alsa-utils/files/alsasound.confd
@@ -32,3 +32,12 @@ LOAD_ON_START="yes"
# no - Do not unload modules
# yes - Unload modules
UNLOAD_ON_STOP="yes"
+
+# KILLPROC_ON_STOP
+# Do you want to kill any processes using ALSA when alsasound stops?
+# Warning: may create some unexpected window behavior or
+# crash running applications.
+# Also, if you are not using modules, it is safe to disable this.
+# no - Do not terminate ALSA processes
+# yes - Kill running processes using ALSA
+KILLPROC_ON_STOP="yes"
diff --git a/media-sound/alsa-utils/files/alsasound.initd b/media-sound/alsa-utils/files/alsasound.initd
index ac0a169a5cda..e3eb3c94880b 100644
--- a/media-sound/alsa-utils/files/alsasound.initd
+++ b/media-sound/alsa-utils/files/alsasound.initd
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound.initd,v 1.6 2007/12/29 06:37:59 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/files/alsasound.initd,v 1.7 2008/05/15 18:16:18 beandog Exp $
# Copyright 2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
@@ -214,9 +214,11 @@ stop() {
[ "${SAVE_ON_STOP}" = "yes" ] && save
- ebegin "Killing processes using ALSA"
- terminate
- eend 0
+ if [ "${KILLPROC_ON_STOP}" = "yes" ] ; then
+ ebegin "Killing processes using ALSA"
+ terminate
+ eend 0
+ fi
if [ -f /proc/modules ] && [ "${UNLOAD_ON_STOP}" = "yes" ]; then
local ver="24"