summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-08-30 09:37:04 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-08-30 09:37:04 +0000
commit95a37c020799dcb74770d7702a1becd956182cd2 (patch)
tree7e4b2f36e6d5cbe9b258830f9390c06f99b79fb0 /media-sound/amsynth/amsynth-1.2.3-r1.ebuild
parentversion bump (diff)
downloadgentoo-2-95a37c020799dcb74770d7702a1becd956182cd2.tar.gz
gentoo-2-95a37c020799dcb74770d7702a1becd956182cd2.tar.bz2
gentoo-2-95a37c020799dcb74770d7702a1becd956182cd2.zip
Revision bump for EAPI 4 porting and CFLAGS respect patch by Markos "hwoarang" Chandros with input from Samuli Suominen in bug #376665 filed by Agostino "ago" Sarubbo.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/amsynth/amsynth-1.2.3-r1.ebuild')
-rw-r--r--media-sound/amsynth/amsynth-1.2.3-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-sound/amsynth/amsynth-1.2.3-r1.ebuild b/media-sound/amsynth/amsynth-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..60c86b1f3468
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.2.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/amsynth/amsynth-1.2.3-r1.ebuild,v 1.1 2011/08/30 09:37:04 chainsaw Exp $
+
+EAPI=4
+
+inherit base autotools
+
+MY_P=${P/ams/amS}
+DESCRIPTION="Virtual analogue synthesizer."
+HOMEPAGE="http://amsynthe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/amsynthe/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa debug jack oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1 )
+ alsa? ( media-libs/alsa-lib
+ media-sound/alsa-utils )
+ jack? ( media-sound/jack-audio-connection-kit )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-respect-cflags.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with sndfile) \
+ $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog
+ elog "amSynth has been installed normally. If you would like to use"
+ elog "the virtual keyboard option, then do:"
+ elog "# emerge vkeybd"
+ elog "and make sure you emerged amSynth with alsa support (USE=alsa)"
+ elog
+}